Trisquel 8.0 : Abrowser 59.0.2 fail to install the plugin 'Privacy Badger' (EFF)

Category:bug report

From the URL 'about:addons' I can find the plugin 'Privacy Badger' (made by EFF).
But when I click 'Install extension' the plugin is not installed (no error message).
However it seems downloaded (I see that in the tab Downloads of Abrowser).

Wed, 05/30/2018 - 08:03

Issue still there with ABrower v60.0.1 and when plugin installed from its official URL:

Wed, 05/30/2018 - 12:17

I didn't have any problem to install Privacy Badger from in Abrowser 60.0.1 (64-bit).

Wed, 05/30/2018 - 12:24

Can you please follow these steps:
* Delete ~/.mozilla/abrowser/ -- make a backup of it first if necessarily.
* Start abrowser
* Install Privacy Badger from

I have tried these steps and it works for me.

Wed, 05/30/2018 - 15:40

Thank you David_Hedlund, it worked your way. The /home was not a 'clean install' partition (it was from my previous Trisquel 8 tests).

However it's strange because Privacy Badger is the only extension I use in ABrowser (and tried to install), let's see if I am the only one with this issue or not. I renamed my previous ABrowser profile folder, in case someone need to review a file in order to understand the issue.

Sat, 01/15/2022 - 02:45
Status:active» closed

Trisquel 8.0 support ended in April 2021.
Please open a new issue in case it remains on the current supported release.