git-send-emails end up with "Use of uninitialized value $values[0] in join or string"

Category:bug report
Status:needs more info

I send a mail with:
git send-email --to="name at domain" --smtp-server="" --smtp-server-port="587" --smtp-user="name at domain" --smtp-pass="my_password" --smtp-encryption="none" 0001*
And I get:
Use of uninitialized value $values[0] in join or string at /usr/share/perl5/Authen/SASL/Perl/ line 498.
And then:
invalid user ID or password

But the password are correct and the git-send-email command worked with trisquel 4.0

So I looked at /usr/share/perl5/Authen/SASL/Perl/ near line 498 and found that function:

sub _response {
my $response = shift;
my $is_client = shift;

my @out;
for my $k (sort keys %$response) {
my $is_array = ref $response->{$k} && ref $response->{$k} eq 'ARRAY';
my @values = $is_array ? @{$response->{$k}} : ($response->{$k});
# Per spec, one way of doing it: multiple k=v
#push @out, [$k, $_] for @values;
# other way: comma separated list
push @out, [$k, join (',', @values)];
return join (",", map { _qdval($_->[0], $_->[1], $is_client) } @out);

I commented push the following line:
push @out, [$k, join (',', @values)];
And uncommented the following line:
#push @out, [$k, $_] for @values;

and retried to send an email, and it worked...


Tue, 10/30/2012 - 08:54
Status:patch (needs work)» needs more info

Thank you for reporting this bug to Trisquel. Trisquel 4.5 reached EOL on September 15th 2012.

Please upgrade to the latest version and re-test. If the bug is still reproducible please re-mark this bug as "active"

Do feel free to report any other bugs you may find.