Installer partition manager crash

Category:bug report

I tried to install Trisquel 5.5 STS Brigantia OVER EVERYTHING ELSE on my computer (Debian and Kubuntu at the time) and in the installer ubi-partman (the partition manager) crashed with status 141. When I tried to continue, it said the install was finished after a split second. Once I rebooted, Debian and Kubuntu were still there. This annoyed me. I wanted to still install a free-as-in-freedom OS, so I installed BLAG 140k. I think this is hardware-specific, so I will give you the computer model; it is an Evo N600c.

Mon, 05/20/2013 - 17:41
Version:» 6.0

Ubi-partman crash on Acer Aspire 5100 with Ubuntu 12.04 LTS and Windows XP installed. Occasional Linux user, but have had Ubuntu dual boot for many years. I did not like Ubuntu when it changed to phone like icon menu (?11.04) and after attempting to load Trisquel on an older HP Laptop and liking the desktop I attempted to install on my Acer 5100. It never gets past the portioning portion of the install and says it crashed with a failed exit code of 141.

I found a script file last night to change Ubuntu 12.04 LTS to Trisquel and tried it. I'm not good with terminal nor quite sure how to use the script correctly but I'll be looking into it. I believe I need to plug in the correct variable information to make it work.

Changing my Ubuntu 12.04 to Trisquel 6 is what I am hoping for, but I'm becoming very frustrated by it.

I'm including the system log from my first try of the install. In order to upload I added .txt to it. It was saved in Ubuntu and had no extention on it.

syslog.txt 170.48 KB
Mon, 05/20/2013 - 19:07

I believe you get the 141 error if you have "complex partitions" that confuse the partman. What that exactly means is not known and this problem has been there for a while. A workaround is to manually partition before hand, using e.g.

Just don't remove partitions you don't want to remove! Be careful.

Tue, 05/21/2013 - 00:17

Thanks, I was getting the feeling it was an issue that was not resolved yet and did read that editing the partitions could possibly fix the issue. I do not understand complex partitions though. I have four that do not appear to be complex to me, Ubuntu created the 2 Linux partitions during the dual boot installation years ago and the other two are for XP and an extended file area area.

I have Gparted and I've done a clonezilla backup so I'll try to adjust the partitions and see if that fixes the Grub MBR area so Trisquel will install.

Thanks......j Ott