usb hub failure

Category:support request


About once a day, my usb hub stops working. What I can observe is that the LED starts flashing (normally, its just "on"), and keyboard and mouse are dead. Plugging everything out including the hub itself, waiting for some minutes and re-plugging does help sometimes, but mostly not.

I have observed this for about a month now and I could not detect any pattern when this happens.

Does anyone have an idea? Thanks in advance


Tue, 11/27/2012 - 16:44
Status:active» needs more info

I might have solved it myself. It seems to be a power issue.

Apparently, my keyboard needs 100 mA, and my mouse 500 mA, and the hub itself another 100mA. So the mouse alone is too much for the usb port which only provides 500 mA.

Fortunately, my notebook has got two usb ports. Now I have plugged the hub with keyboard in the one, and the mouse into the other port. I will observe how they behave ;-)

To be precise: it's a hama usb-hub silver, aluminium, hama article no. 00078498.

Thanks to the people on the #ubuntu-de freenode irc channel who helped me out with "lsusb -v" for the command line and told me that each port has a maximum power of 500 mA.


Tue, 11/27/2012 - 16:48
Status:needs more info» active

Yes, I do need more help in this issue.

After everything was working fine for a couple of days, the hub failed working today. The LED is flashing fast, and I can't connect any device via the hub.

Interestingly, I can use it under Win XP. The hub is recognised and works fine there.

I have no idea what might be the issue, so please help me out on this. I will post the whole thing in the forum, too.

Thanks for any help in advance


Wed, 02/27/2013 - 09:27
Status:active» closed

Thanks to Chris's help, I found out it was a hardware failure of my usb ports. The whole story is documented here: .

I'm closing this issue now as my problems are solved, see the above forum topic.