Can't install Trisquel 7

3 risposte [Ultimo contenuto]
Iscritto: 05/30/2013

I tried installing Trisquel 7 on my computer. It's a laptop that I've bought from ThinkPenguin so it should be compatible and I was previously running Trisquel 6 on it.

When I try to install Trisquel 7 on my computer everything works great in the beggining but after a while the installer crashes. I get a message which says: "The 'grub-efi-amd64-signed' package failed to install into /target/. Without the GRUB boot loader, the installed system will not boot."

Is there anyway to fix this?

Iscritto: 01/22/2011

I had a similar issue installing Trisquel 7 with the netinst iso. It failed when installing grub.

I solved it installing grub from a live cd. To do so, boot from a live cd and type the following in a terminal (I assume Trisquel is installed in /dev/sda hard drve and the root partition is /dev/sda1):

$ sudo su
# TARGET=/media/sda1
# mkdir -p $TARGET
# mount /dev/sda1 $TARGET
# mount --bind /dev $TARGET/dev
# mount --bind /dev/pts $TARGET/dev/pts
# mount --bind /proc $TARGET/proc
# mount --bind /sys $TARGET/sys
# chroot $TARGET /bin/bash

This places you in a root terminal on the trisquel system. Do whatever you want to do there, e.g. re-install grub.

# grub-install /dev/sda
# update-grub

To exit from chroot

# control-D

This brings you back to where you were in the live session and you can unmount

# umount -l $TARGET/dev/pts
# umount -l $TARGET/dev
# umount -l $TARGET/proc
# umount -l $TARGET/sys

Reboot to see if the problem is fixed

Iscritto: 07/05/2014

Oh my I was trying to fix this problem last night! Once I get home I am trying this fix. Thank you!

Iscritto: 05/30/2013

Thank you! Unfourtunately the installer had erased Trisquel from my computer so I was forced to reinstall it. I tried again after the reinstallation, but it didn't work. I think I'll stick to Trisquel 6 until the final release is available.