Emacs 25+ on Trisquel

5 risposte [Ultimo contenuto]
fritjof
Offline
Iscritto: 05/16/2019

Hi

I hope that someone here can help me.
I'm wondering if it is possible to upgrade the Emacs 24, that I got with Trisquel 8, to Emacs 25 or higher. I have some lisp-modifications that I can use on Lubuntu with Emacs 25, but not in 24.
It doesn't appear in the app-depository. Only 24 does. Is this due to compatibility-issues?

Magic Banana

I am a member!

Offline
Iscritto: 07/24/2010

Trisquel 8 is based on Ubuntu 16.04 and is stable. That is why it has ~3-year-old software. You can install "emacs25" or "emacs26" from that PPA: https://launchpad.net/~kelleyk/+archive/ubuntu/emacs

That repository is not under the control of Trisquel: you are on your own to check whether it makes you install proprietary software (or even malware), although I doubt it will ever happen for that particular repository. See https://trisquel.info/forum/gnu-octave-update for a recent discussion of that topic.

kerdadit
Offline
Iscritto: 06/06/2018

Any reason why you wouldn't build it from source?

ADFENO
Offline
Iscritto: 12/31/2012

You can install the GNU Guix package manager[1], which by default comes with repository that is *committed* to follow the GNU FSDG, which Trisquel also does, and after that, install Emacs from GNU Guix.

[1] https://www.gnu.org/s/guix

Em 21 de maio de 2019 02:09:01 BRT, name at domain escreveu:
>Hi
>
>I hope that someone here can help me.
>I'm wondering if it is possible to upgrade the Emacs 24, that I got
>with
>Trisquel 8, to Emacs 25 or higher. I have some lisp-modifications that
>I can
>use on Lubuntu with Emacs 25, but not in 24.
>It doesn't appear in the app-depository. Only 24 does. Is this due to
>compatibility-issues?

--
- Página com formas de contato:
https://libreplanet.org/wiki/User:Adfeno#vCard
- Ativista do software livre (não confundir com o gratuito). Avaliador
da liberdade de software e de sites.
- Página com lista de contribuições:
https://libreplanet.org/wiki/User:Adfeno#Contribs
- Para uso em escritórios e trabalhos, favor enviar arquivos do padrão
internacional OpenDocument/ODF 1.2 (ISO/IEC 26300-1:2015 e
correlatos). São os .odt/.ods/.odp/odg. O LibreOffice é a suíte de
escritório recomendada para editar tais arquivos.
- Para outros formatos de arquivos, veja:
https://libreplanet.org/wiki/User:Adfeno#Arquivos
- Gosta do meu trabalho? Contrate-me ou doe algo para mim!
https://libreplanet.org/wiki/User:Adfeno#Suporte
- Use comunicações sociais federadas padronizadas, onde o "social"
permanece independente do fornecedor. #DeleteWhatsApp. Use #XMPP
(https://libreplanet.org/wiki/XMPP.pt), #DeleteFacebook
#DeleteInstagram #DeleteTwitter #DeleteYouTube. Use #ActivityPub via
#Mastodon (https://joinmastodon.org/).
- #DeleteNetflix #CancelNetflix. Evite #DRM:
https://www.defectivebydesign.org/

dctrud (non verificato)
dctrud

Build from source is extremely quick and easy - happened to do it on this machine just before I activated my account here:

sudo apt build-dep emacs24-common
wget https://mirrors.tripadvisor.com/gnu/emacs/emacs-26.2.tar.gz
tar zxf emacs-26.2.tar.gz
cd emacs-26.2
./configure --prefix=/usr/local
make
sudo make install

farliz
Offline
Iscritto: 05/24/2015

I used a great guide of How to Build Emacs from git Repository, it will help you.

http://ergoemacs.org/emacs/building_emacs_from_git_repository.html