Ethernet Not Working

3 risposte [Ultimo contenuto]
Iscritto: 10/05/2017

Hello everyone,

I have a Libreboot T400 running Trisquel 8. My issue is that I cannot connect to the internet via ethernet. I did the following:

I connected a working ethernet cable to the T400. The small light next to the port switched on.
In Trisquel, it said that a wired network connection was established.
I opened Abrowser and tried to access Wikipedia, but it never connected.
I tried the “sudo service network-manager restart” command in the terminal, but that didn’t work.
I rebooted the computer, but that also didn’t work.

Could you please suggest to me what I could do to resolve this issue?

Iscritto: 05/10/2017

@Aristhopanes Open Terminal and execute the following:
$ sudo ifconfig
$ sudo ip a
$ sudo dmesg|grep Ether
$ sudo lspci|grep Ether
If you can find the interface ens* or eth0 the ethernet is detected.

@psion3 why are you using goog le's dns servers?

Magic Banana

I am a member!

I am a translator!

Iscritto: 07/24/2010

Trisquel 8 uses 'systemctl', not 'service':
$ systemctl restart networking

Not that it would solve your problem. Was Ethernet working with Trisquel 7?

Iscritto: 10/05/2017

I suspect that my IPv4 Primary DNS address is causing the issue because it's that of my router. How do I change my DNS address, and also add more?