GNU Guile manque SRFIs et probablement d'autres modules

1 risposta [Ultimo contenuto]
jeko
Offline
Iscritto: 12/08/2017

Bonsoir !

J'ai installe GNU Guile 2.0 mais je me retrouve avec une distribution de Guile qui manque de modules et SRFI. cClui qui m'a fait remarquer ca est le SRFI-64 pour effectuer des tests unitaires.
Ou puis je me rendre pour inspecter les depots/recettes des paquets de Trisquel pour investiguer sur les raisons de ce manque dans Trisquel 7 ?

Bien a vous,
Jeko

jeko
Offline
Iscritto: 12/08/2017

Au cas où ça puisse intéresser quelqu’un, j’ai remarqué que la version de guile installee via aptitude dans Triquel 7 est la version 2.0.9 alors qu’une version 2.0.11 est disponible d’après la liste de ce dépôt :

http://packages.trisquel.info/trisquel/pool/main/g/guile-2.0/

J’ai donc installé manuellement (dpkg – i) les paquets de la version 2.0.11 et a mon grand bonheur, les modules et extensions dont j’avais besoin étaient inclus dans cette distribution du langage !