How to change keyboard layout to Russian?

18 risposte [Ultimo contenuto]
anonymous

I can't change keyboard layout. I press Super + Space. How to change it?

stas730 (non verificato)

It works in console (Alt + Shift, Super + Shift)

stas730 (non verificato)

Please, help me.

Mampir
Offline
Iscritto: 12/16/2009

I haven't recently used the default Trisquel graphical environment, but I remember that changing the keyboard layout didn't work well at all. As a workaround I installed GNOME Shell.

You can install GNOME Shell like this:

sudo aptitude -R install gnome-shell

Then you have to logout and in the login screen, where you select a user and type in your password, you have to specify what kind of session/graphical environment you want to use. You should select "System Defaults".

If everything is correct, your desktop will look like this: https://www.gnome.org/gnome-3/

Changing the keyboard layout should work as expected with GNOME Shell.

Magic Banana

I am a member!

Offline
Iscritto: 07/24/2010

In the "Input source" tab of the "Region & Language" utility (in the "System settings"), you can add/remove keyboard layouts with the "+" and "-" buttons, move their order with the arrow (the first one is the default layout) and there is a link to the "Shortcut settings" where you can change the shortcuts to switch to the next/previous layout.

stas730 (non verificato)

I can't change keyboard layout. I press Super + Space. How to change it?

stas730 (non verificato)

Please, help me.

stas730 (non verificato)

It works in console.

Mampir
Offline
Iscritto: 12/16/2009

I haven't recently used the default Trisquel graphical environment, but I
remember that changing the keyboard layout didn't work well at all. As a
workaround I installed GNOME Shell.

You can install GNOME Shell like this:

sudo aptitude -R install gnome-shell

Then you have to logout and in the login screen, where you select a user and
type in your password, you have to specify what kind of session/graphical
environment you want to use. You should select "System Defaults".

If everything is correct, your desktop will look like this:
https://www.gnome.org/gnome-3/

Changing the keyboard layout should work as expected with GNOME Shell.

Magic Banana

I am a member!

Offline
Iscritto: 07/24/2010

In the "Input source" tab of the "Region & Language" utility (in the "System
settings"), you can add/remove keyboard layouts with the "+" and "-" buttons,
move their order with the arrow (the first one is the default layout) and
there is a link to the "Shortcut settings" where you can change the shortcuts
to switch to the next/previous layout.

loldier
Offline
Iscritto: 02/17/2016

Trisquel 7 doesn't add a keyboard layout indicator when more keyboard layouts are added. It must be a bug.

https://trisquel.info/en/forum/trisquel-7-keyboard-indicator

Magic Banana

I am a member!

Offline
Iscritto: 07/24/2010

GNOME Shell has such an indicator.

loldier
Offline
Iscritto: 02/17/2016

The sad state of affairs is that Trisquel's multiple keyboard layout feature is broken. The answer should not be "use another DE". The layouts are unusable with or without the indicator. I had to log out to change to Russian and back. If autologin is not enabled, there's no obvious way to enter the password.

I hope this glitch will be ironed out in the next release together with the bug that the screen brightness cannot be saved (Ubuntu 14.04 specific).

VirtualBox_Trisquel_16_03_2016_21_28_15.png russian.png
Magic Banana

I am a member!

Offline
Iscritto: 07/24/2010

I did not write it was "the answer". I only wanted to mention that you can have GNOME Shell (and its keyboard layout indicator) in Trisquel within three clicks in the "Synaptic package manager". You did not have to install Debian to get GNOME Shell (like you wrote you did).

loldier
Offline
Iscritto: 02/17/2016

Now, this is crazy. I'm on a live CD session now that I'm locked out of my desktop on the HDD.

I have several layouts, one of them Russian. But the settings won't work. It doesn't change the layout even if I move Russian on top. If I remove all but one, it changes to the last added layout. The other entries do nothing in the layout list. Only the one that is added last if all other entries are removed. There's no indicator applet for the keyboard in the panel.

Then I tried 'setxkbmap ru' in Terminal which worked. Now I'm locked out of my desktop because I cannot enter my password -- I'm stuck in Russian. I cannot change the login screen keyboard layout, there's no indicator to do that -- only toggle virtual keyboard on/off. It's weird because setxkbmap should not be saved, it should be session-only. On reboot, it should revert to the default setting.

There should be a file somewhere that I can edit to revert back to English. Where is that file located?

Gnu
Gnu
Offline
Iscritto: 03/08/2012

sudo dpkg-reconfigure keyboard-configuration

loldier
Offline
Iscritto: 02/17/2016

Thanks for that. I guess it works. At least when I dropped to TTY at login the command launched a text-mode interface that let me choose a new keyboard layout. I was running Trisquel on a live CD so I couldn't save anything. The command is good to know if I ever encounter the same lock-out again.

I couldn't reproduce the lock-out at login on a live CD session (the keyboard stayed English after 'setxkbmap ru') but the same issue with multiple layouts was there.

In the meantime, I installed Debian over Trisquel because user Mampir recommended installing Gnome Shell as a workaround to the problem. At the moment, Trisquel's default desktop doesn't seem to allow the user have multiple layouts. You can add them but you can't switch between them on the fly.

I'll check back when Trisquel 8 is out. Hope they will have solved the glitch by then.

meydlo
Offline
Iscritto: 04/18/2015

To some extend another workaround might be just to add the keyboard indicator if you're already having 'indicator applet complete':

dconf write /com/canonical/indicator/keyboard/visible true

but it is not sloving the problem which I'm still facing and that is I could not change the keyboard layout just by pressing keyboard shortcuts (as default: super+space)

loldier
Offline
Iscritto: 02/17/2016

I solved the issue by installing packages 'gnome-shell' and 'gnome-shell-extensions'. Then I chose Gnome and GDM as the login manager. LightDM has for some reason no keyboard layout switch indicator and the shortcut super+space doesn't work as intended. Requires a restart.

GDM only gives two layouts to choose between, Finnish and English, no matter what layouts I have configured in System Settings --> Keyboard --> Layout settings. The virtual keyboard doesn't have umlauts even if I choose FI. The good news is, I won't be locked out if I leave Russian as the input and make the mistake of logging out.

sudo dpkg-reconfigure gdm

gdm_configuration.png configure_gdm.png