Import public key

9 risposte [Ultimo contenuto]
jorgino
Offline
Iscritto: 04/17/2020

Hello,
I just installed Trisquel 8 (italian language) and would like to import a public key to use it with Enigmail. I choose System -> Preferences -> Personal -> Password and key then File -> Import , then I select the file with the public key (generated by Flowcrypt in Gmail) but I get the message "import not successfull : no valid user IDs". Can you please help me to import public keys ?
Thank you

apitsch
Offline
Iscritto: 06/08/2019

Hey,

by default, Enigmail uses gpg2 for key management.

Could you therefore please try to import the key on the command line with

gpg2 --import /path/to/public-key

and see if that works?

jorgino
Offline
Iscritto: 04/17/2020

Hi,
I used the command you suggested, it works , message is "1 key imported" ... but I am not able to find where the key is stored.

apitsch
Offline
Iscritto: 06/08/2019

Hi,

you can always list your public keys with

gpg2 --list-public-keys

You should also be able to see them in Icedove Mail > Enigmail > Key Management.

Glad you seem to have found a solution to your problem. Have a nice weekend.

jorgino
Offline
Iscritto: 04/17/2020

Hi,
the keys problem is solved but Enigmail disappeared from Icedove Mail.
Before yesterday Enigmail was into Icedove , yesterday I run the Update software and Enigmail disappeared. It is in the list of packages installed , I disinstalled and reinstalled it but it does not appeat in Icedove. Can you please help on this problem?
Thank you

Magic Banana

I am a member!

Offline
Iscritto: 07/24/2010

I faced the same issue but found an imperfect workaround. I downloaded https://addons.thunderbird.net/thunderbird/downloads/latest/enigmail/addon-71-latest.xpi and, in the gear menu of the "Add-ons Manager" (that you can display from the main menu, with the three stacked segments), I chose "Install Add-on From File...". Although Enigmail appeared enabled in the add-ons manager, it was not. The weird thing is: clicking the "Disable" button and then the "Enable" button that replaces it does enable Enigmail, which appears to be properly working. Unfortunately, Enigmail has to be disabled and then enabled whenever Icedove starts. I have not checked whether the same problem occurs for other (any?) add-on: I only use Enigmail.

At least on my system, the newer version of Icedove (which comes from flidas-updates, not flidas-backports: we have here, after Abrowser, a second exception to the stability rule) suffers from other issues. There are display glitches in the list of emails. Probably not Trisquel's fault. On the contrary, the Trisquel project is responsible for substituting in inappropriate places several "Thunderbird" with either "Icedove" or "Trisquel". Only in the "Add-ons Manager" tab:

Nothing deal breaking but, well, it would be nice to fix those issues for Trisquel 9.

nadebula.1984
Offline
Iscritto: 05/01/2018

You can try to install a GnuPG front end. Then gpg2 will be automatically installed as a dependency.

For most desktop environments, you'll need to install gpa, whereas kgpg is recommended for KDE.

jorgino
Offline
Iscritto: 04/17/2020

I installed kgpg , it is added under Accessories but when I click on it , it does not start. I disinstalled and reinstalled but again it does not start.

jorgino
Offline
Iscritto: 04/17/2020

I installed also gpa , it works and now I can see the key I imported with the command from terminal.
Thank you

jorgino
Offline
Iscritto: 04/17/2020

Hi,
I downloaded the add on as suggested and now Enigmail in again into Icedove.
It works if I send an email to myself using my key, but if I send an email to another user with his own public key I get the message " encryption command error failed " and the email is not sent. I deleted and reimported the public key , I trusted it as "full" but I get always that error message. Any suggestion on this ?
Thank you