mind map software absent from the repo

8 risposte [Ultimo contenuto]
muhammed
Offline
Iscritto: 04/13/2013

Hi guys,

I can't seem to install freemind from the terminal. It shows up in the Add/Remove Programs program but won't install. I'm on Trisquel Mini if it makes a difference.

I tried the freemind-fork Freeplane; same deal.

Muhammed

nadebula.1984
Offline
Iscritto: 05/01/2018

What about KDE Calligra suite's braindump? It's in Debian's main repository as well as Ubuntu's universe repository for the Xenial version, so it's considered free/libre software and should also appear in Trisquel 8's repository. You'll need to install lots of qt dependencies, though.

chaosmonk

I am a member!

I am a translator!

Offline
Iscritto: 07/07/2017

> I can't seem to install freemind from the terminal. It shows up in
> the Add/Remove Programs program but won't install. I'm on Trisquel
> Mini if it makes a difference.

That program has been abandoned for several years[1] and was removed
from Ubuntu and Trisquel several releases ago. Unfortunately, the
backend data for Add/Remove Applications is out of date, based on the
packages present in Ubuntu back in 2015. That's why freemind still
appears, even though it is no longer in the repositories. This is
something we are working on fixing.

[1] https://en.wikipedia.org/wiki/Freemind

calher

I am a member!

Offline
Iscritto: 06/19/2015

I miss freemind. Is its fork active?

Magic Banana

I am a member!

Online
Iscritto: 07/24/2010

Freeplane is. Its latest stable version (1.7.10) was released two months ago: https://sourceforge.net/projects/freeplane/files/freeplane%20stable/

strypey
Offline
Iscritto: 05/14/2015

Freeplane is in the Trisquel Flidas repos, but won't install:

strypey@Bishop:~$ sudo apt install freeplane -y
[sudo] password for strypey:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
freeplane : Depends: libfop-java but it is not installable
E: Unable to correct problems, you have held broken packages.

EDIT: there is an entire thread about the problems with installing Freeplane:
https://trisquel.info/en/forum/freeplane-cant-install

destinationunknown
Offline
Iscritto: 06/22/2018

Have you tried TreeSheets?

I discovered this amazing program in the Trisquel repository a few days ago, and to my surprise, there is a mindmapping feature within the program!

I have begun to construct a mindmap using it already, and have found that it is very easy to learn, and, most importantly, it is free software.

muhammed
Offline
Iscritto: 04/13/2013

Thanks destinationunknown!

I installed treesheets from the terminal. Strangely, I can't find the program in my Trisquel Mini menu. I opened Tree Sheets by entering "treesheets" in the terminal.

I'm going to give this program a try and am optimistic about it! Do you know how to add a shortcut to the menu system?

Magic Banana

I am a member!

Online
Iscritto: 07/24/2010

Isn't there in Trisquel Mini a utility analog to "Main Menu" (aka "Alacarte") in Trisquel? If not, assuming LXDE complies with the "Desktop Entry Specification standard", you can install that utility (the package in Trisquel's repository is named "alacarte") or another one. Or you can manually create, with a text editor, a .desktop file in ~/.local/share/applications. You can read https://specifications.freedesktop.org/desktop-entry-spec/latest/ or, simpler, just modify an existing .desktop file. You only need to specify the keys "Type", "Name" and "Exec".