Redshift on Trisquel 8

22 risposte [Ultimo contenuto]
Aprendiz_de_linux
Offline
Iscritto: 03/02/2014

I have just installed Trisquel 8. I installed it but when trying to load it gives me an error. See bellow the attachment.
I installed GEoCLUE. But still this error appears to me. What should i do?
Thanks in advance.

AllegatoDimensione
Screenshot at 2018-04-24 23:28:36.png854.94 KB
onpon4
Offline
Iscritto: 05/30/2012

You need to either create ~/.config/redshift.conf, or if you already have it, edit it to use the geoclue location provider. I found this page which suggests a template for that file, if you don't have one already:

https://help.ubuntu.com/community/Redshift

Aprendiz_de_linux
Offline
Iscritto: 03/02/2014

Thank you onpon4.
I will follow that guide then. Much appreciated.
Best regards.

mangeur de nuage
Offline
Iscritto: 09/27/2015

Like onpon4 you have to create or edit manually.
If you did not know you are not forced to use the geoclue software you can use a manual configuration in ~/.config/redshift.conf you just need to know your latitude and longitude position, of course this doesn't work if you move from a country to another regularly.

--------------

[redshift]
location-provider=manual
[manual]
lat=
lon=

--------------
You can also install the packet "redshift-gtk" to have a gui on your desktop.

Aristophanes
Offline
Iscritto: 10/05/2017

"You can also install the packet "redshift-gtk" to have a gui on your desktop."

From where can one download this packet? It's not in the "Add/Remove Applications" in Trisquel.

onpon4
Offline
Iscritto: 05/30/2012

It's just listed as "Redshift" in Add/Remove. "redshift-gtk" is the package name, though, so that's what it's listed as in Synaptic and what you would put as the package to install with e.g. apt-get.

Aristophanes
Offline
Iscritto: 10/05/2017

I had a look in Synaptic, and it seems that I have "redshift-gtk" already installed (I had installed "Redshift" from Add/Remove). However, I don't seem to have a GUI interface for Redshift; I get the same error as the OP.

onpon4
Offline
Iscritto: 05/30/2012

You need to open the config file and change it, or create one. See:

https://trisquel.info/en/forum/redshift-trisquel-8#comment-131152

Aristophanes
Offline
Iscritto: 10/05/2017

I'm not sure where to look to see whether I already have this file. I cannot seem to find the .config directory.

chaosmonk

I am a member!

I am a translator!

Offline
Iscritto: 07/07/2017

> I cannot
> seem to find the .config directory.

It's in your home folder. Since it begins with "." it will be hidden by default. If you're using a graphical file manager like Caja or Nautilus you'll need to use "Ctrl+H" to see it.

Aristophanes
Offline
Iscritto: 10/05/2017

So, I followed these instructions (https://help.ubuntu.com/community/Redshift), and I created the necessary configuration file. I can see the Redshift icon in the taskbar and the programme is enabled, but the colour temperature of the screen is unchanged. Why?

onpon4
Offline
Iscritto: 05/30/2012

There are two settings, one for day and one for night. What did you set them to? I use 5000 and 1500, respectively.

Aristophanes
Offline
Iscritto: 10/05/2017

They were 5800 and 4800, respectively, as in the sample configuration. I changed them to the values that you use, and I can now see the difference. By the way, are the values you picked arbitrary, or are they based on what's optimum for the eyes?

onpon4
Offline
Iscritto: 05/30/2012

I tried to make the day shade about the same as dim sunlight (i.e. shade), and I tried to make the night shade similar to a campfire or fireplace (ballparking low). The Wikipedia page on color temperature shows a simple chart with a bunch of color temperatures and about what they correspond to.

Aristophanes
Offline
Iscritto: 10/05/2017

So, I followed these instructions (https://help.ubuntu.com/community/Redshift), creating the necessary configuration file. I can see the Redshift icon in the taskbar and the programme is enabled, but the colour temperature of the screen is unchanged. Why?

Vikings_thum
Offline
Iscritto: 04/04/2017

You can also simply run it from a terminal, e.g.:
$ redshift -l 51.312801:9.481544

$ man redshift
Will show you a list of all options

Hdesmi
Offline
Iscritto: 04/11/2015

Tutorial (the way I did) :

From the Trisquel 8 "Add/remove applications" software: search "redshift", install it.

Edit the Redshift config file (from a console) :

pluma ~/.config/redshift.conf

Content to copy/paste into (you will have to change "lat" at "lon" values to yours):

[redshift]
location-provider=manual
[manual]
lat=44.833333
lon=-0.566667

Save the file then close it.

Open the menu Trisquel, open "Accessories", run "Redshift".

Magic Banana

I am a member!

I am a translator!

Online
Iscritto: 07/24/2010

If who want a program (such as Redshift) to start when you log in, just add it (the command 'redshift' in this case) to the "Startup Applications".

serval
Offline
Iscritto: 09/04/2014

I would only add, that redshift can also be used in a "one shot manual mode" with the following command:
redshift -O TEMP
where TEMP is the colour temperature. For example, to set the colour temperature to 3700K, you can type in the terminal:
redshift -O 3700

Abdulrhman Ayman
Offline
Iscritto: 08/14/2018

You need gtk-redshift, open terminal, type: sudo apt install gtk-redshift

After installation, head to Main Menu > System > Control Center > Startup Applications > Add > Command: gtk-redshift -l 30:30 -t 5000:5000

This will auto-start gtk-redshift every time you login with a temperature of 5000 which is just fine to protect your eyesight. you may also

onpon4
Offline
Iscritto: 05/30/2012

That's not necessary. One of the options in the gtk-redshift tray menu is "Autostart". Just check that and it starts up automatically.

The only extra step necessary is tweaking the config file (~/.config/redshift.conf).

Aristophanes
Offline
Iscritto: 10/05/2017

In Ubuntu 14.04 LTS using the X.Org X server display driver, redshift doesn't affect the colour of my mouse cursor. The issue seems to be that the graphics driver is configured to use hardware cursors. According to the redshift website, some graphics drivers have an option to disable hardware cursors in xorg.conf. Could you please explain to me how to test this solution?

Aristophanes
Offline
Iscritto: 10/05/2017

Another (potentially less radical) solution might be to change the mouse cursor pointer from white to black. Does anyone know how to achieve this?