Using the F12 key to attempt to change boot order during startup

5 risposte [Ultimo contenuto]
amenex
Offline
Iscritto: 01/03/2015

After all these years, getting around to learning the BIOS settings in my Lenovo
T420 laptop running Etiona, I stumbled upon the use of the F12 key to select the
boot order during startup. It was already enabled in BIOS.

Upon pushing the F12 key prior to initiation of the boot process, I managed to
get the boot-order selection screen to pop up. It lists the following drives:
USB
HDD1
HDD2
PCI ...
There are three hard drives on my T420 in its current physical setup
/dev/sda
/dev/sdb
/dev/sdc
I presume that the following are the "translations" of those descriptions:
USB = /dev/sdc
HDD1 = /dev/sda
HDD2 = /dev/sdb
However, the BIOS simply reloads the boot-order selection screen when I highlight and select
any one of these choices except HDD1, whereupon the first hard drive listed in the GRUB menu
boots up; that's /dev/sdb.
It's puzzling because the syslog says that there are eight USB connections on the internal
USB bus. I can account for all eight. Four are external USB ports, of which two are occupied
by the cable connecting the USB 3.0-connected drive, /dev/sdc; but I cannot be sure whether
GRUB will connect to /dev/sdb or /dev/sdc during startup unless I nudge that external drive
by starting GParted and forcing that application to search for the installed drives.
The internal drives occupy two more USB slots; one is the main hard drive and the other is
on a SATA hard drive caddy plugged into the slot meant for a DVD drive. The mouse and a wifi
dongle occupy two more USB positions on the USB bus. A Broadcom bluetooth device on the
motherboard takes care of the eighth USB position.

I'm hoping that I can use the F12 key to force the USB-connected external drive to be the
booted drive. In a normal BIOS setup I used on several desktop PC's, I could set the boot
order by changing the order of the devices for which the system would would search on
startup, but I'm not sure whether I have that option on the boot-order selection screen,
mainly because there's no indication how the system picks the order of the drives HDD1
vs. HDD2. The BIOS settings in Startup list ATA HDD3 and ATA HDD4...

Thanks.

amenex
Offline
Iscritto: 01/03/2015

Oops; the boot-selection screen list is:

USB
HDD0
HDD1
PCI LAN

Magic Banana

I am a member!

I am a translator!

Offline
Iscritto: 07/24/2010

However, the BIOS simply reloads the boot-order selection screen when I highlight and select any one of these choices except HDD1

Do you have a bootloader installed on another disk?

amenex
Offline
Iscritto: 01/03/2015

Magic Banana inquires whether I have GRUB installed on another disk ...

Actually, it's the HDD0 entry in that F12 startup menu that doesn't cause the F12
startup menu to reload. That brings up a GRUB menu that is familiar and which lists
the instance of Etiona on /dev/sdb first. I can then select any instance that I want.

In my efforts to get memtest86+ to appear in the GRUB menu, I ran update-grub
every time I got an instance of Etiona up & running. That said, sudo fdisk -l tells
me that only /dev/sda3 is designated as the boot partition. And each time that I
installed Etiona I accepted /dev/sda as the boot drive.

nadebula.1984
Offline
Iscritto: 05/01/2018

I suddenly recalled something (although it maybe irrelevant here). The official UEFI firmware of SandyBridge ThinkPads doesn't support the combination of "legacy BIOS mode" and "GPT partition table", even if you do have a "BIOS boot" partition. Maybe you should have a look at your hard disks' partition tables?

update-grub does search for all existing operating systems. However, you could also try grub-install.

nadebula.1984
Offline
Iscritto: 05/01/2018

HDD0 == 2.5-inch main HDD bay
HDD1 == 5.25-inch optical drive bay
HDD2 == mSATA slot

The orders in UEFI and in your operating systems may be different. But it's strongly suggested that you flash coreboot on all three of your T420 machines. With coreboot, you can use Atheros AR9380/Killer N1103 on them.