Icedove version in Trisquel repo is obsolete

Progetto:Trisquel
Versione:8.0
Componente:Programs
Categoria:segnalazione di bug
Priorità:critical
Assigned:Non assegnata
Stato:active
Descrizione

Trisquel pulls its Icedove from Debian wheezy. Icedove in Trisquel repo is 38.8.0-1~deb7u1.1+7.0trisquel2 while the upstream version is 45.4.0esr-1~deb7u2.

I suppose the problem is because of the deb-src URL in the package helper.

Mer, 11/30/2016 - 23:19
Assegnato a:anonymous» mixalis_t
Stato:active» patch (ready)

https://devel.trisquel.info/trisquel/package-helpers/merge_requests/165/

Gio, 02/23/2017 - 16:11
Mar, 03/28/2017 - 12:26
Assegnato a:mixalis_t» anonymous
Stato:patch (ready)» active
Mar, 03/28/2017 - 12:33

Building fails with this error: /usr/lib/i386-linux-gnu/libc_nonshared.a(stack_chk_fail_local.oS): In function `__stack_chk_fail_local':
(.text+0x10): undefined reference to `__stack_chk_fail'

Mar, 05/15/2018 - 09:48
Mar, 11/26/2019 - 22:43
Versione:7.0» 8.0

This issue is still actual for Trisquel 8.0 according to a recent forum post https://trisquel.info/en/forum/thunderbird-install-instead-icedove-trisquel8. Not sure if there are any exploitable security bugs in non-browser contexts.