AR9271 no longer works with kernel 4.4.0-186-generic

Categoria:segnalazione di bug
Assigned:Non assegnata

On my laptop which uses trisquel 8.0 after upgrading to kernel 4.4.0-186-generic my wifi adapter no longer works. My laptop acts as if there is no adapter. If I switch back to kernel 4.4.0-119-generic it then works. On my desktop which uses Trisquel 9.0 the USB wifi doesn't work with kernel 4.15.0-112-generic in the same way.

My wifi is the Technoethical N150 Mini.

Dom, 07/26/2020 - 14:59
Stato:active» needs more info

The WiFi chipset is Atheros AR9271, according to

My USB dongle contains the same chipset, according to lsusb. It works with the kernel 4.15.0-112-generic in Trisquel 8's repository.

Is the package open-hth9k-htc-firmware installed on your system?

Mar, 07/28/2020 - 07:31

Did you mean "open-ahth9k-htc-firmware" ? That is installed on the laptop using 4.4.0-186-generic but wasn't installed on the desktop using 4.15.0-112-generic. Installing it on the desktop solved the issue. The laptop is still not seeing wifi networks with the dongle and new kernel.

Mar, 07/28/2020 - 17:56
Titolo:USB Wifi no longer Works With Kernel 4.4.0-186-generic or 4.15.0-112-generic» AR9271 no longer works with kernel 4.4.0-186-generic
Stato:needs more info» active

So, the bug only affects the 4.4 version of the kernel, right? I updated the title accordingly. Can't you upgrade the kernel on the laptop system? You could install the linux-image-generic-hwe-8.0 package, in Trisquel 8's repository, to get the same version as on your desktop system.

Mar, 07/28/2020 - 18:20

Looks as though we've both been bitten by the same bug.

The solution looks deceptively simple. I can update the T420 clone, which hasn't yet
been affected, but I'll have to pass along the fix to the primary T420, whose WiFi
dongle[s] are not even recognized.

Is there a safe way of accomplishing this task with an ext4-formatted USB flash drive ?
I hesitate to install the fix on the clone, because I might end up with two non-functioning
WiFi connections ...

George Langford

Gio, 07/30/2020 - 05:51

That solved it for the laptop now as well. Thank you for the help. Should I set the status to closed ?

Mer, 09/09/2020 - 22:27
Stato:active» closed