With NV34 video card, "xrandr -o left" leads to corruption in the left side of the screen

Categoria:segnalazione di bug
Assigned:Non assegnata
Stato:can't reproduce

If I run "xrandr -o left" (changing screen orientation to portrait), the command succeeds, but there'll be corruption on the left side of the screen. More exactly, a column ~40 pixels wide running from top to bottom on the left of the screen displays what was in that region of the screen before running xrandr (or garbled content). That region of the screen does not update if you move windows over it, with a curious exception: the mouse cursor appears normally when hovering there. There's no corruption when I switch back to landscape orientation, but running "xrandr -o left" again usually makes the problem reappear. Screenshots from Gimp show the screen as it should be, without the corruption (I can take a photograph of the screen if necessary).

I can correct this by changing the screen resolution or orientation back and forth some times (it might take a couple of times, it might take 10 -- I can't find a pattern on this, nor anything particularly different in the logs when I manage to correct it). Rebooting, however, makes the problem reappear.

This came up after I installed a NV34 video card (GeForce FX 5200); before that, I used a Radeon 9250 and the problem did not arise (the Radeon worked very slowly though, but I guess that was expected due to the lack of drivers). I also had Trisquel 5.0 running (with the exact same config files) in another computer with a NV15 video card (Asus GeForce 2 7700), and this bug didn't come up then.

I'm running Trisquel 5.0 with LXDE, but I managed to reproduce this by booting a regular (that is, Gnome) Trisquel 5.0 live CD. Using an Ubuntu live CD the problem did not come up (does Ubuntu use nouveau by default? If it doesn't, I suspect the bug could be related to the NV15 video card misbehaving with nouveau).

I'm attaching Xorg.0.log and the output of lshw and dmesg (I have saved those logs / outputs after starting the computer, logging with X, and running "xrandr -o left", "xrandr -o normal" a couple of times; the problem was still manifesting when I saved the logs); please let me know if there's anything else I should do.

dmesg.txt48.83 KB
lshw.txt15.61 KB
Xorg.0.log_.txt115.6 KB
Lun, 03/05/2012 - 14:39

Also: the problem only manifests itself in my monitor's native portrait resolution -- 1600x900. In any other available resolution (either portrait or landscape), the problem doesn't appear. (Sorry, forgot to add this in the bug report.)

Dom, 11/24/2019 - 23:42
Versione:» 6.0
Stato:active» can't reproduce

Does this bug affect you still as of today in 2019? I used to have problems like this with xrandr in past versions, but I can't reproduce this specific issue any longer.

If the issues are solved for you, mark this as closed. However, if the problem persists, mark this as active.