Machine hangs when trying to reboot

Categoría:informe de erro
Estado:needs more info

When trying to restart, the system writes:

Killing all remaining processes ... FAIL

and then hangs.

Reproduced on desktop, laptop by at least two forum members.

Removing network-manager seems to fix the issue for some people.

See forum thread:

Ven, 04/27/2012 - 19:40
Asignado a:anonymous» upstream

Assigning to upstream. I believe the bug is related to either one of these issues:

Lun, 04/30/2012 - 03:48

Thanks, I can see now that it's an upstream bug.

I confirm that the following workaround works:
- remove modemmanager
- replace network-manager by wicd

Mar, 05/01/2012 - 14:40

This bug explains the problem and suggests a fix

sudo mv /etc/rc6.d/S35networking /etc/rc6.d/S15networking
sudo mv /etc/rc0.d/S35networking /etc/rc0.d/S15networking
sudo mv /etc/rc6.d/ /etc/rc6.d/
sudo mv /etc/rc0.d/ /etc/rc0.d/

I confirm this works.

Lun, 09/10/2012 - 23:47
Estado:active» patch (ready)

Should be fixed in modemmanager (Trisquel 6.0)

Mér, 06/05/2013 - 13:45
Estado:patch (ready)» needs more info

Does this still happen in 6.0?

Mér, 07/10/2013 - 15:20

Yes, for me.

Sáb, 07/13/2013 - 01:33

You could be enjoying a hardware quirk, e.g. a crappy BIOS. Does it help if you add one of these kernel parameters?


warm, cold, bios, smp, triple, kbd, acpi, efi, pci, force

i.e. try adding reboot=warm to /etc/default/grub to default parameters line, update-grub, reboot and then try to reboot

if that no worky, then try adding reboot=cold, update-grub, reboot and try etc.