Abrowser font rendering

Zugewiesen:nicht zugewiesen

Since the latest update, text occasionally becomes blurry in Abrowser (see attached screenshot). Highlighting the text sometimes causes the selected text to render properly. This problem occurs whether the new privacy setting "Do not load custom fonts" is turned on or off.

Screenshot at 2018-02-24 14:32:27.png76.72 KB
Sa, 03/31/2018 - 07:38

After upgrading Abrowser today, this problem persists. While it is not a serious bug, I think it needs to be addressed before the official Trisquel 8 release. One of the first things people will do when trying Trisquel is test the default web browser, and encountering this early on might give the false impression that Trisquel is buggy in general.

Mi, 07/11/2018 - 20:53
Priorität:normal» minor

Changing priority to "minor" because it does not seem to affect most users. I suspect it's related to hardware for this reason. However, it is not an issue with regular Firefox, and comparing the default about:config settings for Abrowser and Firefox I don't see anything that could be the cause.

I've tried the solutions in every thread I can find about blurriness in Firefox, and none work. Most solutions are specific to font rendering, which is not the issue because images are affected too. Disabling hardware acceleration seemed promising but had no effect.

I've noticed that the blurriness comes and goes as I scroll. Often, if I scroll down a bit the blurriness will go away, and if I scroll back up the blurriness will return at the exact same point. Moreover, the blurriness never appears until I begin scrolling through a page. This makes me suspect that scrolling might actually cause the issue. However, disabling smooth scrolling had no effect, and I haven't found any other settings related to scrolling that might apply.

Di, 07/17/2018 - 00:06
Priorität:minor» critical

In current Trisquel 32-bit, Abrowser current, Firefox current, and Tor current all exhibit the blurry text on all forum pages and other page types variously.
Seamonkey 2.49.3 does not exhibit this issue.
When the blurry text exists, clicking to another tab and back clears up the section of blurry text. However, scrolling immediately produces blurry text in subsequent sections.
Also, neither Firefox current, Tor current, nor Seamonkey current exhibit these behaviors in LinuxMint.
It is a major issue since internet browsing and communication is a major function performed by my computers, and some of it is conducted using browsers.
Abrowser would be functional for me otherwise, if not for this major issue.
I might suggest editing title to "text consistently blurry in Abrowser."

Sa, 08/11/2018 - 22:25

Hm. I consistently have this problem in Abrowser, but not in Tor Browser, Icecat, or Firefox. Have you tried Icecat?

Do, 08/16/2018 - 22:20
Titel:text sometimes blurry in abrowser» Abrowser font rendering
Mi, 09/05/2018 - 18:39

Hi, I'm having the same problem. As you mention, this only happens with abrowser.
It usually happens in images and text. If I select the blurry image/file with my pointer then It shows well.

abrowserblur.png 409.5 KB
Di, 09/11/2018 - 08:27

Im sorry to hear this . . . how do we fix this bug.

here's my hardware readout >>>>

H/W path Device Class Description
system 892229U (Intel)
/0/4 processor Intel(R) Celeron(R) M CPU 420 @
/0/13 memory 3GiB System Memory
/0/100/2 display Mobile 945GM/GMS, 943/940GML Express Int
/0/100/2.1 display Mobile 945GM/GMS/GME, 943/940GML Express

Mi, 10/24/2018 - 12:55

I got absolutely same problem as chaosmonk described. I think it might have some "Hardware Acceleration" linked, but if this doesn't affect I have no idea where it might come.

Mi, 10/24/2018 - 16:29

I updated kernel to linux-libre-4.19-gnu and problem magically disappered.

Mi, 07/17/2019 - 13:35

I am still seeing the issue on a clean install onto my Libreboot Macbook A1181. Fully up to date as of 17th July 2019.

A case where I had not seen the issue previously is that it also occurs in the settings/preferences, as well as internet sites. Happy to provide support or information as required.

Blurry Text.png 183.75 KB
Mi, 07/17/2019 - 22:26

Drat. I thought we'd seen the last of this bug. Can you run "uname -r" in a terminal and paste the output here so we can see which kernel you're using?

Perhaps a newer kernel would fix the problem for you like it did for xdknight. You can install 4.19 from jxself's repository.


Do, 07/18/2019 - 15:01

As requested, output as follows:


I would ideally like to use Trisquel 'as-is', particularly as it is my go-to distribution to recommend to others. However, I am happy to try this to explore fixing this issue. Assuming no further Kernel upgrades until the release of Trisquel 9?

I don't currently have a different machine to trial this on to rule out a hardware-specific issue.

Do, 07/18/2019 - 20:18

> I don't currently have a different machine to trial this on to rule out a hardware-specific issue.

It is certainly a hardware-specific issue. Only a few users have experienced it. I only experienced it on my X60 and none of my other machines.

Since Firefox doesn't seem to have this issue, it is possible that there is a software solution other than upgrading the kernel to make Abrowser work on the problematic hardware. However, I'm not sure exactly where the issue lies. Firefox comes bundled with all of its dependencies, whereas Abrowser uses the system libraries, so the issue might be entirely unrelated to Abrowser and have something to do with one of its dependencies.

> I would ideally like to use Trisquel 'as-is', particularly as it is my go-to distribution to recommend to others. However, I am happy to try this to explore fixing this issue.

Since I'm not sure where to begin to look for another solution, I encourage you to try a newer kernel to see if this fixes the problem. It is very easy to go back to the original kernel afterward.

> Assuming no further Kernel upgrades until the release of Trisquel 9?

Trisquel 8's 4.4.0 kernel will continue to receive security updates until 2021, but the default will always be 4.4.0.X, not a newer version. Trisquel does have a 4.15.0 kernel that you can try:

$ sudo apt install linux-generic-hwe-8.0

If that doesn't work you can try an even newer kernel from jxself's repository.

Mi, 02/12/2020 - 22:55

I have updated the kernel to 4.4.0-161-generic #189+8.0trisquel2 and to abrowser 72.0.2 (32-bit) in trisquel - 8.0 on a compaq presario v3000. It is xrandr'ed to a larger screen and can't be checked on the native screen because someone broke it during disassembly.

The font rendering problem displaying broken letters with scrolling still exists here.

My interest was re-ignited when I saw that mozilla intends (I think this is what they meant) to end its control of the seamonkey project. I have long liked the layout of the preferences (many options, and not too many technical settings leaving me wondering about big mistakes, even if they are made) and the look and feel of its browser windows.

I was wondering if the fix for the font rendering issue was discovered.


Do, 02/13/2020 - 07:10

> I was wondering if the fix for the font rendering issue was discovered.

Unfortunately, I don't think anyone ever figured this out.

Are you willing to boot into a Trisquel 9 ISO,[1] run Abrowser, and let me know whether this problem persists in Trisquel 9?

[1]: https://trisquel.info/en/forum/trisquel-9-graphical-iso-available-testing

Do, 02/13/2020 - 22:38

I am hesitant to play with a test version. After I mess things up, it takes me quite a while to get back to attending to daily business.
I did: Load Trisquel 8.0 onto a t41 and made no upgrades. The Abrowser font rendering problem did not seem to exist.
It has regularly showed up in the preferences security section when scrolling down to the bottom of the page, and then once 'invoked', at other various places in the window as scrolling back and forth.
I then changed the resolution (using Monitor Preferences) on this hp v3000 on the desktop display screen to lower values. While the desktop was disturbed and blurred by this, the font rendering issue seemed to be resolved in Abrowser.

When the issue occurs, it seems that it is the section of the screen where the problem exists rather than the section of the displayed page. When the section of the displayed page is scrolled far enough from where it first distorted, it clears. But then other sections at other locations on the display distort.

Also, while I was typing, I thought to try something. I made the Abrowser window about 1/6 of the total screen. I couldn't get it to distort. Then I made it a bit bigger until I could get it to distort. Then I grabbed the window and dragged it around the desktop. The distorted fonts rectified. Subsequent trials resulted in that at some Abrowser window size, the distorted fonts would not rectify by dragging it around. I am not capable of testing this in a precise manner.

Fr, 02/14/2020 - 03:01

I determined to download and burn to dvd the Trisquel 9 iso from the link provided.
But, before I insert and boot that cd, it seems that ISO is not signed.
I have little experience with dev or beta, but I thought these were normally signed?

Fr, 02/21/2020 - 03:56

> But, before I insert and boot that cd, it seems that ISO is not signed.

Yes, it looks like only the official releases available at the "Downloads" page are signed, not the alpha releases.

Di, 03/31/2020 - 22:00

I've had this font rendering problem with Abrowser, and I think Firefox too, since Sept of 2018. How has the experiment with Trisquel 9 worked out?
I consider it a major problem that I've just had to tolerate, OR? I don't know what! But don't want to resort to a return to the MS Windows extreme.
PLEASE KEEP UPDATING this issue... even if its just reporting another dead end.

Di, 04/14/2020 - 13:53

It has been for more than 2 years!! this bug is not resolved yet :(
Is there any chance of getting this bug resolved?

Actually I use my computer to browse the web mostly; I am feeling like I am partially blind while sitting on PC! and I think I will have to switch to another completely free GNU/Linux-Libre soon! :(

Di, 04/14/2020 - 19:07

I managed to fix most of the font rendering problems of Trisquel 8 upgrading libcairo2 to 1.14.8-1, libcairo-gobject2 to 1.16.0-4 and libfreetype6 to 2.9.1-3. I used packages from Debian repositories. Also I have disabled autohint on fontconfig.

Do, 04/16/2020 - 23:59

Hello All.. I'm glad this issue is still active. Thank you to those who are contributing here!... especially chaosmonk! I've found a few of your suggestions very informative.

Reading all input so far, am I right in thinking that this monitor blurring problem with Abrowser isn't actually with "font rendering", but still perhaps an unknown cause?____ But my main question/comment is regarding a "partially" successful attempt to upgrade my Trisquel 8's Kernel, as suggested by chaosmonk:
> Trisquel does have a 4.15.0 kernel that you can try:

> $ sudo apt install linux-generic-hwe-8.0
I used that cmd verbatim, and from what I could observe, and the bit I could understand, , it seemed to work. So then I Shutdown and Rebooted, hoping that process would also update my menu options that appear immediatley after entering the CMOS PWD... BUT, the options were still as before... even under the 4th option (Advanced Trisquel..); there were several options, but all just updates of Linux 4.4, going from .140 to .173, my still current default. HOWEVER:
I'm wondering IF this may be caused by the fact that that OS option menu was created by an installation of Debian 9 more recently than my Trisquel 8 was installed?_____
IF SO, to update grub via Trisquel (or whatever one's currently functioning GNU/Linux OS happens to be), I have to ask a question or 2 that I should put under its own forum heading... so the answer(s) will be easily found by someone asking that question, which I think a LOT more people will want to know, than more info about the Abrowser prob. SO, I'll follow this ? with a new forum topic heading titled "How can one update the current OS Menu options that appear right after one enters the CMOS PWD?"