Abrowser don't find loggin page

5 replies [Last post]
stearinljus lys
Offline
Joined: 06/01/2019

Hello everybody.

My problem is regarding Abrowser. When I want to connect with a network which requires to log in, Abrowser fails to find the login site. It shows the dinosaur with a map. I must first log in with another browser and then I can use Abrowser.
Have anybody any idea why is that so and how to fix it?

Thanks Farhad

liberpoolesque
Offline
Joined: 01/07/2020

Login screen? You mean a captive portal? In Abrowser, captive portal detection is disabled by default, which might cause your problem.
There used to be a checkbox on the main page that allowed you to enable portal detection, but it seems to be gone now.

You could try enabling it manually: Go to Abrowser's settings page by entering "about:config" in the address bar, then click past the warning.
Now you just need to set the property "captivedetect.canonicalURL" to the value "http://detectportal.firefox.com/success.txt" (without the quotes, of course) and the property "network.captive-portal-service.enabled" to the value "true". This will try to make a connection to detectportal.firefox.com each time you use Abrowser to check if there are any captive portals.

Does it find the captive portal if you do that?

stearinljus lys
Offline
Joined: 06/01/2019

I did as you said. But now I can not even start Abrowser. The icon comes to the panel
with the text "Starting web browser" and then disappear. I tried with restarting the computer but it didn't work. How can I set back things to what it was?

boba
Offline
Joined: 08/28/2017

You should be able to find the line you added or modified in this file, in your home directory:

~/.mozilla/abrowser/*.default/prefs.js

and modify it according to your previous settings.

stearinljus lys
Offline
Joined: 06/01/2019

Thank you!
Now I got back my Abrowser :)

liberpoolesque
Offline
Joined: 01/07/2020

Ah, I remember that there was a bug where, if you enable portal detection, Abrowser would always crash on startup, but only for some people. Apparently it is still there. In that case, your only option would be to keep a second Browser on your system for captive portals until the bug is fixed.