[apt error] Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)

5 replies [Last post]
TheAmazed74
Offline
Joined: 09/30/2019

Log: I get this log when executing `sudo apt-get update`:

W: The repository 'http://mirror.fsf.org/trisquel.packages flidas Release' does not have a Release file.

N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.

N: See apt-secure(8) manpage for repository creation and user configuration details.

W: The repository 'http://mirror.fsf.org/trisquel.packages flidas-security Release' does not have a Release file.

N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.

N: See apt-secure(8) manpage for repository creation and user configuration details.

W: The repository 'http://mirror.fsf.org/trisquel.packages flidas-updates Release' does not have a Release file.

N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.

N: See apt-secure(8) manpage for repository creation and user configuration details.

E: Failed to fetch http://mirror.fsf.org/trisquel.packages/dists/flidas/main/source/Sources 404 Not Found [IP: 209.51.188.52 80]

E: Failed to fetch http://mirror.fsf.org/trisquel.packages/dists/flidas-security/main/source/Sources 404 Not Found [IP: 209.51.188.52 80]

E: Failed to fetch http://mirror.fsf.org/trisquel.packages/dists/flidas-updates/main/source/Sources 404 Not Found [IP: 209.51.188.52 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.

_____________________

Originally, I was using `http://mirrors.serverhost.ro/trisquel/packages` but was informed that the switching to the FSF's mirror may fix the issue. - It did not.

_____________________

# Basic Information
- I have tried flashing the USB drive and reinstalling, but I get the same errors with the same mirror.
- I am using the ThinkPenguin TPE-N150USB Wireless Adapter.
- I am also on my personal WIFi and not (as others have asked) school Wifi or a form of public Wifi.

_____________________

Original Discussion:
- https://www.reddit.com/r/trisquel/comments/d80yaz/apt_error_clearsigned_file_isnt_valid_got_nosplit/

TheAmazed74
Offline
Joined: 09/30/2019

Also, I have ran Trisquel in the past and know my drivers have been supported.

Beko
Offline
Joined: 08/31/2019

Have you tried booting into a live-trisquel environment to test if it would work for you there?

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

FSF's mirror of Trisquel's repository is apparently down. Hopefully temporally. If you do not want to wait more for updates, change the mirror again.

TheAmazed74
Offline
Joined: 09/30/2019

> Have you tried booting into a live-trisquel environment to test if it would work for you there?

@beko Thanks, I now have and can report `apt-get update` seems to be successful in the live USB. However, I have no tried installing any apps there.

> FSF's mirror of Trisquel's repository is apparently down. Hopefully temporally. If you do not want to wait more for updates, change the mirror again.

I have tried several mirrors. I have linked their outputs below:

- http://archive.trisquel.info/trisquel/packages

Cat File:
https://distbin.com/activities/9f2d1de8-30d3-40b2-b9fa-0eff8a00a5ce

Output:
https://bin.privacytools.io/?5c30013c34188d3e#+cM7fMchx7Pul0ogJwk4NqJa4X5yYiAg+TQ2XGZTUmY=

- http://mirrors.ocf.berkeley.edu/trisquel/packages

Output:
https://www.reddit.com/r/trisquel/comments/d80yaz/apt_error_clearsigned_file_isnt_valid_got_nosplit/f172ezc/

@magic-banana

TheAmazed74
Offline
Joined: 09/30/2019

I tried installing Debian from an old-er Debian 9 Full USB. Then I tried re-writing the USB with `dd` and still get the same errors.

Therefore, I doubt this is an issue with the hardware or the software (considering `apt-get update` worked in Debian).

__________________________________________________________

ThinkPad x230 on H-Node:
https://h-node.org/search/results/en/1/search/notebook/x230