Asus KFSN 4-DRE at the end of november 2016

68 replies [Last post]
hack and hack
Offline
Joined: 04/02/2015

According to this article, I shouldn't be intimidated:
http://www.howtogeek.com/187797/dont-be-intimidated-building-your-own-computer-is-easier-than-youd-think/

Can I choose any of these necessary pieces?
I guess not. Specially not regarding a graphic card (with DVI support).
Hopefully this will do: https://www.thinkpenguin.com/gnu-linux/geforce-8400gs-1gb-pci-express-20-video-card-gnulinux-full-low-profile-brackets

It seems to be supporting DVI-I dual link. It should in theory support DVI-D (dual link), but I'll have to ask to be sure.

I know about the case, roughly about the CPUs, and the RAM.

Which leaves the power supply. Is there anything I shouldn't buy?
Is there anything that's a must-have?
Don't I need a fan? I'd like something as silent as I can afford (my budget is clearly limited, but feel free to go insane, at least I'll learn about the features).

Also, what's your setup like?

I also found this: http://thierrylaurion.me/asus-kfsn4-dre-serverworkstation-board/
He's talking about a heatsink. Is it as a replacement?
Is it really worth it (besides his aquarium project)?

Last but not least, your experiences with Libreboot on this board:
- does it still have a long delay on boot?
- does it still have issues with usb peripherals?
- anything else you experienced I should know?

Personally, I found out that a USB external audio card being plugged in on boot prevented Libreboot from starting up on an X200 (docked, at least).
I need to unplug it, and plug it back before unlocking the drive the second time (you know, having to put the same passphrase twice).
Note that I got rid of pulseaudio and strictly use alsa and jack (via qjackctl and alsamixer).
I'll tell the Libreboot team when I'll figure out how to get back on their IRC node (last time I was banned (automatically) because I pasted some logs massively (I thought it would make one post instead of one per line... ).

lembas
Offline
Joined: 05/13/2010

Don't be too cheap with the power supply. Bad power makes for strange effects and could fry your other parts. As for what brand to select or avoid my knowledge is ancient.

You'll need a heatsink and probably also a fan. Unless you're building something that creates very little heat. A CPU without a heatsink+fan might fry very fast or at least shutdown automatically as the heat gets too high.

Note that different parts use different sockets so plan accordingly. :)

hack and hack
Offline
Joined: 04/02/2015

Thanks for the info lembas, much appreciated!

hack and hack
Offline
Joined: 04/02/2015

Besides what I already found on the forum, any more experience with this board anyone?

As for fans, it seems CPU's might come with one heatsink for each.
Yet the manual talks about locations to plug 4 fans in.
This sounds like a lot. Do I need all 4??
And does the Smart fan technology from ASUS works with free software (meaning, should I get ASUS fans that support the feature)?

It seems picking a well isolated case can help reduce noise, btw. Silent fans seems to be a possibility.

I'm still thinking of starting off rather cheap, so if I don't HAVE TO get 4 fans, I won't.

hack and hack
Offline
Joined: 04/02/2015

It looks like it's the cheapest compatible case I can find (http://www.newegg.com/Product/Product.aspx?Item=N82E16811854018&nm_mc=AFC-C8Junction&cm_mmc=AFC-C8Junction-PCPartPicker,%20LLC-_-na-_-na-_-na&cm_sp=&AID=10446076&PID=393856...), which costs just as much as the mother board :(

2 fans included, but no power supply. Most likely would cost just as much... And still no RAM nor CPU spent on.
It would be hard to get something with strong performance for less than 500.

My goal is to have something as silent as possible (hopefully less than the X200).
Water cooling (in kit) seems like an option, but that's some more budget, and it would be only for one CPU, not the whole system. So I'd probably use the stock fans at first if I get this case.

Any input welcomed, as usual.

hack and hack
Offline
Joined: 04/02/2015

It seems there is free software fan control (for GPU), but it seems it depends on the owned hardware.
See here https://askubuntu.com/questions/22108/how-to-control-fan-speed

It should be mostly about the motherboard, and the GPU fan.
but what to look for? Is knowing that nouveau supports the GPU enough (what about the mobo)?
This (https://nouveau.freedesktop.org/wiki/PowerManagement/) seems to indicate that Power Management is still a work in progress for some GPU.
I know about a case having PWN. Can this be controlled by free software? This PWM thing seems to be directly related to the software.

Else there's something like this, which supposedly only rely on hardware (and me checking the temp).
http://www.newegg.com/Product/Product.aspx?Item=N82E16811992012&cm_re=FAN_CONTROLLER-_-11-992-012-_-Product

Lembas, thanks to your advice, I'm picking the power supply last. It seems in needs to be powered not only to the mobo, but to the GPU as well. Thanks to h-node, and the nouveau website, I found (way) better and cheaper.

There should be two case fans, the GPU fan(s), the power supply's fan (not sure I should mess with this one, and the CPU's ones.

What I get is that GPU fan control might not be mature yet, but in theory I should be able to handle PWM with free software.
Can anyone confirm (or not)?

hack and hack
Offline
Joined: 04/02/2015

Is there a specific kind of CMOS to pick (EDIT: answer is CR2032 lithium 3V, it seems to be standard)?

If the BIOS chip is new, would I be able to boot, or do I need to install from a floppy disk the proprietary BIOS first? (EDIT: no, I most likely won't be).

I got my mobo without any of these. EDIT: I might have the BIOS chip though. Hopefully it's configured.

I will probably have to install the bios on a floppy disk from windows (how am I gonna connect a floppy reader on a laptop, no idea), and then install it. Then boot from a liveUSB, and flash Libreboot. Maybe there's a simpler way. I'll have to get back on the #librebot if I can.
EDIT: On #libreboot, I got some help, suggesting that I can hot-swap the chip. Yeah it was in the wiki, but when you don't know what it is exactly, it's very easy to skip.

hack and hack
Offline
Joined: 04/02/2015

Ok, on #libreboot, no one is able to answer me, besides the the info that this board has not been fully tested yet.

Lilos posted a thread (closed now, very practical) about several issues, like not being able to boot with 2 CPUs, USB keyboard not working, the PC not booting from the GPU ("fully" supported by Nouveau, I checked), and the HDD not recognized.

So I have no idea if updates since may solve these issues or not.

So it's safe to say: don't purchase for now.
I have one, but now I really hesitate in purchasing the rest of the hardware until I have more info.

Now, since it's supported by Coreboot, normally most of it should work with libreboot, right?
So worst case, I can still use the proprietary BIOS (or better, Coreboot, so less blobs), until hopefully Libreboot catches up. Worst case, well, that purchase could become a bad decision :_(

lilos
Offline
Joined: 09/04/2015

Hi board work perfect i use it evryday with gtx 650.
I use coreboot with sea bios libreboot have boot lag of 30 sec.
Old problem are fixed.

P.S coreboot do not have blobs for this board!Just build with no microcode.

hack and hack
Offline
Joined: 04/02/2015

Hi, thank you lilos!

When you say "Old problems are fixed", you mean Libreboot fixed the problems you had initially, and that all that remains is the 30s boot lag?

***

About Coreboot:
So I take the source from here (https://www.coreboot.org/downloads.html), and not the blobs, right?

Any tips on the configuration you used? (https://www.coreboot.org/Build_HOWTO)
I guess I should compile for x64.

But other than that, there are sections about AMD boards (NIC firmware, AMD IMC, AMD XHCI) and VGA support (https://www.coreboot.org/VGA_support).
Are all these microcode/blobs? Can I safely ignore them?

Thanks again, now I have some hope!

lilos
Offline
Joined: 09/04/2015

Yes old problems are fixed only this 30 sec lag is there.
Yes build coreboot with no microcode, x64 is ok.

AMD boards (NIC firmware, AMD IMC, AMD XHCI)

NIC firmware i think this is in other rom .
XHCI this is only for usb 3.0 so no wory.
Libreboot old fork of coreboot for this board.

uboot
Offline
Joined: 06/01/2016

- Yes old problems are fixed only this 30 sec lag is there.

- > Have you tried to disable serial when building the rom ? With serial enabled, my KGPE-D16 was taking a while to start (nearly 1min), without serial it boots fast (less than 10s until seabios menu)

hack and hack
Offline
Joined: 04/02/2015
uboot
Offline
Joined: 06/01/2016

To build a coreboot rom from git.

Dependencies : apt-get install git build-essential flex bison libncurses5-dev wget zlib1g-dev

git clone http://review.coreboot.org/p/coreboot && cd coreboot && git submodule update --init --checkout
make crossgcc && make iasl (add CPUS=*number of cores* after crossgcc to speedup the compilation)
make menuconfig

Then from the menu, choose your options, here is what I use for KGPE-D16 builds, I leave everything untouched and tick some additional options :

----

General setup ->
Use CMOS for configuration values
Create a table of timestamps collected during boot

Mainboard ->
Mainboard vendor -> ASUS
Mainboard model -> KGPE-D16 (replace with your mobo)
Rom chip size -> 8MB (Instead of 2 as I have a bigger chip) | To find out the size of your chip : sudo dmidecode | grep 'ROM Size'

Chipset :

Include CPU microcode in CBFS -> Do not include microcode updates

Generic Drivers :

Serial Port on SuperIO -> Disabled (Optional, it boots faster if disabled in my case, YMMV)

If you don't use seabios (default), then go to Payload and choose your payload.

----

Then to build the rom with the config file generated :

make

The rom (coreboot.rom) will be in /coreboot/build/ folder, copy it to an other folder and flash it to the chip with your programmer. (Backup the original rom first ! sudo flashrom -p internal -r original_bios.rom -VV) Once you put back the chip on the mobo, clear CMOS (remove it) then boot. Make sure the RAM is correctly inserted and populated in the right slots (Dumb issue I had..)
If you want to start fresh, then enter :

make clean

from coreboot folder.

hack and hack
Offline
Joined: 04/02/2015

Thanks a lot uboot, very interesting!

hack and hack
Offline
Joined: 04/02/2015

uboot, I have a couple of questions:
- what do you mean by a programmer for flashing the chip?
Can't I flash it internally, like with Libreboot?

- It seems this mobo can't boot with usb mass storage devices. Does that mean that the only way to flash the chip is to boot with a liveCD?

uboot
Offline
Joined: 06/01/2016

Even with Libreboot you can't just flash it from Linux (internal) with flashrom IF you're still running the factory BIOS.

You'll need to extract the chip from the motherboard (I think it is DIP8 like on KGPE) and use a chip programmer to flash libreboot/coreboot on it. Once done, put back the chip, clear CMOS and apply power. You should be good.
Next, you'll be able to update your coreboot / libreboot rom from your Linux distro using flashrom.

There are various programmers available. I personally use a BeagleBone, which was recommended on Libreboot website. Well to be honest, it's a bit overkill if you intend to just flash this chip. You could find some very cheap chip programmers on aliexpress for example (5$ shipping included) but most of them will use a Window$ tool.. except ch341a eventually, I'm not sure it is compatible with flashrom. I think it is but you will need to verify.
Otherwise, you can use a RaspberryPi, which use the linux_spi interface like the BeagleBone. It works very well. You could even find some use for it, like a small mediacenter or whatever (although it is full of blob xD)

Well, for your second issue, from what I read, there are indeed issues with USB boot on this mobo.
Anyway, you will still need to flash the chip using a programmer.

hack and hack
Offline
Joined: 04/02/2015

Are you sure??


ASUS KFSN4-DRE?
Internal flashing should work just fine, even if you are currently booting the proprietary firmware.
Libreboot currently lacks documentation for externally re-flashing an LPC flash chip. However, these boards have the flash chip inside of a PLCC socket, and it is possible to hot-swap the chips. If you want to back up your known-working image, simply hot-swap the chip for one that is the same capacity, after having dumped a copy of the current firmware (flashrom -p internal -r yourchosenname.rom), and then flash that chip with the known-working image. Check whether the system still boots, and if it does, then it should be safe to flash the new image (because you now have a backup of the old image).
Keeping at least one spare LPC PLCC chip with working firmware on it is highly recommended, in case of bricks.
DO NOT hot-swap the chip with your bare hands. Use a PLCC chip extractor. These can be found online. See http://www.coreboot.org/Developer_Manual/Tools#Chip_removal_tools
Do check the HCL entry: ../hcl/kfsn4-dre.html

https://libreboot.org/docs/install/#flashrom

It's probably not up-to-date since it seems external flashing is possible now, yet what I read says that even if I'm booting the proprietary firmware,
internal flashing should work.

I went into all this hoping I wouldn't have to do any external flashing :(

uboot
Offline
Joined: 06/01/2016

My mistake. Indeed, it is possible to flash internally on this board.

hack and hack
Offline
Joined: 04/02/2015

No problem :)

That's good news.
It's unfortunate that this mobo isn't more developed for.
It's way cheaper than that other Asus mobo.

Coreboot seems better than Libreboot for this one.
Hopefully flashing internally works the same way.

hack and hack
Offline
Joined: 04/02/2015

uboot,

why I have this message when I do "make crossgcc && make iasl && CPUS=4": "Target architecture is now i386-elf"? Can I choose to compile for x64?

Is choosing no microcodeupdates enough? Are the blobs downloaded in the first place?

I also have this message in red:
"warning: Building GCC 6.3 with a different major version (4.8).
Bootstrapping (-b) is recommended."

Ah, finally found the official doc (not much new though): https://www.coreboot.org/Lesson1

EDIT:
It's doing the following over and over:

Welcome to the coreboot cross toolchain builder v1.44 (March 3rd, 2017)

Building toolchain using 1 thread(s).

Target architecture is now mipsel-elf

warning: Building GCC 6.3 with a different major version (4.8).
Bootstrapping (-b) is recommended.

Downloading tarballs ...
* gmp-6.1.2.tar.xz (cached)
* mpfr-3.1.5.tar.xz (cached)
* mpc-1.0.3.tar.gz (cached)
* libelf-0.8.13.tar.gz (cached)
* binutils-2.28.tar.bz2 (cached)
* gcc-6.3.0.tar.bz2 (cached)
Downloaded tarballs ... ok
Unpacking and patching ...
* gmp-6.1.2.tar.xz
o gmp-6.1.2_freebsd-configure.patch
* mpfr-3.1.5.tar.xz
* mpc-1.0.3.tar.gz
* libelf-0.8.13.tar.gz
* binutils-2.28.tar.bz2
o binutils-2.28_mips-gold.patch
o binutils-2.28_no-bfd-doc.patch
* gcc-6.3.0.tar.bz2
o gcc-6.3.0_elf_biarch.patch
o gcc-6.3.0_gnat.patch
o gcc-6.3.0_libgcc.patch
o gcc-6.3.0_memmodel.patch
o gcc-6.3.0_nds32.patch
o gcc-6.3.0_riscv.patch
Unpacked and patched ... ok
Building packages ...
Skipping GMP v6.1.2 for host as it is already built
Skipping MPFR v3.1.5 for host as it is already built
Skipping MPC v1.0.3 for host as it is already built
Skipping LIBELF v0.8.13 for host as it is already built
Building BINUTILS v2.28 for target ... ok
Building GCC v6.3.0 for target ... ok
Packages built ... ok
Cleaning up temporary files... ok

You can now run your mipsel-elf cross GCC toolchain from /home/user/coreboot/util/crossgcc/xgcc.

I stopped it, and I don't feel like going with "make menuconfig" at this point, since I'm not sure I did it right.

uboot
Offline
Joined: 06/01/2016

This is not correct : make crossgcc && make iasl && CPUS=4

This is correct : make crossgcc CPUS=4 && make iasl

This will build the entire toolchain, but you don't need the whole thing. (take a lot of time to compile as well)

If you want to build only x86 & x64 you use (from the coreboot folder) :

make crossgcc-i386 CPUS=4 && make crossgcc-x64 CPUS=4 && make iasl

then :

make menuconfig

To configure the build options for the rom.

EDIT : CPUS=4 will build the toolchain with 4 threads. For example, on my KGPE there is two CPUs (12cores per CPU) so I would use : CPUS=24
Replace with the appropriate numbers

EDIT2 : On KFSN 4-DRE, you can flash internally but if for some reason, the coreboot rom you compiled fails to boot, you're in trouble ^^ unless you have a way to flash the DIP8 chip externally... Consider this first. Maybe you could use a stable Libreboot rom first ?

hack and hack
Offline
Joined: 04/02/2015

Ah, got it, thanks again uboot :)

I'm trying this only: "make crossgcc-x64 CPUS=4 && make iasl"
since I most likely won't need a 32bit install.

I checked again, 4 is fine because I have 4 cours, so 4 threads, and only one CPU.
I've seen a video of lilos on GobelinRefuge where he has 2 CPUs, one big enough GPU, and the heatsinks are installed in diagonal (didn't knew it was possible).
But compared to mine, the fans were very noisy, so I'll probably stick to one CPU.
It should be enough for my needs (since it's also coupled with the GPU), but until I try, I won't know.

Regarding flashing, I should be OK (I think), because I'll start the PC with the BIOS, then I'll hot swap with another chip. So if it fails to boot, I can still use the BIOS chip to boot, and try again (in theory).
Worst comes to worst, I still have an extra chip.

I suppose I could even compare Libreboot and Coreboot, though Libreboot is indeed late on the updates in comparison. But I might miss GRUB, since it's supposedly easier to load ISOs to GRUB than to Seabios (not sure I ever loaded any ISO though, but I like GRUB since I'm used to it).

Problem is, it looks like GRUB isn't really useable for this board yet (very slow keyboard input, most likely even typing the decryption phrase would be a nightmare): https://www.coreboot.org/Board:asus/kfsn4-dre).
Well, I'll try Seabios and see how it goes.
I remember that I had to make GRUB configurations just to boot Trisquel (for full disk encryption access: https://libreboot.org/docs/gnulinux/encrypted_debian.html), so I wonder how it goes next. I'm trying Seabios, but just in case, if I can't install the way I want to, I'll re-compile with GRUB and use a PS2 keyboard for the config.
But if I need it just to turn the PC on, that won't cut it.

So worst case, I'll use Libreboot, and hopefully I'll figure out how to fix the 30s boot delay.

EDIT:
I compiled it with Seabios, but I have an error with GRUB2 as a payload (no coreboot.rom found this time:
./autogen.sh: line 86: autoreconf: command not found
make[1]: *** [config] Error 127
make: *** [grub2] Erreur 2

uboot
Offline
Joined: 06/01/2016

Did it work with seabios at least ?
For the error, it seems that you're missing dh-autoreconf so :

sudo apt-get install dh-autoreconf

It is also possible to "chainload" the GRUB payload.
So when you boot, it loads "seabios" then instead of searching for HDD or DVD drive, it loads GRUB payload instead. It is safer this way. (To avoid a "brick") (You can still boot normally through seabios if you hit Esc key)

https://www.coreboot.org/GRUB2

Roughly, you need to include grub payload into the rom freshly built and also add a "bootorder" file with this line :

/rom@img/grub2

You can practice with QEMU (Build a rom for i440fx target with seabios only) to see if it works. Then once you're satisfied, you can build again (for your mobo this time) with seabios and include bootorder file & GRUB payload.

I wish I could recommend Libreboot but the project seems dead. The build system is broken as well. That's why I recommend using coreboot instead.

hack and hack
Offline
Joined: 04/02/2015

Yes, it compiled successfully with Seabios.

Ah, I didn't recognized that as a missing program... Thanks I'll try that then.

Chainloading huh... Definitely will try again with Qemu.
But if I can get full disk encryption to work with Seabios only, I'm more than fine with that.
Besides a tiny bit of familiarity, I don't see why GRUB would be better.

Well, it's a shame that Libreboot is a bit outdated.
I'm used to it, plus there's less to do since it's already compiled (never compiled it/built it, if that's what you meant).
And I really like their tutorials.
Not a fan of bringing more and more functionalities either.

Oh well.

hack and hack
Offline
Joined: 04/02/2015

Now I have this when trying to compile with GRUB2:
configure: error: qemu, coreboot and loongson ports need build-time grub-mkfont (need freetype2 library)
make[1]: *** [config] Error 1
make: *** [grub2] Erreur 2

Yet the freetype2 library (libsomething6) is already installed.

I don't mind using Seabios only if it's possible to use full-disk encryption like with Libreboot.

Well at least I figured out how to boot with a liveCD, and to transfer the flashrom utility and the rom from a thumbdrive to the CD.

EDIT:
I see in the Libreboot release (not up-to-date) that this mobo isn't listed in the GRUB folder but only in Seabios.
I assume that it's not ready with GRUB2.

So for now, it's best to go on with Coreboot since it has the latest release, if I can build it with GRUB.

Else I'd stick with Seabios, but how do I perform a full disk encryption in that case?
With GRUB on Libreboot with the X200, I had to type a bunch of stuff to be able to boot (and later to setup a grub config file that does this automatically).

uboot
Offline
Joined: 06/01/2016

Sorry, can't help with the dependency issue. I'm using Debian (Stretch) and it builds fine.
You can't boot from a fully encrypted drive (with /boot encrypted) with seabios afaik.

Other option would be to use petitboot payload instead of seabios or grub.
Here is a tutorial from tpearson : https://www.raptorengineering.com/content/kb/1.html

The Asus KFSN 4-DRE isn't listed though xD You can still try it though. I should try this someday with my KGPE.. I'm just lazy these days. And I don't have 16MiB chips at hand for the moment. Only 8MiB.

hack and hack
Offline
Joined: 04/02/2015

Thanks again for your help uboot.

Well, I'll install Debian Stretch if I have to, full disk encryption isn't an option.

Man, no one cares about this board :D ...
The power/price ratio seems fine, even with one CPU.
My X200 is sometimes going to the limit when using Popcorn-Time, or with some games.
This board should have more room.

Oh well.

SuperTramp83

I am a translator!

Offline
Joined: 10/31/2014

>Popcorn-Time

Popcorn-Time is superbloatedslowashell. You might be interested in running only the core of it, peerflix.
Peerflix is awesome, fast as lightning, simply amazing software.

https://github.com/mafintosh/peerflix

Another great one for searching dem magnets (and consequently use them with peerflix) is pirate-get

https://github.com/vikstrous/pirate-get

Now you can do it all from the sweet sweet terminal, much faster and sexier than bloatcorn :)

hack and hack
Offline
Joined: 04/02/2015

But I'd miss having the pictures/posters of what I might want to watch :(

Otherwise, these two seem worth trying. Do you really see a lot of difference? Sometimes, my laptop crashes while streaming (vlc and Popcorn-Time).

SuperTramp83

I am a translator!

Offline
Joined: 10/31/2014

>But I'd miss having the pictures/posters of what I might want to watch :(

:D

>Do you really see a lot of difference?

Been running like that for like a year.. I really just need to know which movie I want to watch, I find the magnet and pop it, fast and nice :)

hack and hack
Offline
Joined: 04/02/2015

So your CPU handles it allright? Because with Popcorn-Time, it's fast enough.
But I definitely can't put it on fullscreen (on external screen).

SuperTramp83

I am a translator!

Offline
Joined: 10/31/2014

On my old hardware Popcorn Time, which is basically peerflix with GUI + movie covers, runs like crap. I remember it running slowly even on a i5 quad core I owned in the past, but there it was acceptable, in fact I loved Popcorn time a lot back when it first came out.

Peerflix will run fast like a bunny on steroids even on a Pentium 2... Seriously, instead of waiting 30 seconds to load the damn thing, then search for the movie, then wait for a couple of minutes for the movie to start, I just issue the command, I aliased it to 'pf', so it's 'pf 'magnet' -k, with the eventual addition of '-t subtitle.srt'. In toto, 1 minute and the movie has started and the popcorn is crunched.

A neat CLI program for dem subtitles is subliminal ->

Try it and see, mate :)

hack and hack
Offline
Joined: 04/02/2015

Will do, thanks for the extra software :D !

SuperTramp83

I am a translator!

Offline
Joined: 10/31/2014

yw, mate hack :)

hack and hack
Offline
Joined: 04/02/2015

I found a way on the web: I had to install the -dev version of libfreetype6. Then I had to install unifont.

Then I had another error, where the first solution was to try make clean, then try make again. Didn't work, but I'm getting closer!

I'll do it again so I can paste the error here.

Otherwise, I have a few more questions:
- Do I need to verify my download using git clone? I did try https instead of http, it worked.
- How deblobbed is really Coreboot? I see the option for not getting microcode updates, but aren't there any installed in the default download?

EDIT:

Seems it worked this time, for some reason. On the other hand, I didn't see the usual "no microcode updates" while building. Instead I see several lines with microcode written in there.
Yet in menuconfig, I did select "do not include microcode updates".


romstage/cpu/amd/family_10h-family_15h/update_microcode.o
romstage/cpu/amd/microcode/microcode.o
ramstage/cpu/amd/microcode/microcode.o

But hey, those worries about potential blobs and a potential lack of download verification, it's very close to a success!

EDIT2:

According to this https://www.coreboot.org/Build_HOWTO
it seems I'd have to add the blobs myself if I wanted them.
I'm still concerned about not having the message about having no microcode updates enabled anymore.

As for git clone, this https://git-scm.com/docs/git-clone says http is secure.
I still wonder what's the difference with downloading, and why gpg/checksum checks aren't available.
Guess I'll ask on #coreboot and #git, if it exists.
Ah, just found this https://git-scm.com/book/en/v2/Getting-Started-Git-Basics and https://git-scm.com/book/en/v2/Git-Tools-Signing-Your-Work and https://git-scm.com/book/en/v2/Git-Basics-Getting-a-Git-Repository

hack and hack
Offline
Joined: 04/02/2015

Much appreciated, thanks again lilos.

hack and hack
Offline
Joined: 04/02/2015

Bad planning led to this: I can fit 2 fans+heatsinks (over the 2 CPUs), but those who fit are super noisy (https://www.youtube.com/watch?v=yKWhB15Pm4E).

Some quiter fans+heatsinks exist, but one barely fits, and if I want to fit 2 of these, I can only put a fan on each side (one blowing air for both side by side heatsinks, one sucking the air out of the two side by side heatsinks).
Not sure it would work (twice the heat for nearly half the airflow), since the recommended setup for one heatsink is one fan (minimum) blowing air, not sucking air.

What would you do in this situation?
1. use two 6 cores CPU with very noisy server fans+heatsinks
2. use one 6 cores CPU with a silent fan+heatsink
3. try the 2 silent fans setup described above (most likely won't work well)?
4. Try the 2 silent fans but with both fans on the external sides, blowing air inside (against each other). But that would mean that the hot air would go in between the heatsinks, where there's like 1 cm of space between the two. Bad airflow, I might have to add fans to the side of the case or something.

I feel more like going for n°2 because:
- (much?) less noise
- 2x6 cores? Who needs this much? I see it's worth it for Handbrake for example (though one 6 cores should suffice), what can it be useful for as well?

N°4 is now also an option, and a nice compromise between silence and power.
But I'll have to check. Not sure it's a good idea.

I'm hesitating because:
- I already have two CPUs, and it feels weird using only one when I have 2 spots available.

For now, 1 CPU is most likely enough. So I can go with the more quiet fan.
But wanting to use 2 CPUs just because I can, and definitely no wanting server-like noises, having 2 quiet CPUs blowing air towards each other is an option, but definitely no optimal since they kinda cancel each other.

One last option would be to put only a heatsink on the second CPU (it should fit), thus using air from the quiet CPU fan. But that would work only with solid additional case fans from the side or something.
Specially since the air from the CPU fan would hit the single heatsink sideways (the air not going inside).

So basically, is one 6 cores CPU enough even for high-end tasks?
And is there a solid solution for using two CPUs silently?

Magic Banana

I am a member!

Online
Joined: 07/24/2010

Multi-threaded (aka parallel) applications take advantage of several cores... but, currently, almost no desktop application is multi-threaded. Mozilla, with its dozens of developers, is only starting to split Firefox into *two* processes: https://wiki.mozilla.org/Electrolysis

Going sequential to multi-thread means rewriting code. And the new code is much harder to write. And not all tasks benefit from parallelizing in the first place.

Notice however that several cores allow to perform several heavy tasks (such as transcoding) and still have a reactive system: launching one more application will be fast as long as at least one core still is mostly idle. But that is not common on a desktop system. That is why I would say four cores already is many (again: for a *desktop* system).

hack and hack
Offline
Joined: 04/02/2015

I see, so with 6 cores, I'd have plenty.
It's definitely going to be a desktop system, nothing with many VMs or simultaneous connections.

Besides having an empty CPU spot feeling itchy,
I'll probably go with the "1 CPU, 1 quiet fan/heatsink" (gotta check the measurements again).

If I really need another CPU later, I can probably add a simple watercooling solution (quiet enough, and easier to fit). But that would cost a bit more, and I hope it's relatively maintenance free.

I'll definitely start "small" for now. Thanks for the Magic help of yours http://www.sherv.net/cm/emo/funny/2/banana.gif

hack and hack
Offline
Joined: 04/02/2015

I'll just add this option here if someone has the same issue:
I decided to try a silent heatsink+fan, and for the second CPU a noisy one (much much cheaper).
That's a Noctua http://noctua.at/en/nh-u12do-a3/specification
and a Dynatron F661.

Because I found out I can disable a CPU at will:
either in the GRUB config (so every time I restart, I keep the noisy CPU+fan turned off),
or with a command that can fire it up or shut it down.

That way, I can get more brainzpowa (with the added noise) only when needed. Hell, maybe even running both might be silent enough.

I have yet to try, so hopefully I didn't made a mistake on my calculations for the space needed on the mobo for both.

Worst case, it doesn't fit and I'd have lost 20 bucks, but I doubt it. It should work.

Btw, since in i3wm all shortcuts are a combination of keystrokes, is there a software I can use to add single keystroke shortcuts/commands?
Like using F1 for toggling CPU number 2 on/off?

jxself
Offline
Joined: 09/13/2010

I have been thinking about swapping out the CPU heatsinks on my KFSN4-DRE with something like http://www.cwc-group.com/3uk8.html because the ones I originally purchased (which are http://www.cwc-group.com/s2k6fmcs04gp.html) are very loud.

hack and hack
Offline
Joined: 04/02/2015

Yes, 50dBA must be very loud. It seems anything more than 20 is considered loud.

You better be sure about using passive cooling. It was about smaller heatsinks, but reviews said it wasn't cooling at all.
But it might work at this size maybe.
Just in case, I'd make sure that the case airflow would go through it. If the front fans can reach them, it might be just fine. I'm not sure two of these would fit side by side though.

hack and hack
Offline
Joined: 04/02/2015

I might have made (another) small mistake : my CPU has a TDP of 137, which the Noctua cooler supports.
But I can't find any data about the Dynatron.

One thing I will try is to use the second Noctua fan (which I didn't plan to use since I'm out of space) in front of the Dynatron, as a support fan.

But I need to figure out how to immobilize it without glue (or anything definitive).
With some luck, I can set it up directly on the case.

Well, worst case I'd just use one CPU, can't be that bad.

hack and hack
Offline
Joined: 04/02/2015

Back for more stupidity on my part...
here's yet another example of bad planning:
I didn't expect my graphic card to be long enough to COVER one of the CPU slots...

How hard can it be to measure the whole thing before buying extra stuff I'll never need, like another CPU and another fan/cooler?

*sigh* At least the info might help others.

hack and hack
Offline
Joined: 04/02/2015

After asking on #coreboot and #libreboot (no answers on #git) :

First, I was told that if I have nothing like microcode.bin listed, then it "should" be fine. Like the person was not very sure of it.

I still have no idea whether git clone is reliable enough.

Else, I need to try and contact tpearson. 3 options :
1 - fix USB support on Seabios. Waste of effort since encryption of /boot/ is impossible.

2 - install Libreboot. But no /boot/ encryption.
I also need to use MBR or GPT with a proper boot sector on the HHD (because it's Seabios). Not sure what this means yet.

3 - Fix GRUB's USB issue. Maybe I can live with it, I have to try. Probably what I'll try first, since I've already compiled the rom.

4 - use Petitboot. it looks tough because it's supposed to fit linux+coreboot deblobbed+petitboot payload on a 2MiB chip (extra small expenses, without guarantee). I'm supposed to uncheck everything possible in menuconfig. I'll have to also compress the payload with LZMA.
Thanks uboot for the tutorial you've linked above somewhere.

My best bet is to focus on GRUB. No need to rush for Libreboot since I do want full-disk encryption.
I'll ask tpearson about Petitboot if I want to try it, and if the tutorial isn't enough.

Man, it takes a lot of work to have freedom the way I want to. I'm amazed I didn't give up yet.

EDIT: fixing what I wrote about chip size. 8Mb is 1MiB, so I have the proper chip for either Libreboot or Coreboot with GRUB2 (I hope so).
And basically, if I get GRUB to work, and the USB issue is acceptable, I'll stick to this, and maybe help fixing USB on GRUB.

There's also this for the K8 version of the board (not mine) : https://mail.coreboot.org/pipermail/coreboot/2016-August/081944.html

All that's left is to try and hope for the best. And email tpearson, forgot about that.

Magic Banana

I am a member!

Online
Joined: 07/24/2010

8 Mb actually is 0.953674316 MiB.

hack and hack
Offline
Joined: 04/02/2015

True, though I was referring to the chip size (the "official" size).

EDIT: I couldn't flash the new chip because I made the build with n image size of 8388608 B, whereas the chip size is actually 1048576 B.

So instead of 8 MB, I should select 1 MB. So 1MB = 1MiB?
(EDIT: my chip size is 1024 kb. so 1mb, so X MiB).

And now it fails to build:
GEN generated/bootblock.ld
CP bootblock/arch/x86/bootblock.ld
FMAP build/util/cbfstool/fmaptool -h build/fmap_config.h build/fmap.fmd build/fmap.fmap
syntax error
FATAL: Failed while processing provided descriptor
make: *** [build/fmap.fmap] Erreur 4

Let's do it all over again then.
I see some libraries are missing, so grub-mount isn't even installed.
Problematic for mounting encrypted drives I guess. I'll add the missing libraries (it's the dev versions, but couldn't find libzfs) and try again, just in case.

Magic Banana

I am a member!

Online
Joined: 07/24/2010

So 1MB = 1MiB?

No:

  • 1MB = 1,000 * 1,000 = 1,000,000 bytes = 8 * 1,000,000 = 8,000,000 bits;
  • 1MiB = 1,024 * 1,024 = 1,048,576 bytes = 8 * 1048576 = 8,388,608 bits.

That said, until the late 90s, nobody was using "MiB" as a unit. "MB" actually meant today's "MiB". Marketers redefined "MB" to sell hard drives that were larger in appearance (the number was greater). That said, computer scientists had redefined "kilo" (that means 1,000, not 1,024) and the subsequent multiples. Separate words probably are less confusing... but that is not Microsoft's opinion. Windows' file manager still writes "MB" to mean "MiB".

hack and hack
Offline
Joined: 04/02/2015

Thanks Magic Banana :)Ah, so B stands for bytes.

lilos
Offline
Joined: 09/04/2015

Board can`t boot from usb and i wonder is there some good sata to iso hardware emulator like xbox360 hardware cd-rom emulator.

Is anyone tryed to enable NVIDIA Kepler Re-Clocking on devuan with linux-libre 4.10 ?

cat /sys/kernel/debug/ -- > and nothing after debug... any idea ?

nouveau.pstate=1 no need for kernel > 4.5

cat /sys/class/drm/card0/ but no pstate there ?

card0-DVI-D-1/ card0-HDMI-A-1/ device/ subsystem/
card0-DVI-I-1/ dev

Here is my boot kernel parametar:

linux /boot/vmlinuz-4.10.8-gnu root=UUID=9564c0ff-a75b-4e9c-8922-0abe50da1cbb nouveau.config=NvBoost=2

My mesa ver from devuan testing is :

glxinfo | grep OpenGL
OpenGL vendor string: nouveau
OpenGL renderer string: Gallium 0.4 on NVE7
OpenGL core profile version string: 4.3 (Core Profile) Mesa 13.0.6
OpenGL core profile shading language version string: 4.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 13.0.6
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 13.0.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions: