Can't find how to disable Trisquel voice

15 replies [Last post]
sradms0
Offline
Joined: 08/24/2015

Hi users, new gnu/linux user here with a question.

Everything I click on has a robotic voice describing what it is that I have selected.

Could someone direct me to the right place to where I can disable this setting?

onpon4
Offline
Joined: 05/30/2012

Settings->Universal Access->Seeing. Turn off the screen reader there.

Dave_Hunt

I am a member!

Offline
Joined: 09/19/2011

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

In System Settings, select Universal Access, and untick Screen Reader.
The voice is that of Orca, a bit of software that makes Trisquel more
friendly to blind/ visually impaired users.

HTH,

Dave

On 08/29/2015 04:18 PM, name at domain wrote:
> Everything I click on has a robotic voice describing what it is
> that I have selected.
>
> Could someone direct me to the right place to where I can disable
> this setting?
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQEcBAEBAgAGBQJV4hg4AAoJEPDWzxLwi2tAnocH/jGt4AiTs+u3pb0NdufkiSbL
iGgK9fAhqa4iDs0N4VdcS3DTbm5dXLhyNOCElNp4+MFDZ4VW0In4CSoY/b5I6sVx
vZg6PGSaka/kemFBZyVMQ4ohJTTwaRGMFU61F9nPU0afQuHRXDNgtU1+uesm8GJw
gJXHsYBy5t2sisiLtwypZ46maU1W9+/8DUO+Z5poeFamOXfl/IeBzUCmAL4uSGrG
8z3G7HHgdsRxOqSQIUUaNlMDrsI6zetOfvUptG9P9mFv7+mpkdvQJ9uz3JyFb4GW
UsleRWcMQIzvJhOyIX5ny/l8O/lj5ofy8UvbEpYE3kBPc2Mve2D7SPr0mOcobSI=
=xDlX
-----END PGP SIGNATURE-----

sradms0
Offline
Joined: 08/24/2015

this happens in the login section.

Dave_Hunt

I am a member!

Offline
Joined: 09/19/2011

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On the login dialogue, use 'ctrl+s' to toggle the speech.

On 08/30/2015 10:12 AM, name at domain wrote:
> this happens in the login section.
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQEcBAEBAgAGBQJV4xVrAAoJEPDWzxLwi2tA9CEIALreF40fZaRSNvaXH7KFwbXA
AUOXvZyNYTuBfixkYa1/5Q432p45G/4z+HU9bFrTET9xble/rFEkhDn8VuFzSqjK
NaCNB3mHS53vg3FiCon66l0bIeNrZ9NXA7pNdSRUcxfQruF4x2zUrYEcE9k8gPVz
LibaWWemURhfG/kX3NOqVQGNCuR3Ixmz/v7lWdH9Z/TdP1N33gw/YYpMz0r8TezM
D5CV9CG94EpmaoaFItjP6lN7dcYsnWonfqA0tLDRLejGgfROfXFPeWBO52GWHftY
cIqHHhyU+2ni0kf2GijdJvk1n6OYGR8rgPKtY58AJkMn+tdExXHV1QbyL5vatck=
=0H6h
-----END PGP SIGNATURE-----

sradms0
Offline
Joined: 08/24/2015

Thanks, Dave.

amenex
Offline
Joined: 01/03/2015

Great. I'm not blind, and I don't want to wake up the whole neighborhood. How do I shut off the screen reader during login ?

I tried:
> sudo mv libcanberra-ready-sound.desktop libcanberra-ready-sound.desktop.bak<

I also used Universal Access to turn off the screen reader, but it persists at the login prompt.

And my system doesn't have any "reader" function associated with Orca. I used catfish to search on "orca" in my file system.

Dave_Hunt

I am a member!

Offline
Joined: 09/19/2011

Pressing 'ctrl+s' in the login prompt will toggle screen reader off.

amenex
Offline
Joined: 01/03/2015

Dave_Hunt suggested that I turn the robovoice off at login. I just turn off the speakers, but that doesn't address the problem, which doesn't occur in half a dozen other Trisquel installations of mine ... if only I knew what I did then, other than just turning it off in System Settings, which worked a few months ago but not any longer.

t3g
t3g
Offline
Joined: 05/15/2011

Having Orca enabled by default for everyone is really annoying since most people do not need or use it. Maybe don't have it automatically load whenever a newer ISO or full release comes out.

onpon4
Offline
Joined: 05/30/2012

It only happens when you let the bootloader time out.

Perhaps the live CD could also pop up a dialog on boot asking if you would like to disable the screen reader (and explaining what it does and why it's there). Then it could just remember that decision when installing.

SuperTramp83

I am a translator!

Offline
Joined: 10/31/2014

>Having Orca enabled by default for everyone is really annoying since most people do not need or use it.

I don't know about that mate. I mean, it is much easier for you to write sudo apt-get purge gnome-orca in a terminal than for a blind mate turn it on when s/he boots into the OS after installation. Am I right?

amenex
Offline
Joined: 01/03/2015

Trisquel comes with a lot of stuff that most folks won't need but which maintain the portability of the LiveDVD, which is an essential requirement to facilitate wide distribution of the Trisquel OS. I think what we're muttering about is the difficulty of turning off that robo voice ... which apparently was recently made even more difficult, as it was once a simple task to stop it in one of the System Settings menus, and all the rest of my own Trisquel installations don't do that any more.

onpon4
Offline
Joined: 05/30/2012

I think the only place it's been a problem is in the login screen. That might be down to using LightDM instead of GDM.

davidnotcoulthard
Offline
Joined: 02/28/2014
CodyH
Offline
Joined: 12/08/2015

As amenex and SuperTramp83 mentioned, the orca screen reader is useful for better widespread adoption of the Trisquel OS. Also, SuperTramp's recommendation of opening the terminal (Ctrl+Alt+T is the default shortcut for Trisquel) and issuing

"sudo apt-get purge gnome-orca"

would be the most appropriate response to the OP's question. Using the Ctrl+S command does not remove the package (reasoning: if you are turning it off, it is unlikely you are going to use it at any point in the future). Along the same lines, issuing the "sudo apt-get remove gnome-orca" would also be less optimal because it will leave the orca configuration/preferences files.

The "sudo apt-get purge gnome-orca" command is the most straightforward and useful for those who never intend to use the orca screen reader.