Carte d'identité électronique Belge

7 replies [Last post]
Épona Lug Catubodua
Offline
Joined: 05/07/2014

Il semble qu'il y ai un problème dans Trisquel qui fait qu'il soit impossible d'installer le paquet eid-mw après avoir téléchargé et installé le .deb d'eid-archive et rechargé les informations des paquet pour avoir eid-mw disponible par apt.

Le problème est que le paquet est cassé pour une dépendance qu'il n'y a pas sous Ubuntu (j'ai essayé sur l'ordinateur de ma copine qui est sous Ubuntu, la dernière version à support à long terme), la dépendance qui semble poser problème est libfontconfig1 qui devrait être >=2.9.0, or (tout comme sous Ubuntu) la version installé est la 2.8.0 et la même version d'eid-mw marche très bien avec cette version, je pense donc qu'il y a une erreur dans les dépendance de paquets sous Trisquel (d'autant plus qu'il semble y avoir plus de dépendance pour la même version d'eid-mw sous Trisquel que sous Ubuntu).

Je pense faire un rapport de "bug", mais avant ça, j'aimerai savoir si quelqu'un à eu le même problème et s'il a réussi à contourner ce problème ou encore, si quelqu'un n'a eu aucun problème à installer eid-mw.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Trisquel 6 Toutatis (la version actuelle) est basée sur Ubuntu 12.04 Precise Pangolin et a, dans ses dépôts, la même version de libfontconfig1: la version 2.8.0-3.

Trisquel 7 Belenos (qui devrait sortir dans les semaines à venir) est basée sur Ubuntu 14.04 Trusty Tahr et a, dans ses dépôts, la même version de libfontconfig1: la version 2.11.0-0.

Il n'y a pas d'"erreur". Soit tu essaies d'installer à la main les dépendances en provenance des dépôts des versions plus récentes d'Ubuntu (mais c'est vite l'enfer/risqué car ces dépendances ont elles-même des dépendances), soit tu adopte avec antécédence la prochaine Trisquel 7 : http://devel.trisquel.info/makeiso/iso/

Épona Lug Catubodua
Offline
Joined: 05/07/2014

Je n'ai peut-être pas été des plus clair, d'autant plus que je n'ai pas vérifier sur Ubuntu juste avant de poster mon message mais bien un jour avant: sur Ubuntu 12.4 eid-mw ne dépend tout simplement pas de libfontconfig1, alors pourquoi en dépend-il sous Trisquel?
Bien sûr, certains paquets d'Ubuntu ne sont pas sur Trisquel parce qu'ils ne sont pas libre, mais j'ai vérifier tout les autres paquet indiqué dans les dépendance d'eid-mw sous Trisquel et ils sont disponible et dans des versions suffisamment récente, dés lors, je ne vois pas bien d'où peut venir cette dépendance qui "casse" le paquet.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Je viens de télécharger https://eid-mw.googlecode.com/files/eid-mw_4.0.0r1135_i386.deb (oui, 386, une erreur lors de l'installation, mais je doute que cela fasse la moindre différence pour ton problème). Lorsque je double clic sur le fichier, GDdebi me propose son installation. Il y a des dépendances mais elles sont toute dans les dépôts de Trisquel 6. J'ai la version 2.8.0-3 de libfontconfig1. Celle des dépôts.

Je ne sais pas d'où peut venir ton problème. Peut-être as-tu ajouté des dépôts PPA qui proposent des versions plus récentes de certains paquets ?

Épona Lug Catubodua
Offline
Joined: 05/07/2014

Je n'ai pas d'autres dépôt, que celui ajouté automatiquement par eid-archive qui est donc le même que celui installé sur Ubuntu.

Voici la procédure que j'ai suivi tant sur Trisquel que sur Ubuntu:
Comme conseillé un peu partout, j'ai été sur cette page: http://eid.belgium.be/fr/utiliser_votre_eid/installer_le_logiciel_eid/linux/ où j'ai téléchargé cette version d'eid-archive: http://eid.belgium.be/fr/binaries/eid-archive_2014%2E5_all_tcm226-250299.deb (étonnamment, on a pas le choix entre 32 et 64 bits), je l'ai donc installé avec GDebi, j'ai en suite mis à jour avec Synaptic, j'ai rechargé les informations des paquet, là, le dépôt ajouté par eid-archive m'a permit d'installer eid-viewer et eid-mw sous Ubuntu, sous Trisquel, je n'ai réussi à installer eid-viewer qu'après un redémarrage (ceci-dis, il est possible que j'ai redémarré sous Ubuntu, je ne sais plus) et j'ai eu ce problème de dépendance pour eid-viewer.
Je viens de vérifier, la mise à jours a installer la même version d'eid-archive tant sous Trisquel que sous Ubuntu.

Ceci-dis, merci car en remarquant que la version d'eid-mw sur googlecode était moins récente que celle sur le dépôt officiel (files.eid.belgium.be), j'ai téléchargé celle-ci: https://eid-mw.googlecode.com/files/eid-mw_4.0.0r1135_amd64.deb et ça marche très bien :-)!

Par contre, je n'ai toujours pas compris d'où vient cette dépendance problématique. Serait-ce possible que le dépôt de eid ait des dépendance différente en fonction de la distribution utilisée?

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Je ne comprends pas bien d'où vient le problème. Mais puisqu'il est maintenant résolu...

Tu essaieras d'installer une version plus récente après être passé à Trisquel 7.

Épona Lug Catubodua
Offline
Joined: 05/07/2014

Au fait, y a-t-il une date de prévue pour la sortie de Trisquel 7?

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

La réponse arrivera certainement demain, derrière ce lien : http://www.openedjam.org/livestream

À quelle heure ? Tout dépend où l'on habite : http://www.timeanddate.com/worldclock/fixedtime.html?msg=Rub%C3%A9n%27s+Talk&iso=20140726T2045&am=45