Create a bootable live DVD from a downloaded Trisquel_9 ISO image

9 replies [Last post]
Joined: 01/04/2015

Here's the situation:
1. I downloaded an ISO image from the website and saved it in the downloads directory of my USB 3.0-connected SATA hard drive.
2. Wanting to reinstall Trisquel_9 to the HDD in (1) I learned to hot-unplug the SATA-HDD
caddy from the DVD drive bay and replace it with the original DVD drive without restarting
the Lenovo. Otherwise, it boots into grub rescue mode.
3. Startup Disk Creator fails to recognize the DVD drive, although my bootable USB-flash
drive can locate and mount the DVD drive without complaint.
4. Brasero recognizes the Trisquel_9 ISO image and the DVD drive but cannot connect to
Startup Disk Creator.

Why am I attempting this feat ?
All the Trisquel_9 installations on my stack of three Lenovo T420 laptops have lost all the
dot (.hidden) files and so cannot run Icedove. I haven't tried any other applications other
than Leafpad and whois. When I re-install Trisquel_9 in order to download my mail to Icedove, I can do that just once; on reboot all the other newly installed dot files disappear, leaving .icedove, but without its companion dot files, Icedove stops functioning.
Consequently, I'm hoping that a bootable live DVD will produce Trisquel_9 reinstalls that
retain those dot files, as the Trisquel_9 installations made with the live USB flash drive
cannot do so.

Joined: 03/28/2021

Try using the growisofs command:
growisofs -Z /dev/dvdrw=trisquel-image.iso

Joined: 01/04/2015

jib's suggestion works; I navigated to the downloads directory containing the ISO image
(which necessitated mounting that HDD, which is the aforementioned USB 3.0-connected SATA HDD) then
growisofs -Z /dev/dvdrw=trisquel_9.0_amd64.iso
and after persuading the DVD drive to accept the blank DVD, the burn started forthwith.

Upon rebooting with the newly burned DVD in place, the Trisquel page appeared as bright as a new car
... after about ten minutes for the DVD to read the necessary code, the Live session started. Great !

Thanks, jib !

Joined: 01/04/2015

Alas, after moving and editing the profiles.ini file to a newly created /.icedove folder, icedove won't start:
icedove -P gqat6csx.08202015
Opens a profile manager which does not include gqat6csx.08202015 although that is clearly included in the
.icedove folder in the USB 3.0 connected SATA HDD external drive enclosure. This used to work fine.
Here's the profiles.ini file:



Changing StartWithLastProfile=1 to StartWithLastProfile=0 might be the key ...

Nope. Here's what starting icedove from Mate Terminal brings:
icedove -P gqat6csx.08202015
/usr/lib/icedove/defaults/pref/vendor.js:58: prefs parse error: expected ',' or ')' after pref value
JavaScript error: resource://gre/modules/XULStore.jsm, line 66: Error: Can't find profile directory.
JavaScript error: resource://gre/modules/XULStore.jsm, line 66: Error: Can't find profile directory.
JavaScript error: resource://gre/modules/XULStore.jsm, line 66: Error: Can't find profile directory.
JavaScript error: resource://gre/modules/XULStore.jsm, line 66: Error: Can't find profile directory.

Followed by a profile manager that lists default-release and default but none of the three that are in the .icedove folder.

Magic Banana

I am a member!

Joined: 07/24/2010

Error: Can't find profile directory.

That suggests /media/george/b8a1ee74-96d2-407a-8d4e-98df997fcbe3/george/.icedove/gqat6csx.08202015 is not the correct path. Does 'ls' (for instance) find the file?
$ ls /media/george/b8a1ee74-96d2-407a-8d4e-98df997fcbe3/george/.icedove/gqat6csx.08202015

Joined: 01/04/2015

The full "ls" command gets everything that's in gqat6csx.08202015, including Mail, so I shortened the command:
ls /media/george/b8a1ee74-96d2-407a-8d4e-98df997fcbe3/george/.icedove
which dutifully lists three profiles, two that are relics of former setup attempts, plus gqat6csx.08202015,
profiles.ini, and installs.ini.
lists all my email folders. That path is correct.
In the meantime, I set about uninstalling icedove and reinstalling it. That leads to Synaptic Package Manager.
Reading carefully, I successfully negotiated to the task of "reinstalling icedove", clicked "Apply" and
watched it do its magic. I did so twice, once on the icedove that's in the /dev/sda3 HDD (successfully)
and another time on the icedove that's in /dev/sdb3 HDD (not so good).
I then navigated in Mate Terminal to the folder containing the oft-mentioned profile and invoked icedove:
cd /media/george/b8a1ee74-96d2-407a-8d4e-98df997fcbe3/george/.icedove
george@george-ThinkPad-T420:/media/george/b8a1ee74-96d2-407a-8d4e-98df997fcbe3/george/.icedove$ icedove -P gqat6csx.08202015

Whereupon the obvious was clearly too close to be recognized:
/usr/lib/icedove/defaults/pref/vendor.js:58: prefs parse error: expected ',' or ')' after pref value
JavaScript error: resource://gre/modules/XULStore.jsm, line 66: Error: Can't find profile directory.
three more identical reports of invisible directories.

An Internet search on the link in the first of the quoted complaints:
/usr/lib/icedove/defaults/pref/vendor.js:58: brings up an excruciatingly long discussion we had
last December when I was struggling with the upgrade from Trisquel_7 to Trisquel_8:
wherein you suggested at 14:17 on December 13:
sudo sed -i 54d /usr/lib/icedove/defaults/pref/vendor.js but I don't know whether vendor.js
as been changed in TQ_9 vs. TQ_8.

The present T420 has a DVD drive in place of the DVD/SATA caddies in the other two T420's. I
attempted the Synaptic Package Manager icedove reinstall on one of those. Its HDD's are at
/dev/sdb2 and s/dev/sda7, respectively. The reinstall of icedove into the /dev/sda7 HDD worked
OK once I got the profiles.ini files's path statements accurately describing the HDD, but the
reinstall of icedove into the /dev/sdb2 HDD led to the same errors as reported here. The USB
3.0 connected SATA HDD reinstall of icedove remains unsuccessful; that's at /dev/sdc3.

BTW, I removed enigmail from both the /dev/sda7 and /dev/sdb2 HDD's; that application isn't
on the first T420.

Magic Banana

I am a member!

Joined: 07/24/2010

I don't know whether vendor.js as been changed in TQ_9 vs. TQ_8.

It probably changed (line 58 may now be the line to delete, given the error message). But I do not think that error is harmful: forget it.

Does ~/.icedove/installs.ini contain that?

It should.

Joined: 01/04/2015

Yes; installs.ini is in good shape.

Success with the third T420 ! Here's what was needed:
(1) Synaptic Package Manager (SPM) revealed that enigmail & trisquel-recommended were present
on all three HDD's. SPM removed them; then SPM reinstalled icedove, all at my directive.
(2) /dev/sdb3 and /dev/sdc3 both have to be mounted according to their names, Data & Data-II;
otherwise, I lose track of trisquel's identifying designations of those partitions.
(3) /dev/sda1 has its .icedove file at home/george/.icedove, different from the other T420's.
(4) sda is distinguishable from all the other HDD's because it's smaller at 500GB, so I could
keep track of it and get the PATH right in profiles.ini.
And I can restart all the different OS's and they will still open icedove.

Persistence and attention to detail seem to have won out in this process. Trisquel does not
have an innate disregard for extra HDD's on the T420's USB bus. Thanks to all who helped.

Magic Banana

I am a member!

Joined: 07/24/2010

/dev/sda1 has its .icedove file at home/george/.icedove

As we have already discussed, your Icedove profiles should certainly all be in ~/.icedove, so that you do not have to plug a disk to access your emails.

Joined: 01/04/2015

Magic Banana's posting came while I was composing a description of my Eureka afternoon, so when I tried
to "Preview" that epistle, it was swallowed up by a "not authorized to view this page" popup.

What I discovered for myself is that I had been putting my suitably edited profiles.ini file, not just
in /media/username/Mount.Point/username/.icedove/profiles.ini, but also in /.icedove,
along with the other dot files usually placed there. That's a different place than ~/.icedove

They're all fixed now. Three Lenovo T420's that I can use interchangeably, each one with its own icedove.

The lesson learned is to shift the default.profile.toobig out of the /home location to the Data partition
and to accompany it with a suitably edited profiles.ini file containing the necessary PATH statement, plus
similarly updating the original profiles.ini file in its original location.

That plugged-in portable disk lets me keep my project files in one location while skipping from one
T420 to another. Yes, it's a minor bother to remember to hot plug that external hard drive, then run
update-grub, before rebooting into the operating system in the recently plugged-in external drive.

While I can run multiple nmap scan scripts from an internal operating system, and then access and save
data to a different hard drive over the internal and external USB bus, the CPU's run hotter that way.