Démarrage retardé par «dev-disk»

9 replies [Last post]
Stem
Offline
Joined: 05/03/2017

Bonsoir,

Chaque fois que je démarre mon PC, il reste soudainement inactif pendant 1 min 30, puis continue la séquence de boot.

Après enquête, il s'est avéré que cette inactivité était due à «dev-disk», qui était programmé pour durer cette fameuse minute et demie. Du coup, j'ai 2 questions:

1) Qu'est-ce que c'est ?
2) C'est vraiment nécessaire de le faire durer si longtemps ?

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Je suppose qu’il s’agit du démarrage d’un de tes disques. Il n’est pas normal que cela prenne tant de temps.

As-tu exécuté la commande suivante pour établir ton diagnostique (peut-être pourrais-tu nous montrer ce qu’elle sort) ?
$ systemd-analyze critical-chain

Stem
Offline
Joined: 05/03/2017

J'ai simplement demandé au grub de m'afficher le contenu de la console au moment du démarrage, c'est là que j'ai vu que c'était le «job start for dev-disk» qui retardait tout. Il semble avoir été programmé pour cette durée car ça s'affiche sous la forme «# min # s/1 min 30». Où est-ce que je peux régler ça ?

La commande me donne le résultat suivant:

graphical.target @2min 1.884s
└─multi-user.target @2min 1.884s
└─apache2.service @1min 53.637s +8.246s
└─network-online.target @1min 53.614s
└─NetworkManager-wait-online.service @1min 37.031s +16.583s
└─NetworkManager.service @1min 34.034s +2.972s
└─dbus.service @1min 32.982s
└─basic.target @1min 32.963s
└─paths.target @1min 32.963s
└─cups.path @1min 32.962s
└─sysinit.target @1min 32.896s
└─apparmor.service @9.138s +1.667s
└─local-fs.target @9.123s
└─run-user-1000-gvfs.mount @2min 5.006s
└─run-user-1000.mount @1min 45.562s
└─local-fs-pre.target @4.971s
└─lvm2-monitor.service @2.766s +2.204s
└─lvm2-lvmetad.service @3.829s
└─systemd-journald.socket @2.742s
└─-.slice @2.617s

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Il s’agit probablement d’un problème dans ton fichier /etc/fstab. Peut-être un système de fichiers spécifié là mais qui n’existe pas : https://superuser.com/questions/972355/what-needs-to-run-to-stop-the-start-job-dev-disk-by-check-on-each-boot (la partition swap dans ce cas) ou qui n’a pas été correctement créée comme dans https://forums.opensuse.org/showthread.php/503587-Slow-boot-What-is-quot-A-start-job-is-running-for-dev-disk-by-quot et https://bbs.archlinux.org/viewtopic.php?pid=1558260#p1558260 ou encore https://www.linuxbabe.com/desktop-linux/systemd-start-job-running-dev-disk avec des instructions pas à pas pour corriger un UUID qui n’est pas correct.

Peut-être un système de fichiers que tu veux monté à un endroit spécifique mais qui n’est pas disponible au démarrage : https://www.linuxquestions.org/questions/linux-general-1/a-start-job-is-running-for-dev-disk-by-device-4175612584/ (la solution est d’ajouter l’option « noauto »).

Si tu ne t’en sors pas avec ces instructions, montre-nous la sortie de ces deux commandes :
$ lsblk -o +UUID
$ cat /etc/fstab

Si tout te paraît correct mais que le problème persiste, voyons ce que 'journalctl' raconte sur le sujet :

  1. exécute 'journalctl' dans un terminal;
  2. appuie sur la touche /;
  3. tape la chaîne caractères « dev-disk » (sans les guillemets);
  4. appuie sur la touche Entrée;
  5. appuie sur la touche n pour avancer d’occurrence en occurrence;
  6. appuie sur la touche q pour quitter.
Stem
Offline
Joined: 05/03/2017

J'ai regardé dans journalctl, et une erreur revient sans arrêt: Timed out waiting for device dev-disk-by\x2duuid-59f1be61\x2d882b\x2d44ef\x2d93, et l'UUID correspond à un SWAP fantôme

En fait, il y a plusieurs anomalies dans le FSTAB, du genre des indications pas du tout cohérentes avec lsblk:

#
# / was on /dev/sdb1 during installation
UUID=2033b672-0e50-41ab-894a-3c7364211d53 / ext4 errors=remount-ro 0 1
# /home was on /dev/sdb6 during installation
UUID=4b656c3d-c218-4431-b1da-7693e4d9cfd6 /home xfs defaults 0 0
# swap was on /dev/sda5 during installation
UUID=59f1be61-882b-44ef-93e5-7427e05bf31f none swap sw 0 0
# swap was on /dev/sdb5 during installation
UUID=f429abcf-0a1e-4983-a313-e0b6a25b52d4 none swap sw 0 0

Or, lsblk me donne le résultat suivant:

NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT UUID
sda 8:0 0 1,8T 0 disk
├─sda1 8:1 0 931,3G 0 part / 2033b672-0e50-41ab-894a-3c7364211d53
├─sda5 8:5 0 976M 0 part [SWAP] f429abcf-0a1e-4983-a313-e0b6a25b52d4
└─sda6 8:6 0 930,8G 0 part /home 4b656c3d-c218-4431-b1da-7693e4d9cfd6

Magic Banana

I am a member!

Offline
Joined: 07/24/2010
  1. Édite /etc/fstab avec ton éditeur de texte préféré (la commande suivante utilise Pluma, par défaut dans Triquel) exécuté avec les droits d’administration :
    $ gksu pluma /etc/fstab
  2. Supprime les lignes suivantes (une swap qui n'existe pas/plus) :
    # swap was on /dev/sda5 during installation
    UUID=59f1be61-882b-44ef-93e5-7427e05bf31f none swap sw 0 0
  3. Enregistre le changement.

Le reste est cohérent avec la sortie de 'lsblk'. Quelles autres « anomalies » vois-tu ?

Stem
Offline
Joined: 05/03/2017

Mon fstab indique des partitions sous la forme sdbX alors lsblk me montre bien qu'il n'y a que des partitions de type sdaX.

EDIT: OK, j'ai rien dit. J'ai supprimé la fameuse ligne et ça a tout résolu.

Tout de même, je me demande comment cette swap fantôme a pu apparaître.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Je crois comprendre.

À l’installation, il y avait apparemment un autre disque branché. Avec une partition swap (et sûrement un autre système GNU/Linux). L’installeur a donc décidé d’utiliser cette partition swap (une même partition swap peut être utilisée par plusieurs systèmes GNU/Linux). Ce disque était considéré comme étant le premier, d’où la lettre « a ». Ton disque actuel était considéré second, d’où la lettre « b ». Comme le premier disque n’est plus branché, /dev/sdb est devenu /dev/sda et la swap sur le disque débranché ne parvient plus à être activée.

Les lettres « b » dans /etc/fstab n’importe pas, car elles se trouvent dans des lignes qui commencent par le caractère "#" et qui sont donc des commentaires, qui sont ignorés.

zangisharp
Offline
Joined: 01/08/2019

Salut Banana je savais pas que t'es Français :D. enchanté :D

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

De même. :-)