Désinstaller les jeux d'échecs correctement

4 replies [Last post]
Ker Tris
Offline
Joined: 05/27/2016

Bonjour,

Je souhaite désinstaller les jeux d'échecs de mon ordinateur (Trisquel 8).

J'ai pu désinstaller "xboard" et "fairymax" sans problème, mais lorsque je sélectionne "hoichess", "gnome-chess" ou "glchess", Synaptic me sélectionne automatiquement "trisquel-recommended" et je ne sais pas ce que ça implique si je désinstalle ce dernier...

Pouvez-vous m'aider, svp ?

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

« trisquel-recommended » est un méta-paquet. En d’autres terme, il n’existe *que* pour sa liste de dépendances. Dans ce cas, elles définissent une liste de paquets dont l’installation, au-dessus de l’environnement de bureau par défaut, est recommandée.

La suppression d’un méta-paquet n’a donc aucune influence sur le système. Seuls deux fichiers, « changelog » et « copyright », dans /usr/share/doc, sont supprimés.

Bon, en fait, il y a une influence future : si de nouvelles dépendances sont ajoutées à « trisquel-recommended » (c’est-à-dire de nouveaux paquets recommandés), un système avec « trisquel-recommended » se verra proposer l’installation de ces dépendances. Un système sans « trisquel-recommended », non. Supprimer « trisquel-recommended » signifie donc ne plus suivre les « recommandations » (au-dessus de l’environnement de bureau par défaut, lui défini par le méta-paquet « trisquel »). Par exemple, parce que l’on ne veut pas le jeu d’échecs installé par défaut. Normalement les dépendances d’un méta-paquets ne changent qu’entre versions de Trisquel (par exemple entre Trisquel 8 et la future Trisquel 9). Il faut alors installer « trisquel-recommended » après la mise à jour si l’on souhaite découvrir les nouveaux paquets recommandés par la nouvelle version de Trisquel (et peut être en supprimer certains et donc « trisquel-recommended »).

Ker Tris
Offline
Joined: 05/27/2016

Ah merci, c'est plus clair pour moi !
Ceci dit, n'y a-t-il pas un moyen de lister l'ensemble des recommandations (soit les dépendances du méta-paquet « trisquel-recommended ») :
1/ lorsque « trisquel-recommended » est installé ?
2/ lorsque « trisquel-recommended » est désinstallé ?

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Encore une fois : désinstaller « trisquel-recommended » n’a aucune influence directe sur le système. Les dépendances de « trisquel-recommended » peuvent être listées depuis le « Gestionnaire de paquet Synaptic » (onglet « Dépendances » des « Propriétés » du paquet) ou depuis un terminal :
$ apt depends trisquel-recommended
trisquel-recommended
Dépend: vino
Dépend: mate-screensaver
Dépend: libreoffice-style-galaxy
Dépend: libreoffice-style-tango
Dépend: libreoffice-gnome
Dépend: libreoffice-calc
Dépend: libreoffice-impress
Dépend: libreoffice-writer
Dépend: bogofilter
Dépend: bluez
bluez:i386
Dépend: bluez-cups
Dépend: gvfs-bin
gvfs-bin:i386
Dépend: espeak
espeak:i386
Dépend: espeak-data
Dépend: inputattach
Dépend: mousetweaks
Dépend: usb-creator-gtk
Dépend: gnome-raw-thumbnailer
Dépend: gnome-xcf-thumbnailer
Dépend: ooo-thumbnailer
Dépend: seahorse
Dépend: ssh-askpass-gnome
Dépend: gnome-session-canberra
Dépend: libcanberra-pulse
Dépend: gucharmap
Dépend: brasero
Dépend: brasero-cdrkit
Dépend: abrowser
icecat
Dépend: transmission-gtk
Dépend: simple-scan
Dépend: sane-utils
sane-utils:i386
Dépend: aisleriot
Dépend: gnome-sudoku
Dépend: gnomine
Dépend: glchess
Dépend: liferea
Dépend: pidgin
Dépend: pidgin-plugin-pack
Dépend: pidgin-libnotify
Dépend: deja-dup
Dépend: python-indicate
Dépend: python-libproxy
Dépend: gnome-orca
Dépend: libgail-3-0
Dépend: libgail-common
Dépend: at-spi2-core
at-spi2-core:i386
Dépend: libglib2.0-bin
libglib2.0-bin:i386
Dépend: gnome-accessibility-themes
Dépend: libatk-adaptor
Dépend: python-gi-cairo
Dépend: gimp
Dépend: rhythmbox-mozilla
Dépend: rhythmbox-plugin-cdrecorder
Dépend: rhythmbox-plugins
Dépend: python-mako
Dépend: vinagre
Dépend: python-qt4
Dépend: libreoffice
Dépend: vim
vim-athena
vim-athena-py2
vim-gnome
vim-gnome-py2
vim-gtk
vim-gtk-py2
vim-gtk3
vim-gtk3-py2
vim-nox
vim-nox-py2
Dépend: cheese
Dépend: gnome-chess
Dépend: gnome-mahjongg
Dépend: vlc
Dépend: onboard
Dépend: onboard-data
Dépend: icedove
Dépend: xul-ext-lightning
Dépend: enigmail
Dépend: rhythmbox
Dépend: caja-actions
Dépend: caja-gksu
Dépend: caja-image-converter
Dépend: caja-open-terminal
Dépend: caja-sendto
Dépend: caja-share
Dépend: caja-wallpaper
Dépend: deja-dup-caja
Dépend: folder-color-caja
Dépend: eom
Dépend: ffmpegthumbnailer
Dépend: enchant
Dépend: libreoffice-pdfimport
Dépend: mate-netspeed
Dépend: mate-desktop-environment-extras
Dépend: vlc-plugin-samba
Dépend: vlc-plugin-notify
Dépend: fonts-arphic-ukai
Dépend: fonts-arphic-uming
Dépend: fonts-dejavu-core
Dépend: fonts-freefont-ttf
Dépend: fonts-guru
Dépend: fonts-guru-extra
Dépend: fonts-kacst
Dépend: fonts-kacst-one
Dépend: fonts-khmeros-core
Dépend: fonts-lao
Dépend: fonts-liberation
Dépend: fonts-lklug-sinhala
Dépend: fonts-lohit-guru
Dépend: fonts-mathjax
Dépend: fonts-nanum
Dépend: fonts-noto
Dépend: fonts-noto-cjk
Dépend: fonts-noto-hinted
Dépend: fonts-noto-mono
Dépend: fonts-noto-unhinted
Dépend: fonts-opendyslexic
Dépend: fonts-opensymbol
Dépend: fonts-sil-abyssinica
Dépend: fonts-sil-padauk
Dépend: fonts-symbola
Dépend: fonts-takao-pgothic
Dépend: fonts-thai-tlwg
Dépend: fonts-tibetan-machine
Dépend: fonts-tlwg-garuda
Dépend: fonts-tlwg-garuda-ttf
Dépend: fonts-tlwg-kinnari
Dépend: fonts-tlwg-kinnari-ttf
Dépend: fonts-tlwg-laksaman
Dépend: fonts-tlwg-laksaman-ttf
Dépend: fonts-tlwg-loma
Dépend: fonts-tlwg-loma-ttf
Dépend: fonts-tlwg-mono
Dépend: fonts-tlwg-mono-ttf
Dépend: fonts-tlwg-norasi
Dépend: fonts-tlwg-norasi-ttf
Dépend: fonts-tlwg-purisa
Dépend: fonts-tlwg-purisa-ttf
Dépend: fonts-tlwg-sawasdee
Dépend: fonts-tlwg-sawasdee-ttf
Dépend: fonts-tlwg-typewriter
Dépend: fonts-tlwg-typewriter-ttf
Dépend: fonts-tlwg-typist
Dépend: fonts-tlwg-typist-ttf
Dépend: fonts-tlwg-typo
Dépend: fonts-tlwg-typo-ttf
Dépend: fonts-tlwg-umpush
Dépend: fonts-tlwg-umpush-ttf
Dépend: fonts-tlwg-waree
Dépend: fonts-tlwg-waree-ttf
Dépend: fonts-sil-gentium
Dépend: fonts-stix
Dépend: nmap

Supprimer n’importe lequel de ces paquets (notamment « glchess » ou « gnome-chess ») supprime donc « trisquel-recommended » (ce qui n’a aucune influence directe). Même chose pour les dépendances des dépendances de « trisquel-recommended », les dépendances des dépendances des dépendances de « trisquel-recommended », etc.

Laisse-moi t’expliquer de nouveau la seule différence indirecte de la suppression de « trisquel-recommended » : « vlc » est, pour Trisquel 8, une dépendance de « trisquel-recommended ». Avant Trisquel 8, le système par défaut incluait Totem (le lecteur vidéo de GNOME) à la place de VLC. Autrement dit, le méta-paquet « trisquel-recommended » de Trisquel 7 a « totem » comme dépendance et non « vlc ». En mettant à jour de Trisquel 7 à Trisquel 8, VLC n’est installé que si « trisquel-recommended » est installé. Autrement non. Mais il est bien sûr possible d’installer« trisquel-recommended » après la mise à jour vers Trisquel 8 et VLC viendra avec.

Ker Tris
Offline
Joined: 05/27/2016

Re !
Oui, merci, j'ai bien compris l'histoire du méta-paquet, tu m'as bien expliqué.
Je voulais juste savoir comment afficher la liste des dépendances et tu viens de me l'expliquer (je ne savais pas si la procédure serait la même avec le méta-paquet installé ou non).

Merci, maintenant je sais comment profiter des recommandations sans forcément toutes les suivre !

Pour Trisquel 9, j'utiliserais "Meld" pour comparer les changements (peut-être y a-t-il plus simple, avec le changelog par exemple ?).