Flatpak

4 replies [Last post]
amuza
Offline
Joined: 02/12/2018

I was searching for a way to have Gajim + OMEMO on Trisquel [0], then someone told me my GTK version was too old, and my only chance was to use Flatpak installation [1], and then installing plugins [2].

That's been my first time I hear of Flatpak. What is your opinion?
Is everything Libre?
Is the software there built and signed by the original developers?
Or is it built and signed by Flatpak?
Do you trust Flatpak?

[0] https://trisquel.info/en/forum/gajimomemo-was-jmp-was-librem5-and-why-i-am-no-longer-interestedgeneral-free-software-talk
[1] https://flathub.org/apps/details/org.gajim.Gajim
[2] https://dev.gajim.org/gajim/gajim/wikis/help/flathub

Magic Banana

I am a member!

Online
Joined: 07/24/2010

Like a .deb package, a flatpak can be made by anybody and can contain free software and/or proprietary software. In the present case, the Gajim team makes the flatpak and I see no reason why it would not be all free software (since Gajim and its dependencies are free software): https://dev.gajim.org/gajim/gajim/blob/master/flatpak/org.gajim.Gajim.yaml

... but flatpak itself is not packaged in Trisquel 8.

tonlee
Offline
Joined: 09/08/2014

> Libre?

https://github.com/flatpak/flatpak/blob/master/COPYING

https://dev.gajim.org/gajim/gajim

On debian 9 64bit I installed
flatpak 1.2.4 - 1
gajim 1.1.2
omemo 2.6.26

Gajim and omemo runs.

ADFENO
Offline
Joined: 12/31/2012

I don't know if it was Snap or Flatpak, but [one of these] had a issue reported in Trisquel, in which they would allow installing from the default repository maintained by the package manager, that wouldn't be a problem if the repository had policy to include only GNU FSDG compliant packages.

To clarify, this message doesn't have references, as such, take with a grain of salt as I'm currently unable to look which program was in Trisquel's website search - I'm going to do some college tests/exams now.

Em 14 de abril de 2019 14:01:59 BRT, name at domain escreveu:
> > Libre?
>
>https://github.com/flatpak/flatpak/blob/master/COPYING
>
>https://dev.gajim.org/gajim/gajim
>
>On debian 9 64bit I installed
>flatpak 1.2.4 - 4
>gajim 1.1.2
>omemo 2.6.26
>
>Gajim and omemo runs.

--
- Página com formas de contato:
https://libreplanet.org/wiki/User:Adfeno#vCard
- Ativista do software livre (não confundir com o gratuito). Avaliador
da liberdade de software e de sites.
- Página com lista de contribuições:
https://libreplanet.org/wiki/User:Adfeno#Contribs
- Para uso em escritórios e trabalhos, favor enviar arquivos do padrão
internacional OpenDocument/ODF 1.2 (ISO/IEC 26300-1:2015 e
correlatos). São os .odt/.ods/.odp/odg. O LibreOffice é a suíte de
escritório recomendada para editar tais arquivos.
- Para outros formatos de arquivos, veja:
https://libreplanet.org/wiki/User:Adfeno#Arquivos
- Gosta do meu trabalho? Contrate-me ou doe algo para mim!
https://libreplanet.org/wiki/User:Adfeno#Suporte
- Use comunicações sociais federadas padronizadas, onde o "social"
permanece independente do fornecedor. #DeleteWhatsApp. Use #XMPP
(https://libreplanet.org/wiki/XMPP.pt), #DeleteFacebook
#DeleteInstagram #DeleteTwitter #DeleteYouTube. Use #ActivityPub via
#Mastodon (https://joinmastodon.org/).
- #DeleteNetflix #CancelNetflix. Evite #DRM:
https://www.defectivebydesign.org/

nadebula.1984
Offline
Joined: 05/01/2018

Debian's testing repository has the latest gajim package. However, I'm not sure whether Trisquel (based on an outdated LTS version of Ubuntu) meets the version requirements of the dependencies.