Greyed out, ticked boxes for 'Encrypt' and 'LVM' during Flidas install (solved but weird)

7 replies [Last post]
strypey
Offline
Joined: 05/14/2015

OK, so I finally got my filing system tidied up and decluttered, and backed up (rsync to an SD card). I have a boot USB with an image of Flidas on it (copied directly with dd), and I'm writing this from a live session using that now. I'm feeling like a lite hacker (like a leet hacker but not quite as impressive), and I'm ready to try out installing Flidas on Bishop, my trusty old digital carrier pigeon. Yay!
https://www.coactivate.org/projects/disintermedia/bishop

I have my preferred partition scheme in place (see link above), so what I'm wanting to do is install Flidas to my secondary testing OS partition, ideally leaving me with a working Belenos system if anything goes wrong. But the first time I ran the graphical installer, the tick boxes for 'Encrypt the new installation' and 'use LVM' were both ticked and greyed out.

Oh no! I don't want to make any changes to my user files partition, and I *definitely* don't want any LVM right now, thank you. So I rebooted and tried the text install, but it got as far as try to download files from the nearest mirror in Taiwan, and then did nothing for about 10 minutes, so I rebooted again.

I decided to experiment with installing to a USB stick, not a live system like this one, but an installed system that can be updated and store user config. This is something I've always been curious about. So I booted back into the live system, put in an 8GB USB 2.0 stick (my Belenos and Uruk installs have never been more than about 5 GB so this ought to be enough) and launched the installer again.

As I clicked through, the installer asked me if I wanted it to unmount partitions on sdac, to which I agreed. Then, what do you know, this time the tick boxes are *not* greyed out, and I can untick them. So on with partitioning. The next question is, what is the best file system format to use for an installed system on a USB?

A quick web search turned up many options; ext4? btrfs? f2fs? After skimming over a few pages ...
https://askubuntu.com/questions/220015/how-to-use-btrfs-with-compression-on-external-usb-hard-drive
https://help.ubuntu.com/community/Installation/FromUSBStick#Prerequisites

... I decided that since I'm just experimenting, it's fine to just go with ext4 for now. Any useful links about the pros and cons of different file system formats on both USB drives and internal SSDs would be most appreciated.

I set up my partition scheme with two swap partitions because I read somewhere (probably in some old outdated Debian docs on the web) that using the same one for multiple installs can cause problems. I used to be able to specify which swap partition I wanted to use for each installed OS, but it now seem to automatically select both to be formatted. But I've been told in other threads here that this no longer matters (if it ever did). So I'll probably delete that second swap partition, and give the space back to my /home partition.

I'll post this now and then go on with the install. I'll update with the outcome in later comments.

strypey
Offline
Joined: 05/14/2015

Well, the install worked, and I'm now typing this from an installed OS running off a USB key (8GB USB 2.0)!

I've thought for a while that this would be handy, because if I can have my own OS on a USB key I can carry around with me, I can set up my PC with a generic guest OS that logs in without a password when turned on. Obviously I can do that with a guest account on one OS and have a separate admin account. But it's a pain having to logout and login as me every time I power on, instead of just putting a USB key in a port, and going straight to a login screen where I can login as me.

Also, if I have my own OS, the guest OS doesn't need to even know my user files partition is there. Anyone using the guest login can see it's the only account on the OS install, so the only to reason to think there's other partitions on the internal disk is the guest OS partition being so small for a whole drive (by modern standards). I could even divide my user files into 2 user file partitions, one for use with the guest OS, and a hidden, encrypted one for my own private use (maybe using LVM so I can resize them as needed without data loss?).

One other thing, putting my tinfoil hat on for a minute, is that I don't need to worry as much about anyone getting access to my PC, and hiding some kind of bug (keylogger / trojan / whatever) in my drive. Because I'm only ever booting from my key, and mounting my user file partition as /home, it doesn't matter if the guest OS on the internal disk is compromise.

Final thing, I've just always liked the idea of starting my computer my putting a key in the ignition, in this case the ignition being a USB port ;)

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

As far as I understand, the only use case where having one single swap partition for several GNU/Linux distributions raises a problem is if you want to hibernate one of these distributions, use another distribution and then recover the hibernated system. I do not think there is any other reason to have several swap partitions.

strypey
Offline
Joined: 05/14/2015

I've run apt-get to get all the latest updates, which took a while. I've set up the language support (why is that never installed by default?). Maori is not available as a language, as it usually is, possibly because I set the system location to China instead of New Zealand during setup?

Now I'm trying to get the NTP support working, so the system date and time is synchronized with NTP servers. I tried to toggle the dropdown from 'manual' to 'keep synchronized with internet servers', and I get a pop-up saying "NTP support is not installed". I click on "install NTP support" and I get:
"Could not install package

GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.PackageKit was not provided by any .service files"

Does anybody know what this means, and how I fix it?

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

All I can say is that I enabled it on GNOME Shell and, looking at the installed packages, I only have "ntpdate" that seems to be related. Since it is a dependency of "trisquel-minimal", I guess it is installed on your system as well.

strypey
Offline
Joined: 05/14/2015

NTP all worked fine on Belenos. It's only since installing Flidas that I struck this problem.

strypey
Offline
Joined: 05/14/2015

BTW Yes, I have ntpdate installed. Is there no known fix for this? Shall I file a bug?

strypey
Offline
Joined: 05/14/2015

With my user file partition (until today used with Belenos) mounted as /home by default, a lot of stuff works out of the box (browser history, XMPP accounts etc). Need to customize desktop a bit, install extra apps I like (Mumble etc), and so on. Some of the things I change are fairly specific to my use case (eg Māori language support), but I'm often surprised by some of the default settings when I go through all the applets in the Control Panel and tweak everything. What use is it to have text files previewed as little icons with tiny words on them? Yet it must use more RAM to do that surely?

- downloaded and install all updates using apt-get
- checked language support, installed full support
- change regional format to English, system-wide (was set as Chinese characters)
- installed Esperanto (Māori not there, why not?)
- set system time to Hong Kong
- changed touchpad to '2-finger scrolling', and 'natural scrolling'
- added Māori keyboard layout, moved it to top (default?)
- power management
- in general changed notification to 'only when battery is low'
- on battery power changed 'sleep when inactive' to 10 mins, and display to sleep when inactive' to 5 mins
- on AC power changed 'sleep when inactive' to 30 mins, and display to sleep when inactive' to 10 mins
- (if it's turning off the screen and sleeping too quickly, I can dial these back a bit)
- personal file sharing, ticked share public files (maybe this is poor security, but I use it to swap files with my wife's MacBook without having to mess around with USBs)
- changed check for software updates to 'daily'
- MATE Tweak
- removed Trash and Network icons from the desktop
- changed panel layout to (something?), tried them all, then changed it to 'Redmond'
- turned off 'enable animations'
- changed (?) Window Manager to Marco (No Compositor)
- changed icon size to 'small'
- Appearance, changed all local fonts to 14pt
- File Management
- changed default folder view to 'list'
- ticket include a delete command that bypasses the trash
- turned preview off for text files
- changed preview on photos to a max size of 1MB
- ticked never prompt or start programs on media insertion
- startup applications
- unticked Screensaver (don't need it, screen turning off then system sleep is fine)
- unticked Print Queue Applet (when do I ever print anything?)
- unticked Orca screen reader (don't need it)
- unticked Backup Monitor (don't use it)
- Window Preferences
- ticked select windows when the mouse hovers over them
- ticket unselect windows when the mouse leaves them
- set up XMPP accounts
- already loaded in Pidgin
- installed Mumble for voice conferences
- installed AbiWord to use as .txt editor and .odt editor

ToDo
- find out why automatic time sync not working, refuses to install NTP
- set up offline email accounts in IceDove (need to check if IceDove can do XMPP like ThunderBird can)