He actualizado Trisquel de la 7 a la 8 y ahora no puedo ni entrar en mi usuario

11 replies [Last post]
yawin
Offline
Joined: 02/11/2016

Pues eso, si meto mi contraseña, parece que va a cargar el escritorio y vuelve a la pantalla de login. Eso no pasa con la cuenta de invitado o con otras que cree con adduser.

En esas lo que pasa es que las ventanas se abren sin marco y alt+f4 no las cierra.

Entiendo que tengo un problema con el escritorio, pero no sé arreglarlo.

yawin
Offline
Joined: 02/11/2016

No sé por qué no me deja editar: quería añadir que he instalado "plasma-desktop" y ocurre lo mismo. Aunque en este caso, desde la cuenta de invitado, en vez de abrirme las carpetas sin marco, me pregunta dónde está el programa con el que abrir las carpetas.

Pablo G

I am a member!

Offline
Joined: 05/16/2012

Hola,

Si tienes Trisquel personalizado, como yo lo tenía en mi Vikings X200, es posible que te ocurra como me ocurrió a mí, solución:

https://trisquel.info/es/forum/sin-gestor-de-ventanas-luego-de-actualizar-x200-trisquel-8

Otro problema similar:

https://trisquel.info/en/forum/tirsquel-8-upgrade-disaster-windowing-broken-panels-broken-etc

saludos libres

yawin
Offline
Joined: 02/11/2016

¡Gracias! He podido arreglar el asunto de las ventanas. Pero sigue sin entrar a mi cuenta.

Edit: aqui podeis ver que ocurre https://goblinrefuge.com/mediagoblin/u/lascosasdeyawin/m/session-problem-in-trisquel/

Edit2: Tambien me pasa que, a pesar de tener puesto que uso castellano, me pone el teclado en ingles.

JoseGP
Offline
Joined: 06/18/2016

Entra en una tty y elimina el fichero .Xauthority .

sudo rm ./.Xauthority

yawin
Offline
Joined: 02/11/2016

Resulta que .Xauthority pertenecía a root. Le he hecho chown y ahora ya entra.

Pero tengo un nuevo problema: https://goblinrefuge.com/mediagoblin/u/lascosasdeyawin/m/session-problem-in-trisquel-ii/

Ark74

I am a member!

Offline
Joined: 07/15/2009

En mi experiencia la mejor manera de hacer un upgrade entre versiones es hacerlo desde 0.

En caso de que tu /home (como el mio) esté separado de / (root) puedes mover tu carpeta personal de digamos

mv /home/yawin /home/yawin.bkup

Y reinstalar usando el mismo usuario (yawin, en este caso) y de ahí solo jalar los archivos que necesitas de yawin.bkup a yawin

De esta manera podrás hacer uso de la distro como el desarrollador se rompió la cabeza para que la usaras mejor según su idea y evitar conflictos entre personalización propia con la nueva configuración que una versión nueva trae consigo. Posterior desde ahí partir para la personalización que desees.

También te sirve para identificar useless data, que se queda sin uso en yawin.bkup

Saludos.

yawin
Offline
Joined: 02/11/2016

Ya, pero es que no quiero formatear. Primero de todo porque no debería ser necesario. Y, a parte, porque no quiero reinstalar todo el software que tengo instalado.

Esto se tiene que poder arreglar.

Edit: Al final, he instalado el paquete Triskel y con KDE no me pasa. Así que así me quedo. Ahora toca descubrir cómo eliminar el otro escritorio xD

Ark74

I am a member!

Offline
Joined: 07/15/2009

Interesante,
Al parecer eres víctima de un error recién introducido por alguna actualización.

Recientemente gthumb se rompió para mí, al parecer eso tiene que ver con mate.


$ gthumb
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "topmenu-gtk-module"
Inconsistency detected by ld.so: ../sysdeps/x86_64/dl-machine.h: 517: elf_machine_rela_relative: Assertion `ELFW(R_TYPE) (reloc->r_info) == R_X86_64_RELATIVE' failed!

Update:
Canberra _y topmenu_ se resuelve con


sudo apt install libcanberra-gtk-module libtopmenu-gtk3-module topmenu-gtk3

Queda resolver el tema del kernel, algunas personas sugieren instalar los paquetes i386 sobre amd64, otros dicen que solo es necesario reiniciar y reinstalar. Veremos.
Update_end

Pero el tema de topmenu parece ser algún detalle que comenzó a principios de este mes con mate, el uptime de mi laptop era de 31 días así que no me había percatado, jejeje.

Es una teoría, solo eso.

yawin
Offline
Joined: 02/11/2016

Me dice apt-get que no puede localizar el paquete "libtopmenu-gtk3-module". Pero bueno, me he pasado a KDE así que tampoco voy a perder el sueño. De hecho, en realidad, en mi PC de sobremesa siempre he usado KDE; no lo estaba usando en el portátil porque me vino con el escritorio por defecto de Trisquel y me dió pereza cambiarlo xD

Ark74

I am a member!

Offline
Joined: 07/15/2009

En efecto, era:

sudo apt install libcanberra-gtk-module topmenu-gtk3

Pero algo paso que ya perdí por completo gthumb. Toritoooooo!

Saludos.

yawin
Offline
Joined: 02/11/2016

Ok! Anotado! Muchas gracias ^__^