Https Everywhere error

8 replies [Last post]
GNUbahn
Offline
Joined: 02/18/2016

When I install Https Everywhere in Firefox, Abrowser or IceCat I get an error message in a pop up window. I've searched for fellow sufferers and solutions but can't find any.

Does anyone here have a suggestion for a solution?

AttachmentSize
https everywhere error.png18.85 KB
GNUbahn
Offline
Joined: 02/18/2016

PS: This happens on at least three different machines and two different OS (Trisquel and Mint)

SuperTramp83

I am a translator!

Offline
Joined: 10/31/2014

https://github.com/philips/https-everywhere/blob/master/src/chrome/content/observatory-popup.xul

Line 4 is indeed window id="ssl-observatory-dialog"

I have no idea why this popup, but I guess if you disable the observatory in the preferences the popup dialog should no more bother you.
Other than that, does the extension work well for you? Does it redirect you to the secured version of the site -- https -- if you write http://www.whatever.org ?

Ignacio.Agullo
Offline
Joined: 09/29/2009

name at domain, Ven 16 Set 2016 20:44:14 CEST:

> When I install Https Everywhere in Firefox, Abrowser or IceCat I get
> an error message in a pop up window. I've searched for fellow
> sufferers and solutions but can't find any.
>
> Does anyone here have a suggestion for a solution?

You get the Yellow Screen Of Death. I got it with the
"Bandwidth Meter and Diagnostics" extension during years, but only
when there was a "Server not found" error so it was annoying but not
hampering.

The bug you are reporting seems too much hampering to withstand,
so I guess it appears on only one version of the extension. Try to
find an older version, and if you can't find one, wait for the next
version.

------------------------------------------------------------------------
Ignacio Agulló · name at domain

----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.

GNUbahn
Offline
Joined: 02/18/2016

Thanks for your answers.

SupeTramp83: Can you guide me to disable the observatory in the preferences?

Mangy Dog

I am a member!

I am a translator!

Offline
Joined: 03/15/2015

Click on the HTTPS Everywhere icon > choose preferences & untick the SSL Observatory ;-)

1-HTTPSpref.png 2HTTPSpref.png
GNUbahn
Offline
Joined: 02/18/2016

Ok, I misunderstood. I thought we were talking about the browser's preferences. Thanks. The problem is (temporarily) solved.

SuperTramp83

I am a translator!

Offline
Joined: 10/31/2014

I am temporarily glad you solved it :)

GNUbahn
Offline
Joined: 02/18/2016

:-)