ia32-libs casse apt sur trisquel mais pas sur mint

2 replies [Last post]
silemmo
Offline
Joined: 10/25/2012

Salut tous le monde,

j'ai besoin de xampp pour développer du php mais xampp a besoin de ia32-libs pour fonctionner, mais ia32-libs casse apt-get et pas moyen de réparer. J'ai testé sur linux mint et ça marche très bien donc le problème vient bien de trisquel.
Que faire ?

ps : je sais que je peut utiliser GLAMP mais je préfère utiliser xampp car à l'école on utilise xampp.

ps2 : ce problème peut aussi servir pour ceux qui veulent installer wine ou unetbootin ou tout autre programme qui est en 32 bits.

Merci d'avance pour votre aide.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

D'après cette documentation francophone :
Il est fortement déconseillé d'utiliser Xampp

Par ailleurs, je doute que tu vois la moindre différence (autre qu'esthétique comme le "panneau de contrôle graphique") avec une installation basée sur la commande suivante (et utilisant donc les paquets dans les dépôts Trisquel) :
$ sudo apt-get install apache2 php5 mysql-server php5-mysql

Ton problème est lié au support "multiarch"... et ça fait mal à la tête. Maintenant, si tu y tiens, tu peux essayé de suivre ce qui est écrit dans la documentation mentionnée plus haut. Il y a même un dépôt PPA. Je doute néanmoins que ton problème se résolve ainsi...

silemmo
Offline
Joined: 10/25/2012

Salut merci pour ta réponse,
je pense que la documentation n'est pas très à jour.

Car encore une fois sur linux mint 15 ça marche très bien. Peut être parce que c'est basé sur ubuntu 13.04 ?

Je tourne actuellement sur parabola, qui marche bien, mais le soucis est différent lol c'est une question de permissions pour xammp. Alors que j'ai suivi le même procédé pas-à-pas.

Bref, merci encore je continuerai à chercher.