Impossible d'installer le logiciel beid

6 replies [Last post]
Stem
Offline
Joined: 05/03/2017

Bonjour,

Quand j'essaye d'installer le paquet «eid-mw», j'ai le message suivant:

stem@P35-DS3R:~$ sudo apt install eid-mw
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
eid-mw : Dépend: beid-mozilla-extension mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
stem@P35-DS3R:~$

C'est bizarre pour 2 raisons:

1) Le paquet est bel et bien présent dans les dépôts, mais l'installation manuelle ne marche pas non plus à cause de «dépendances manquantes».
2) Je ne comprends même pas pourquoi c'est marqué comme «dépendance indispensable» puisque l'extension en elle-même s'installe depuis les add-ons firefox.

Ça m'embête parce que j'ai des formalités importantes à accomplir.

Cordialement.

Magic Banana

I am a member!

Online
Joined: 07/24/2010

Il n’y a pas de paquet « eid-mw » dans le dépôt de Trisquel 8. Je suppose que tu as installé https://eid.belgium.be/sites/default/files/software/eid-archive_2018.1_all.deb qui installe un dépôt qui ne doit probablement pas contenir que du logiciel libre.

Stem
Offline
Joined: 05/03/2017

Si, il y est, sinon il m'aurait dit qu'il était absent plutôt que cassé. Le seul logiciel que m'a installé eid-archive est la bibliothèque PKCS#11 et les clés GPG, le dépôt ne contient rien d'autre.

Magic Banana

I am a member!

Online
Joined: 07/24/2010

Non. Il n’est pas dans le dépôt de Trisquel 8. Le gestionnaire de paquets te montre tout les .deb qui ont été installés sur ton système et le sont encore. Ce qui est « cassé » est « installé ».

Stem
Offline
Joined: 05/03/2017

OK, mais ce que je ne comprends toujours pas, c'est que j'ai déjà réussi à installer l'application dans trisquel par le passé sans que ça ne pose problème, donc qu'est-ce qui fait que ça ne marche plus ?

Magic Banana

I am a member!

Online
Joined: 07/24/2010

Je ne sais pas. Dans le « Gestionnaire de paquets Synaptic », tu peux essayer « Menu Édition/Réparer les paquets cassés » ou tout simplement supprimer ce paquet.

Stem
Offline
Joined: 05/03/2017

Désolé de re-upper, mais je n'ai rien trouvé en cherchant sur google. Personne, y compris les dev, ne semble savoir le pourquoi de l'existence de cette dépendance fantôme qui ne devrait même pas être là. Qui peut m'aider ?