Impossible réparer paquets cassés et autres erreurs.

29 replies [Last post]
thierra
Offline
Joined: 02/19/2015

Bonjour,

Je suis sous Trisquel 8. Je ne sais pas si je l'ai mal installé mais je trouve que ça marche moins bien que Trisquel 7.

1_ Tentative d'installation de GnuCash avec Synaptic.
Carré rouge et ! blanc devant GnuCash.
Appliquer. Réponse : Impossible d'appliquer les changements. Réparez d'abord les paquets cassés.
Je clique sur réparer les paquets cassés. Réponse, voir le fichier png attaché.

2. Je ferme le portable. Il se met en veille. Quand je l'ouvre. Fenêtre noire et une liste de messages d'erreurs. je n'ai pas le temps de lire, retour trop rapide au bureau.

3. Un signal danger apparaît très fréquemment sur le tableau de bord. Quand je clique, il m'informe que je ne suis pas à jour. Quand je clique sur mise à jour, rien. Mon système est à jour.

D'accord les Libristes, je poses trois questions et c'est pas bien. Mais je pense que les trois problèmes sont liés.

Merci de vos réponses

Librement
Thierry Vedel

AttachmentSize
ErreurReparerPaquetsCassés..png17.42 KB
jpp
jpp
Offline
Joined: 05/28/2018

Moi ma Trisquel 8 fonctionne impeccable ! Peut être que tu n'as pas mis les bons dépots ?

thierra
Offline
Joined: 02/19/2015

Bonjour jpp,

Peux-tu m'indiquer les dépôts que tu as pour Trisquel 8.

Merci

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

As-tu ajouté des PPAs (ou autres dépôts) ? L’onglet « Autres logiciels » de « Dépôts » dans le menu « Configuration » du « Gestionnaire de paquets Synaptic » te le montre et te permet de les enlever. Si tu as de tels dépôts additionnels, il y a de bonnes chances pour que ce soit eux qui mettent le bazar, en proposant des versions plus récentes des paquets dans le dépôt Trisquel. Elles sont alors incompatibles avec d’autres paquets dans le dépôt Trisquel.

Il existe un paquet « ppa-purge ». La commande éponyme est à exécuter dans un terminal, précédée de 'sudo' et suivie du nom du PPA (exécute 'ppa-purge' sans argument pour des exemples). Elle permet non seulement d’enlever un PPA mais aussi d’installer les paquets qu’elle a fournis dans la version disponible dans le dépôt Trisquel. Juste enlever le PPA laisse installés les paquets qui y proviennent.

Tu peux ensuite voir si « Réparer les paquets cassés » arrive à quelque chose.

Si ce n’est pas le cas, clique sur le bouton « Filtres personnalisés » en bas à gauche de la fenêtre du « Gestionnaire de paquets Synaptic » puis, au-dessus, sur « Cassés ». Synaptic liste alors les paquets cassés installés sur ton système. Essaie donc de les supprimer un à un, sauf si cela t’enlève une bonne partie de ton système (les paquets dépendants de ceux dont tu demandes la suppression, et donc supprimés aussi, te sont listés avant que même que tu « appliques » les changements).

Une fois qu’il n’y a plus de paquets cassés, tu peux essayer de réinstaller les applications que tu utilises mais as supprimées.

thierra
Offline
Joined: 02/19/2015

Salut Banana Magic,

Je n'ai pas de ppa.

Recherche de fichiers cassés : 0 cassé, 0 à installer, 0 à désinstaller.

Je ne comprends rien.
Merci
Librement
Thierry Vedel

P.S. Refaire l'installation est peut-être la solution.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010
  1. GnuCash (ou plus probablement une de ses dépendances) ne peut peut-être pas être installé en même temps qu’un autre paquet déjà installé. Après demander l’installation de GnuCash (son carré devient rouge), vois les paquets cassés pour écouvrir une telle incompatibilité.
  2. Pour ce qui est du retour de veille, les messages doivent être lisibles depuis le terminal :
    $ journalctl
    Pour ne pas voir les messages anodins, utilise l’option -p suivi d’un entier. Par exemple, pour ne voir que les erreurs :
    $ journalctl -p 3
    Mais bon, si le système revient rapidement de veille, est-ce vraiment un problème ?
  3. As-tu essayé de mettre à jour avec le bouton du gestionnaire de paquets Synaptic ?
thierra
Offline
Joined: 02/19/2015

1. Voir le commentaire quand je sélectionne le paquet GnuCash. Document png joint. Problème de dépôt ? Je n'ai pas vraiment compris.

2. J'ai appliqué la commande et vu les messages. C'est vrai c'est pas important.

3. J'ai essayé, mettre à niveau; rien. Sélectionner la totalité des MAJ, rien. Gestionnaire de MAJ me dit que je suis à jour.

ErreurGnucash.png
jpp
jpp
Offline
Joined: 05/28/2018

Le plus simple c'est de poster Les messages des commandes qui poses problème et d'erreur Que tu as, Et d'après ça on pourra peut-être t'aider !

Par exemple que retourne la commande: sudo apt-get install gnucash ?

thierra
Offline
Joined: 02/19/2015

Bonjour Jpp,

Voilà pour la commande :
sudo apt-get install gnucash
[sudo] Mot de passe de thierry :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
gnucash : Dépend: guile-2.0 mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

thierra
Offline
Joined: 02/19/2015

J'avance un peu.
J'ai cherché guile-2.0 avec synaptic et suis tombé sur guile-2.0-libs qui est installé. Les propriétés annoncent un conflit avec guile-2.0-slib, voir le fichier joint. Ce dernier paquet n'est pas installé et n'apparaît dans synaptic. Ca dépasse largement mes connaissances et ne sais quoi faire.

Librement
Thierry

jpp
jpp
Offline
Joined: 05/28/2018

Et si tu fais: "sudo apt-get update" et après: "sudo apt-get upgrade"

que donne le retour ?

thierra
Offline
Joined: 02/19/2015

Voila le retour :

sudo apt-get update
[sudo] Mot de passe de thierry :

Atteint:1 https://archive.trisquel.info/trisquel flidas InRelease
Lecture des listes de paquets... Fait

thierry@thierry:~$ sudo apt-get upgrade

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
javascript-common libaio1 libapache2-mod-php libapache2-mod-php7.0
libcgi-fast-perl libcgi-pm-perl libcurl3 libfcgi-perl libfpdf-tpl-php
libfpdi-php libhtml-template-perl libjs-excanvas libjs-jquery
libjs-jquery-cookie libjs-jquery-flot libjs-jquery-ui libmcrypt4
libnusoap-php libphp-adodb mysql-client mysql-client-5.7
mysql-client-core-5.7 mysql-common mysql-server mysql-server-5.7
mysql-server-core-5.7 php php-common php-curl php-fpdf php-gd php-ldap
php-mail-mime php-mbstring php-mcrypt php-mysql php-pclzip php-pear
php-tcpdf php-xml php7.0 php7.0-cli php7.0-common php7.0-curl php7.0-gd
php7.0-json php7.0-ldap php7.0-mbstring php7.0-mcrypt php7.0-mysql
php7.0-opcache php7.0-readline php7.0-xml webfs
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

jpp
jpp
Offline
Joined: 05/28/2018

Désinstalle guile-2.0-libs: sudo apt-get remove guile-2.0-libs , (S'il est en conflit ça veut dire que tu n'en as pas besoin !)

jpp
jpp
Offline
Joined: 05/28/2018

Donc comme demandé tu fais: sudo apt autoremove

thierra
Offline
Joined: 02/19/2015

Je fais désinstaller mais il va aussi désinstaller aisleriot ( mon jeu préféré ) et Trisquel-recommended. Maintenant je suis en conflit avec moi-même. Je n'ai pas encore effectué la commande.

thierra
Offline
Joined: 02/19/2015

sudo apt autoremove effectué. Gnucash toujours cassé. Je supprime guile avec le terminal.

Substance2004
Offline
Joined: 11/05/2013

Je te donne ce petit lien pour mieux comprendre :

https://packages.debian.org/stretch/gnucash

Pour le paquet GNUcash tu as :

depends recommends suggests enhances

dans la liste,

guile-2.0 est en rouge, c'est une dépendance.

Mais il est en conflit avec guile-2.0-libs que nécessite ton jeu.

Je crois que tu vas devoir faire un choix.

C'est emmerdant si tu as déjà des documents fait avec GNUcash mais tu peu aussi choisir un autre logiciel de compta (à moins que certains soit compatibles avec les fichiers GNUcash) :

https://doc.ubuntu-fr.org/comptabilite

Bien entendu, je te conseille ceux qui sont dans les dépôts Trisquel qui sont garantis libres.

Substance2004
Offline
Joined: 11/05/2013

Il faut d'ailleurs faire attention avec le synaptic.

GNUcash est dans l'installateur de logiciel dont tu peut aussi l'installer/déinstaller avec.

ATTENTION : J'ai aisleriot installé par défaut.

Il y a des paquets qui sont dépendants de Trisquel. Les déinstaller peut être très emmerdant par la suite car il entraîne d'autres déinstallations.

Je garderai si j'étais toi aisleriot et choisirai un autre logiciel de compta.

thierra
Offline
Joined: 02/19/2015

Bonsoir Substance 2004,

Nos posts se sont croisés et je viens juste de te lire.

Après moult recherches, je n'ai trouvé que GnuCash comme logiciel de compta pour une très petite entreprise. Je veux le tester. C'est pour un copain auto-entrepreneur. Je viens d'installer Linux, à sa demande car il vomit W10, LinuxxMint, mea culpa, car il peut installer des logiciels propriétaires et c'est des fois très utiles pour communiquer avec l'administration équipée par M$.

Quant au choix entre GnuCash et aisleriot, je me suis dit que je pouvais toujours revenir en arrière, désinstaller GnuCash et réinstaller Aisleriot.

Juyeuses fêtes.
Librement
Thierry

thierra
Offline
Joined: 02/19/2015

Victoire !

J"ai supprimé guile. Aisleriot a été supprimé.
J'ai pu installer GnuCash.
J"ai pu réinstaller Aisleriot.

Merci à tous.

Librement
Thierry

jpp
jpp
Offline
Joined: 05/28/2018

"Mais il est en conflit avec guile-2.0-libs" ? Où est-ce que tu vois ça Substance2004 ?

Substance2004
Offline
Joined: 11/05/2013

Au temps pour moi.

Je croyais à un conflit entre guile-2.0 et guile-2.0-libs

Mais je suis un peu étonné car selon debian guile-2.0 nécessite guile-2.0-libs

https://packages.debian.org/stretch/guile-2.0

jpp
jpp
Offline
Joined: 05/28/2018

Mais je ne comprends pas pourquoi tu es étonné ? Toutes les dépendances doivent être installé, donc guile-2.0 et guile-2.0-libs !

Quand on installe un paquet toutes les dépendances doivent être satisfaite, Sinon ça ne fonctionne pas !

et quand on installe un paquet les dépendances sont installées automatiquement normalement, sauf quand il y a un problème avec le paquet !

Substance2004
Offline
Joined: 11/05/2013

Il a réussi, c'est le principal.

J'ai du mal comprendre à un moment donné.

jpp
jpp
Offline
Joined: 05/28/2018

Bon cool s'est résolu alors ! :)

thierra
Offline
Joined: 02/19/2015

Pour faire le point.

GnuCash installé, aislerot installé.

Je regarde avec synaptic les guile installés :
Guile-2.0-libs est installé !! Vraiment étonnant.
Guile-2.0 installé.

Pas compris mais ça marche.

Librement
Thierry

jpp
jpp
Offline
Joined: 05/28/2018

Bah la chose à comprendre, C'est que tu n'avais pas fait tes mises à jour: sudo apt-get update suivi de sudo apt-get upgrade

sudo apt-get update : Lit la liste des mises à jour disponibles.

sudo apt-get upgrade : Met strictement à jour les paquets actuels.

apt-get est un gestionnaire de paquets en console.
À ce titre, c'est un outil qui permet de vous informer, d'installer, de supprimer et de mettre à jour vos paquets.
De façon général, il gère la mise à jour de votre système et s'utilise pour cela en super-utilisateur alors qu'il vous informe sur ceux-ci en simple utilisateur.

thierra
Offline
Joined: 02/19/2015

Je regrette de te contredire mais j'avais fait les mises à jour. Regarde un peu plus haut, c'est dans un de mes posts le numéro 12, #12.

jpp
jpp
Offline
Joined: 05/28/2018

Oui tu as fait les mises à jour quand je t'ai dis de les faire, Mais avant tu ne les avais pas faite, Donc ça ne pouvait pas fonctionner, Si tu installes un paquet, Sans avoir fait les mises à jour, Tu n'auras pas la dernière version du paquet, Et ça peut causer problème, D'où l'importance de faire ses mises à jour régulièrement

thierra
Offline
Joined: 02/19/2015

Bon JPP je vais encore te contredire. Je fais les mises à jour régulièrement.
Dans ce cas ci, le système m"annoncait que j'étais à jour.
J'ai quand même fait les mises à jour avec le terminal.
Ensuite j'avais toujours le même problème malgré un remove.
J'ai trouvé que guile-2.0-libs était en conflit.
Je l'ai supprimé et j'ai perdu aisleriot.
C"est seulement à ce moment là que j'ai pu installer GnuCash.
Ensuite j'ai réinstallé aislerot sans problème.
J'ai vu que guile-2.0-libs était à nouveau installé d'où mon étonnement.
C'est ça que je ne comprends pas.

J'étais prof de math (sans s) mais surtout je suis toujours mathématicien et donc curieux dans le bon sens du terme et je voudrais comprendre.

Librement
Thierry

P.S.
En remontant les posts, je m’aperçois que j'ai oublié de joindre un fichier d'erreur. Fichier que j'ai supprimé de mon ordinateur. En gros le message disait que des fichiers avait comme attribut " Laisser en l'état ' et que le système ne pouvez pas les réparer. Mea culpa, c'est sûrement là le problème.