Installation mysql-server impossible

9 replies [Last post]
Sems
Offline
Joined: 07/10/2018

Bonjour,

Je tente désespérément d'installer mysql-server, par le gestionnaire de paquets synaptic ou par le terminal et je rencontre toujours la même erreur:

dpkg: erreur de traitement de l'archive /var/cache/apt/archives/mysql-server-5.7_5.7.25-0ubuntu0.16.04.2_amd64.deb (--unpack) :
le sous-processus nouveau script pre-installation a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/mysql-server-5.7_5.7.25-0ubuntu0.16.04.2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Je ne sais pas ce que cela signifie ni comment régler ce problème, avez-vous une solution à me proposer?

Cordialement

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

N’y a-t-il pas d’erreur avant ? Y a-t-il de la place disponible sur ta partition racine (la sortie de la commande 'df' l’indiquerait) ?

Sems
Offline
Joined: 07/10/2018

Bonjour Magic Banana et merci pour ta réponse.
Ce ne doit pas être un problème de place, je dispose de 30 Go. Voici le retour de la commande df

Sys. de fichiers blocs de 1K Utilisé Disponible Uti% Monté sur
udev 1938576 0 1938576 0% /dev
tmpfs 391096 6352 384744 2% /run
/dev/sdb5 38932936 6764948 30167248 19% /
tmpfs 1955472 56376 1899096 3% /dev/shm
tmpfs 5120 4 5116 1% /run/lock
tmpfs 1955472 0 1955472 0% /sys/fs/cgroup
/dev/sdb2 97280 26613 70667 28% /boot/efi
/dev/sda1 961301832 673421244 239026164 74% /home
tmpfs 391096 36 391060 1% /run/user/107
tmpfs 391096 120 390976 1% /run/user/1000

Je viens de retenter une installation via le terminal, en fait mysql est bien installé mais il y a un problème de dépendances

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
mysql-server est déjà la version la plus récente (5.7.25-0ubuntu0.16.04.2).
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
mysql-server : Dépend: mysql-server-5.7 mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).

La commande apt-get -f install renvoie la même erreur. J'ai tout désinstallé et réinstallé et je retombe toujours sur cette erreur. Voici le retour de la commande d'installation:

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
libevent-core-2.0-5 libhtml-template-perl mysql-server-5.7 mysql-server-core-5.7
Paquets suggérés :
libipc-sharedcache-perl mailx tinyca
Les NOUVEAUX paquets suivants seront installés :
libevent-core-2.0-5 libhtml-template-perl mysql-server mysql-server-5.7 mysql-server-core-5.7
0 mis à jour, 5 nouvellement installés, 0 à enlever et 3 non mis à jour.
Il est nécessaire de prendre 60,4 ko/10,0 Mo dans les archives.
Après cette opération, 95,1 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Réception de :1 https://archive.trisquel.info/trisquel flidas/main amd64 libhtml-template-perl all 2.95-2 [60,4 kB]
60,4 ko réceptionnés en 0s (73,6 ko/s)
Préconfiguration des paquets...
Sélection du paquet mysql-server-core-5.7 précédemment désélectionné.
(Lecture de la base de données... 245523 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../mysql-server-core-5.7_5.7.25-0ubuntu0.16.04.2_amd64.deb ...
Dépaquetage de mysql-server-core-5.7 (5.7.25-0ubuntu0.16.04.2) ...
Sélection du paquet libevent-core-2.0-5:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libevent-core-2.0-5_2.0.21-stable-2ubuntu0.16.04.1_amd64.deb ...
Dépaquetage de libevent-core-2.0-5:amd64 (2.0.21-stable-2ubuntu0.16.04.1) ...
Préparation du dépaquetage de .../mysql-server-5.7_5.7.25-0ubuntu0.16.04.2_amd64.deb ...
Aborting downgrade from (at least) 10.0 to 5.7.
If are sure you want to downgrade to 5.7, remove the file
/var/lib/mysql/debian-*.flag and try installing again.
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/mysql-server-5.7_5.7.25-0ubuntu0.16.04.2_amd64.deb (--unpack) :
le sous-processus nouveau script pre-installation a retourné une erreur de sortie d'état 1
Sélection du paquet libhtml-template-perl précédemment désélectionné.
Préparation du dépaquetage de .../libhtml-template-perl_2.95-2_all.deb ...
Dépaquetage de libhtml-template-perl (2.95-2) ...
Sélection du paquet mysql-server précédemment désélectionné.
Préparation du dépaquetage de .../mysql-server_5.7.25-0ubuntu0.16.04.2_all.deb ...
Dépaquetage de mysql-server (5.7.25-0ubuntu0.16.04.2) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu11) ...
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/mysql-server-5.7_5.7.25-0ubuntu0.16.04.2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

A partir de là, je ne sais pas comment faire pour solutionner cette erreur.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Aborting downgrade from (at least) 10.0 to 5.7.

Il semblerait qu'une version plus récente de MySQL ou d'un de ses forks, comme MariaDB (en version 10.0 dans le dépôt Trisquel) ait été préalablement installée. N'ayant jamais installé un de ces systèmes de gestion de bases de données, je doute que je réussirai à t'aider. Mais c'est une piste.

Sems
Offline
Joined: 07/10/2018

Effectivement, j'avais installé MariaDB, le problème est qu'il me demandait un mot de passe root que je n'ai jamais mis et le mot de passe de mon PC n'a jamais fonctionné avec MariaDB, du coup, je l'ai désinstallé.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Il a dû rester des bouts.

Sems
Offline
Joined: 07/10/2018

Qu'est-ce que je peux faire pour les supprimer?

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Je commencerais par demander de l’aide sur la section anglophone du forum, en expliquant cette fois que MariaDB a été installée puis supprimée (d’ailleurs as-tu utilisé la « suppression complète », par exemple « purge » sur la ligne de commande, ou juste la suppression, par exemple avec « remove » sur la ligne de commande : dans le second cas, essaie « purge »). Il est possible que quelqu’un soit passé par là.

Sems
Offline
Joined: 07/10/2018

J'ai utilisé la commande "purge" pour la désinstallation. Je vais donc aller voir sur la section anglophone.
Merci pour ton apport.

Bonne journée

nmrk.n
Offline
Joined: 11/01/2013

À tout hasard si ça peut servir, mais cela vient de Mageia 6 :

Message lors d'une mise à jour très récente : voir pièce jointe ...

et quelques échanges (source liste mageia discuss fr):

"2) Si il suffisait d'exécuter la commande indiquée en root # mysql_secure_installation [Entrée] et taper le mot de passe root le moment venu ce ne serait pas un problème ..."

"mariadb c'est notre équivalent de mysql en plus souple ^^)

"il est installé par défaut parce que des composants du système l'utilisent pour stocker leurs données."

[ATTENTION :]

"prends bien garde que quand on parle de mot de passe 'root' pour mariadb (ou mysql) tu ne dois pas utiliser le même mot de passe que ton utilisateur 'root' !

il faut te créer un mot de passe 'root' rien que pour mariadb et que toi et mariadb soit les seuls à connaître.

comme ça même si un pirate réussi à prendre la main sur mariadb il ne peut pas faire de même avec ton système tout entier ^^)"

[/FIN ATTENTION]

"avant de faire des modifications/mises à jour des bases aux systèmes de bases de données comme mariadb il faut d'abord stopper le daemon système qui le fait tourner, faire les opérations de maintenance comme décrites dans le readme et ensuite soit rebooter (si c'est ta machine) soit redémarer le daemon à la main (si tu maintiens un serveur qu'il vaut mieux ne pas rebooter trop souvent."

Voir pièce jointe ...

"c'est pareil que si une de tes bases venait à être endommagée, il faut dabord stopper le 'moteur' (daemon mariadb) pour empêcher toutes nouvelles modifications de la base en question par ses utilisateurs, puis la réparer et enfin redémarrer le 'moteur' pour la rendre de nouveau disponible. ^^)"

merci à jeff (liste mageia discuss fr)

Des fois que cela puisse éclairer votre chemin mais en ce qui me concerne je ne peux pas faire plus car je n'y connais pas grand chose.

2019-05-26-Probleme_install_mariadb.png