Le gestionnaire de mises à jour ne répond pas

18 replies [Last post]
grimlock
Offline
Joined: 05/15/2015

Bonjour aujourd'hui le Gestionnaire de mises à jour ne répond pas, vous avez la même chose ?

Quel est la commande pour vérifier les mises à jour sans les droits root (sudo) ?
Merci.

AttachmentSize
Gestio mises à jour.png20.54 KB
Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Le "Gestionnaire de mises à jour" fonctionne sur mon système. Vois donc s'il y a une erreur à l'exécution de 'update-manager' dans un émulateur de terminal. Sinon 'sudo apt update'.

grimlock
Offline
Joined: 05/15/2015

Je suis sous Trisquel GNU/Linux Version 8.0, Flidas 64-bit.
Noyau Linux 4.4.0-176-generic x86_64

La commande 'sudo apt update' :
Tous les paquets sont à jour.

La commande 'update-manager' :

Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "topmenu-gtk-module"
/usr/bin/update-manager:28: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
from gi.repository import Gtk
/usr/lib/python3/dist-packages/UpdateManager/UnitySupport.py:29: PyGIWarning: Dbusmenu was imported without specifying a version first. Use gi.require_version('Dbusmenu', '0.4') before import to ensure that the right version gets loaded.
from gi.repository import Dbusmenu, Unity
/usr/lib/python3/dist-packages/UpdateManager/UnitySupport.py:29: PyGIWarning: Unity was imported without specifying a version first. Use gi.require_version('Unity', '7.0') before import to ensure that the right version gets loaded.
from gi.repository import Dbusmenu, Unity
Exception in thread Thread-1:
Traceback (most recent call last):
File "/usr/lib/python3.5/threading.py", line 914, in _bootstrap_inner
self.run()
File "/usr/lib/python3.5/threading.py", line 862, in run
self._target(*self._args, **self._kwargs)
File "/usr/lib/python3/dist-packages/UpdateManager/Core/MetaRelease.py", line 335, in download
uri = urlopen(req, timeout=20)
File "/usr/lib/python3.5/urllib/request.py", line 163, in urlopen
return opener.open(url, data, timeout)
File "/usr/lib/python3.5/urllib/request.py", line 466, in open
response = self._open(req, data)
File "/usr/lib/python3.5/urllib/request.py", line 484, in _open
'_open', req)
File "/usr/lib/python3.5/urllib/request.py", line 444, in _call_chain
result = func(*args)
File "/usr/lib/python3.5/urllib/request.py", line 1297, in https_open
context=self._context, check_hostname=self._check_hostname)
File "/usr/lib/python3.5/urllib/request.py", line 1254, in do_open
h.request(req.get_method(), req.selector, req.data, headers)
File "/usr/lib/python3.5/http/client.py", line 1122, in request
self._send_request(method, url, body, headers)
File "/usr/lib/python3.5/http/client.py", line 1167, in _send_request
self.endheaders(body)
File "/usr/lib/python3.5/http/client.py", line 1118, in endheaders
self._send_output(message_body)
File "/usr/lib/python3.5/http/client.py", line 944, in _send_output
self.send(msg)
File "/usr/lib/python3.5/http/client.py", line 887, in send
self.connect()
File "/usr/lib/python3.5/http/client.py", line 1276, in connect
server_hostname=server_hostname)
File "/usr/lib/python3.5/ssl.py", line 377, in wrap_socket
_context=self)
File "/usr/lib/python3.5/ssl.py", line 752, in __init__
self.do_handshake()
File "/usr/lib/python3.5/ssl.py", line 988, in do_handshake
self._sslobj.do_handshake()
File "/usr/lib/python3.5/ssl.py", line 638, in do_handshake
match_hostname(self.getpeercert(), self.server_hostname)
File "/usr/lib/python3.5/ssl.py", line 301, in match_hostname
% (hostname, dnsnames[0]))
ssl.CertificateError: hostname 'packages.trisquel.info' doesn't match 'devel.trisquel.info'

eean
Offline
Joined: 07/06/2011

Bonjour grimlock.

Il te manque apparemment le module canberra-gtk-module.

Essaie d'installer les paquets suivants :

sudo apt install libcanberra-gtk-module libcanberra-gtk3-module

Puis relance le gestionnaire de mises à jour.

grimlock
Offline
Joined: 05/15/2015

Bonjour eean, je viens d'installer les paquets puis relancé le gestionnaire.

Gtk-Message: Failed to load module "topmenu-gtk-module"
/usr/bin/update-manager:28: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
from gi.repository import Gtk
/usr/lib/python3/dist-packages/UpdateManager/UnitySupport.py:29: PyGIWarning: Dbusmenu was imported without specifying a version first. Use gi.require_version('Dbusmenu', '0.4') before import to ensure that the right version gets loaded.
from gi.repository import Dbusmenu, Unity
/usr/lib/python3/dist-packages/UpdateManager/UnitySupport.py:29: PyGIWarning: Unity was imported without specifying a version first. Use gi.require_version('Unity', '7.0') before import to ensure that the right version gets loaded.
from gi.repository import Dbusmenu, Unity
Exception in thread Thread-1:
Traceback (most recent call last):
File "/usr/lib/python3.5/threading.py", line 914, in _bootstrap_inner
self.run()
File "/usr/lib/python3.5/threading.py", line 862, in run
self._target(*self._args, **self._kwargs)
File "/usr/lib/python3/dist-packages/UpdateManager/Core/MetaRelease.py", line 335, in download
uri = urlopen(req, timeout=20)
File "/usr/lib/python3.5/urllib/request.py", line 163, in urlopen
return opener.open(url, data, timeout)
File "/usr/lib/python3.5/urllib/request.py", line 466, in open
response = self._open(req, data)
File "/usr/lib/python3.5/urllib/request.py", line 484, in _open
'_open', req)
File "/usr/lib/python3.5/urllib/request.py", line 444, in _call_chain
result = func(*args)
File "/usr/lib/python3.5/urllib/request.py", line 1297, in https_open
context=self._context, check_hostname=self._check_hostname)
File "/usr/lib/python3.5/urllib/request.py", line 1254, in do_open
h.request(req.get_method(), req.selector, req.data, headers)
File "/usr/lib/python3.5/http/client.py", line 1122, in request
self._send_request(method, url, body, headers)
File "/usr/lib/python3.5/http/client.py", line 1167, in _send_request
self.endheaders(body)
File "/usr/lib/python3.5/http/client.py", line 1118, in endheaders
self._send_output(message_body)
File "/usr/lib/python3.5/http/client.py", line 944, in _send_output
self.send(msg)
File "/usr/lib/python3.5/http/client.py", line 887, in send
self.connect()
File "/usr/lib/python3.5/http/client.py", line 1276, in connect
server_hostname=server_hostname)
File "/usr/lib/python3.5/ssl.py", line 377, in wrap_socket
_context=self)
File "/usr/lib/python3.5/ssl.py", line 752, in __init__
self.do_handshake()
File "/usr/lib/python3.5/ssl.py", line 988, in do_handshake
self._sslobj.do_handshake()
File "/usr/lib/python3.5/ssl.py", line 638, in do_handshake
match_hostname(self.getpeercert(), self.server_hostname)
File "/usr/lib/python3.5/ssl.py", line 301, in match_hostname
% (hostname, dnsnames[0]))
ssl.CertificateError: hostname 'packages.trisquel.info' doesn't match 'devel.trisquel.info'

Comment citer un message ? (Pour éviter les grandes lignes, merci).
Bonne soirée et à demain.

eean
Offline
Joined: 07/06/2011

Je pensais que les paquets que j'avais indiqué seraient suffisants mais ce n'est apparemment pas le cas.

Essaie d'installer aussi celui-ci avant de relancer le gestionnaire de mises à jour :

sudo apt install topmenu-gtk3

grimlock
Offline
Joined: 05/15/2015

Bonjour, non toujours pas.

/usr/bin/update-manager:28: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
from gi.repository import Gtk
/usr/lib/python3/dist-packages/UpdateManager/UnitySupport.py:29: PyGIWarning: Dbusmenu was imported without specifying a version first. Use gi.require_version('Dbusmenu', '0.4') before import to ensure that the right version gets loaded.
from gi.repository import Dbusmenu, Unity
/usr/lib/python3/dist-packages/UpdateManager/UnitySupport.py:29: PyGIWarning: Unity was imported without specifying a version first. Use gi.require_version('Unity', '7.0') before import to ensure that the right version gets loaded.
from gi.repository import Dbusmenu, Unity
Exception in thread Thread-1:
Traceback (most recent call last):
File "/usr/lib/python3.5/threading.py", line 914, in _bootstrap_inner
self.run()
File "/usr/lib/python3.5/threading.py", line 862, in run
self._target(*self._args, **self._kwargs)
File "/usr/lib/python3/dist-packages/UpdateManager/Core/MetaRelease.py", line 335, in download
uri = urlopen(req, timeout=20)
File "/usr/lib/python3.5/urllib/request.py", line 163, in urlopen
return opener.open(url, data, timeout)
File "/usr/lib/python3.5/urllib/request.py", line 466, in open
response = self._open(req, data)
File "/usr/lib/python3.5/urllib/request.py", line 484, in _open
'_open', req)
File "/usr/lib/python3.5/urllib/request.py", line 444, in _call_chain
result = func(*args)
File "/usr/lib/python3.5/urllib/request.py", line 1297, in https_open
context=self._context, check_hostname=self._check_hostname)
File "/usr/lib/python3.5/urllib/request.py", line 1254, in do_open
h.request(req.get_method(), req.selector, req.data, headers)
File "/usr/lib/python3.5/http/client.py", line 1122, in request
self._send_request(method, url, body, headers)
File "/usr/lib/python3.5/http/client.py", line 1167, in _send_request
self.endheaders(body)
File "/usr/lib/python3.5/http/client.py", line 1118, in endheaders
self._send_output(message_body)
File "/usr/lib/python3.5/http/client.py", line 944, in _send_output
self.send(msg)
File "/usr/lib/python3.5/http/client.py", line 887, in send
self.connect()
File "/usr/lib/python3.5/http/client.py", line 1276, in connect
server_hostname=server_hostname)
File "/usr/lib/python3.5/ssl.py", line 377, in wrap_socket
_context=self)
File "/usr/lib/python3.5/ssl.py", line 752, in __init__
self.do_handshake()
File "/usr/lib/python3.5/ssl.py", line 988, in do_handshake
self._sslobj.do_handshake()
File "/usr/lib/python3.5/ssl.py", line 638, in do_handshake
match_hostname(self.getpeercert(), self.server_hostname)
File "/usr/lib/python3.5/ssl.py", line 301, in match_hostname
% (hostname, dnsnames[0]))
ssl.CertificateError: hostname 'packages.trisquel.info' doesn't match 'devel.trisquel.info'

eean
Offline
Joined: 07/06/2011

Mince. Et bien en fait je constate que j'ai les mêmes messages d'erreur ou d'avertissement que toi, sauf que chez moi update-manager se lance.

Est-ce que la commande update-manager te rend la main dans le terminal juste après la dernière ligne (ssl.CertificateError...) ?

grimlock
Offline
Joined: 05/15/2015

Bonjour je viens de lancer le 'Gestionnaire' puis, tout se déroule normalement jusqu'à la mise à jour, mais il y a encore le message 'Failed...'.

Maintenant, ça recommence il ne répond plus.

noyau en cours.png terminal gestio.png
Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Le "Gestionnaire de mise à jour" reste-t-il bloqué sur "Terminé" ? Si ce n'est pas le cas, il a l'air de fonctionner normalement.

grimlock
Offline
Joined: 05/15/2015

Oui, il reste bloqué sur "Terminé" ou "Téléchargement depuis archive.trisquel.info/trisquel".

grimlock
Offline
Joined: 05/15/2015

Finalement, je vais laisser de côté ce petit soucis et utiliser 'sudo apt update'. Merci, et salut.

Trisquel-1920
Offline
Joined: 12/09/2019

Bonjour, à tous,

Juste pour donner des points de comparaisons, pas des solutions :-(

"le Gestionnaire de mises à jour ne répond pas, vous avez la même chose ?"
>> Oui, j'ai actuellement le même problème que toi grimlock.

sudo apt update => Tous les paquets sont à jour.

sudo apt install libcanberra-gtk-module libcanberra-gtk3-module => libcanberra-gtk-module est déjà la version la plus récente (0.30-2.1ubuntu1).
libcanberra-gtk3-module est déjà la version la plus récente (0.30-2.1ubuntu1).

sudo apt install topmenu-gtk3 => topmenu-gtk3 est déjà la version la plus récente (0.2.1+git20151210.8c6108f-3).

Je suis pourtant sur Trisquel GNU/Linux Version 9 (dév), 64 bits
et noyau 4.15.0-91-generic.

update-manager => Image en pièce jointe Blocage.png

Blocage.png
Sasaki
Offline
Joined: 08/11/2014

ssl.CertificateError: hostname 'packages.trisquel.info' doesn't match 'devel.trisquel.info'

Je vois ça en fin de chacun de tes messages d'erreur. Qu'indique ton sources.list ? Mon premier réflexe serait d'aller chercher de ce côté.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

J'ai aussi ce message d'erreur. Mais pas de blocage.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Je n'avais pas redémarré Trisquel depuis plusieurs jours. J'observe maintenant le même soucis.

grimlock
Offline
Joined: 05/15/2015

Bonjour, aujourd'hui 'update-manager' fonctionne normalement. Je n'ai rien fait de particulier juste 'sudo apt update'(23 mises à jour). A+

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Sur mon système aussi, apparemment.

Trisquel-1920
Offline
Joined: 12/09/2019

Bonjour,

aujourd'hui 'update-manager' fonctionne aussi normalement.

Mises à jour complètes reboot et vérif des mises à jour.