Librebooted and trisquelised MacBook2,1: Where is the '@'?

27 replies [Last post]
GNUbahn
Offline
Joined: 02/19/2016

Though it is not working at lightning speed, I am generally happy with the performance of my librebooted MacBook2,1. One issue I am struggling with, though, is that I can't figure out where to find the '@' on the keyboard.

Any suggestions?

GNUbahn
Offline
Joined: 02/19/2016

Doesn't work.

I am using a Danish keyboard layout, on which '@' is on the '2' key as well; AltGr + 2.

Is there a way to check which key a certain character is assigned to?

megurineturilli
Offline
Joined: 01/10/2012

Mac keyboards are different from PC keyboards. The Command key is mapped to the Windows key and the right alt/Option key can be used as Alt Gr key. Trisquel only supports PC keymaps, and the Alt Gr key needs to be configured properly.

https://en.wikipedia.org/wiki/File:KB_Danish.svg

GNUbahn
Offline
Joined: 02/19/2016

Alt Gr key needs to be configured properly

How do I do that?

loldier
Offline
Joined: 02/17/2016

It should be right option/alt+2.

@

GNUbahn
Offline
Joined: 02/19/2016

But it doesn't work

loldier
Offline
Joined: 02/17/2016

I suppose it must be specific to LibreBoot, then.

I can attest that I'm on Trisquel, type on an external USB Apple wired keyboard (aluminium white without numpad), keyboard layout dk (setxkbmap dk) -- and I can type @@@@@@@@@@@@@@@@@@@@@@@

ææææææææææææææææææ
øøøøøøøøøøøøøøøøøø
ææææææøøø
åååååååååååååååååååå
ææææææøøøøøøøøæøæøæøæøøæøæ''''''****//////??????%%%%%%%

Only æ and ø have changed places from my usual FI layout (they are reversed).

GNUbahn
Offline
Joined: 02/19/2016

The key combination you call 'right option' is right apple-key?

Anyway, I can't make it work. I better ask at the libreboot irc

Strange though!

loldier
Offline
Joined: 02/17/2016

The Apple key is the Command key with the looped square symbol. You don't want this now.

With Macs, Option key = Alt. It has a symbol that looks like Starship Enterprise from Star Trek the sci-fi TV series.

https://en.wikipedia.org/wiki/Option_key
https://en.wikipedia.org/wiki/Looped_square

Are you sure you even have the right hand side Option key?

Look at the last attachment. The @ sign is on the star sign next to ø.

apple_kb.jpg dk_kb.png Apple_key.jpg option.JPG danish_notebook.png
GNUbahn
Offline
Joined: 02/19/2016

Thanks.

No, I don't have a right side Option key.

To the right of the space bar I have a (right) Command key and to the right of that there is one with a symbol equal to one that is on the lower part of the Enter key. It also seems to function as an Enter key.

I found this: https://elementaryos.stackexchange.com/questions/376/how-to-type-on-a-macbook-2-1
which made me think: Can I assign a different function to that strange kind of Enter key?

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

From the "Input Sources" tab of the "Region & Language" utility in the "System Settings", a click on the small "keyboard" button shows the complete layout you are using.

GNUbahn
Offline
Joined: 02/19/2016

Does this depend on the DE? I don't have that option in Xfce

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Yes: it is GNOME Control Center (by default in Trisquel). The following command is desktop-independent and should print the current layout in a PS file named "server-0.ps":
$ xkbprint :0
However the characters obtained with AltGr are not shown.

vita_cell
Offline
Joined: 07/19/2015

In my Macbook2,1 "@" it is Shift+2 on US keyboard. On ES is right (right command)AltGr+2, as a standard keyboard.

GNUbahn
Offline
Joined: 02/19/2016

That is weird. I don't even have the right command key!

GNUbahn
Offline
Joined: 02/19/2016
loldier
Offline
Joined: 02/17/2016

Why not take a picture of your own keyboard instead of linking to ebay?

GNUbahn
Offline
Joined: 02/19/2016

Good question. There are two correlated answers:

1) I am running a Galaxy S2 with Replicant which has some memory issues causing my camera to not work

2) I didn't find a picture of it in other places

Ignacio.Agullo
Offline
Joined: 09/29/2009

On 06/06/17 21:51, name at domain wrote:
> Good question. There are two correlated answers:
>
> 1) I am running a Galaxy S2 with Replicant which has some memory
> issues causing my camera to not work

I installed Replicant on my Galaxy S3. Everytime I tried to use
the camera for video, or to use the secondary camera, the camera
application would crash and never to recover, even after a reboot of the
system. I found that the only way to get the camera back was to access
the settings of the camera application and delete the application data.

--
Ignacio Agulló · name at domain

vita_cell
Offline
Joined: 07/19/2015

Yes you have "right command", it is like "left command". In US keyboard for "@" you need to push any "shift + 2", for ES "right command + 2".

Eemeli
Offline
Joined: 01/04/2014

I struggled with that issue two years ago. For Trisquel there is a good solution: run "sudo dpkg-reconfigure keyboard-configuration" and then in one of the menus choose something like "Use Keypad Enter as AltGr".

I.e. the issue is that the Macbook 2.1 keyboard does not have an AltGr-key. In the physical keyboard, there is a keypad enter, just like you said: the key that acts as an enter. After using dpkg-reconfigure that key will act as AltGr and not as enter.

For more information see the wiki we wrote a year or so ago: https://trisquel.info/en/wiki/macbook

Actually most of the issues listed there have been solved in newer versions of libreboot. I should update the wiki...

GNUbahn
Offline
Joined: 02/19/2016

Thanks Eemeli. You saved my day!

1) Run 'sudo dpkg-reconfigure keyboard-configuration' in terminal

2) Choose 'apple laptop'

3) Choose your settings and remember to choose 'Use Keypad Enter as AltGr'

loldier
Offline
Joined: 02/17/2016

That was a really good piece of advice.

keyboard_config.png
GNUbahn
Offline
Joined: 02/19/2016

To me, this is the kind of information that can be crucial for success. I am sure that goes for other non-savvies as well.

libreleah
Offline
Joined: 04/03/2017

hi,

can you document any solution that you find to this on libreboot.org?

https://libreboot.org/git.html#editing-the-website-and-documentation-wiki-style

Eemeli
Offline
Joined: 01/04/2014
GNUbahn
Offline
Joined: 02/19/2016

The problem of "@" has returned on my MacBook 2,1. I have had it for quite some time now.

I have followed the instructions that worked before agien and again, but I just can't get it to work.

Anyone else with this problem - and any suggestions for a solution?

Eemeli
Offline
Joined: 01/04/2014

I guess that the old instructions which used "sudo dpkg-reconfigure keyboard-configuration" caused this to happen:

- adds the line "KEYMAP_TOGGLE=lv3:enter_switch" to "/etc/vconsole.conf"

However there was maybe a recent update which made this line stop working. At least it stopped working on my laptop with Parabola.

There is another way to make the keypad enter act as an AltGr, however it requires more fiddling around. If you mess up and can't type properly after rebooting, you might need to start your computer with a live cd to fix the problem. Here goes:

WARNING: tested only on Parabola GNU/Linux! Not tested on Trisquel!

1) the idea is to make your own keymap file. Read "man loadkeys". At least on Parabola with the Mate desktop, once the AltGr works in the console, it will work also in the desktop.

2) go to console, e.g. Alt + Ctrl + F2 (or F3, F4, etc until your are prompted for the login), and log in with an account that can use sudo.

3) make sure you have the correct keyboard loaded, i.e. in your case the Danish one. For me I ran "sudo loadkeys fi" to make sure that the default Finnish keymap is loaded.

4) we are going to read the raw keycodes in console: run "showkey" and press the keypad enter (on my laptop it gives the keycode 96). Wait 10 seconds for showkey to quit.

5) Save the current keymap into a file: run "dumpkeys > keymap.orig"

6) Then search for "= AltGr". On my laptop you find it looking like this:

keycode 100 = AltGr AltGr AltGr AltGr AltGr AltGr AltGr

7) Copy that line (use nano or emacs or vim, whichever text editor you are familiar with in the console), and go to the line starting with "keycode 96 =", and paste it there. Change the AltGr keycode into 96 from 100 (use the keycode you got from step 4!), and remove the line for keypad enter. Alternatively on the starting with "keycode 96 =" change all mentions of "KP_Enter" into "AltGr". Save this file as "enter_switch.map". For me the difference of these files looks like this:

$ diff enter_switch.map keymap.orig
504c504
< keycode 96 = AltGr AltGr AltGr AltGr AltGr AltGr AltGr
---
> keycode 96 = KP_Enter KP_Enter Hex_F KP_Enter KP_Enter KP_Enter KP_Enter

7') Before going forward and making changes to your system, try if this keymap works: "sudo loadkeys enter_swith.map". If it works, go to step 8. If not, try to figure out what went wrong. Reload defaults by running "sudo loadkeys -d".

8) Copy the file "enter_switch.map" into "/etc/enter_switch.map", and modify "/etc/vconsole.conf" to add the line

KEYMAP=/etc/enter_switch.map

9) Then reboot and your keypad enter should work as an AltGr in console.

10) If you messed up, run "loadkeys -d" if you can and then remove the changes made in step 8. If you can't type anything meaningful, you should boot a live cd, mount your hard drive, and remove the line "KEYMAP=/etc/enter_switch.map" from "/etc/vconsole.conf".