Package linux-libre being kept back

2 replies [Last post]
ao
ao
Offline
Joined: 07/20/2017

Dear Trisquel community,

On Trisquel 9, I usually update like this:
$ sudo apt update
$ sudo apt upgrade
But lately I get the message that linux-libre is being kept back. Why is that?

According to Synaptic, linux-libre 5.19.2 is installed and 5.19.6 in available. If I right-click the package and select properties (in Synaptic), then it says that linux-libre conflicts with linux-libre, and is dependent of linux-libre.I get the tip to choose force version, but that also comes with a warning.

Does anybody haze the same experience or tips on how to solve this?

jxself
Online
Joined: 09/13/2010

What you're encountering is the package transition I initiated

http://www.fsfla.org/pipermail/linux-libre/2022-August/003496.html

Do this:

sudo apt update
sudo apt full-upgrade

You should then see the package manager prompting about the removal of the package called freesh-keyring, the installation of freesh-archive-keyring, and otherwise updating the kernel packages.

https://social.bobcall.me/@jxself/108895568701241202

ao
ao
Offline
Joined: 07/20/2017

Thanks jxself!