Php 5.6 (oder 7) statt 5.5.9 in Trisquel ?

5 replies [Last post]
rytege
Offline
Joined: 10/05/2017

In meinem Betriebssystem wird es PHP 5.5.9 installiert.
Ich brauche mindesten das 5.6 Version (entweder php 5.6 oder php 7). Wie kann ich es installieren?
Danke für ihre Antworten.

martinh
Offline
Joined: 02/21/2014

Welche Version von Trisquel hast du eigentlich ?

Wenn du unbedingt PHP brauchst kommst du wahrscheinlich nicht
drum herum ein PPA zu benutzen.
Das Problem ist dann nur in wie weit man moeglicherweise nicht-libre software
auf dem rechner hat ?

Zum beispiel: https://launchpad.net/~ondrej/+archive/ubuntu/php

Das waere eine Moeglichkeit... aber, wie gesagt, in wie weit das dann libre ist ?

rytege
Offline
Joined: 10/05/2017

Danke für diese Antwort.
Ich will nur libre Software benuzten. Ist das 'ondrej' PPA/php libre Software, wie kann man es wissen?

Ich habe von dem Trisquel 7.0 belenos CD Trisquel installiert. Außer es, wie kann ich wissen, welche Version ich benutze?

Danke für deine Hilfe!

martinh
Offline
Joined: 02/21/2014

Hmmm, ich weis nicht ob das 'ondrej' PHP libre software ist.

Nur weil wenn du Trisquel 8 haettest, das muesste PHP 7 schon haben.

Oh, du kannst im terminal: uname -a
eingeben, das gibt ein bisschen info.

rytege
Offline
Joined: 10/05/2017

Danke martinh für deine Erklärungen!
Ich werde mit PHP 5.5.9 versuchen, zu arbeiten. Mal los sehen ;-)
Viel Spaß.

rytege
Offline
Joined: 10/05/2017

Ich kann meinen Projekt mit PHP 5.5.9 mitarbeiten! Super.