Plantage régulier de LibreOffice

11 replies [Last post]
Sems
Offline
Joined: 07/10/2018

Bonjour,

Depuis que j'ai installé Trisquel 8.0 64 bits, j'ai des plantages réguliers de LibreOffice. Je l'ai désinstallé et réinstallé, mais rien n'y fait. La version actuellement installée est la 5.1.6.2.
Les plantages sont consécutifs à l'accès à des fonctions, de manière aléatoire. Une fonction peut fonctionner plusieurs fois sans plantage puis finir par planter l'application. J'en suis à un point où je fais une sauvegarde après chaque action...

Mon PC est un ACER F17 F5-771G-52H9

Merci d'avance pour l'aide que vous pourriez m'apporter

Cordialement

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Une RAM défaillante gère des plantages aléatoires. L’as-tu testée (avec MemTest86+, qui s’exécute depuis le menu du chargeur de démarrage) ?

Sems
Offline
Joined: 07/10/2018

Merci Magic Banana pour ta réponse.
Peux-tu me préciser comment réaliser ce test, je suis ceinture blanche sur Linux?

Merci d'avance

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Cela n’a pas grand-chose à voir avec le noyau, Linux. Je suppose que tu voulais écrire GNU/Linux : https://www.gnu.org/gnu/linux-and-gnu.fr.html

Oui, je peux détailler :

  1. Installe le paquet nommé « memtest86+ », par exemple depuis le « Gestionnaire de paquets Synaptic » que tu trouves dans le « Contre de contrôle »;
  2. Redémarre;
  3. Au menu du chargeur de démarrage (GNU GRUB, par défaut), plutôt que de démarrer Trisquel, lance « Memory Test » (ou quelque chose du genre) avec la flèche du bas puis Entrée.

L’écran, avec un fond bleu, t’indique le test de la RAM qui est en cours : MemTest86+ écrit dans la RAM différents motifs puis lit au même endroit et voit s’il s’agit bien de ce qu’il a écrit. Laisse le test tourner pendant une bonne nuit. Si, au matin, le fond de l’écran est devenu rouge, c’est que la RAM est défaillante.

Sems
Offline
Joined: 07/10/2018

Oups, désolé, tu as raison, c'était un abus de langage...
Merci pour tes explications.
Bon, j'ai installé MemTest86+ (voir impression d'écran ci-jointe), néanmoins, je n'y ai pas accès au redémarrage dans le Grub.
J'ai les 3 possibilités de démarrage suivantes:
- Trisquel
- Options avancées pour Trisquel
- System Setup
J'ai essayé les options avancées, il y a plusieurs options (upstart, recovery mode) et je n'ai pas vu d'option de test de mémoire.

Screenshot at 2018-12-11 07:32:21.png
Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Voilà qui est bizarre. Exécute donc cela dans un terminal :
$ sudo update-grub
'sudo' te demandera ton mot de passe : donne-le-lui, suivi d’Entrée (il est normal que rien ne s’affiche lorsque tu tapes ton mot de passe). Redémarre et vois si, cette fois le menu de GRUB inclut une nouvelle entrée pour tester la mémoire vive.

Sems
Offline
Joined: 07/10/2018

Bon, j'ai fait la manip dans le terminal:
Création du fichier de configuration GRUB…
Image Linux-Libre trouvée : /boot/vmlinuz-4.4.0-139-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.4.0-139-generic
Image Linux-Libre trouvée : /boot/vmlinuz-4.4.0-138-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.4.0-138-generic
Image Linux-Libre trouvée : /boot/vmlinuz-4.4.0-137-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.4.0-137-generic
Windows Boot Manager trouvé sur /dev/sdb2@/EFI/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for EFI firmware configuration
fait

J'ai redémarré et je n'ai toujours pas l'option de test.
A noter que j'ai installé Trisquel en dual-boot avec Windows, je ne sais pas si cela a un impact...

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

C’est vraiment curieux. Ici, 'update-grub' trouve MemTest86+, en plus des noyaux Linux-libre et des « Images mémoire initiales » :
$ sudo update-grub
(...)
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
fait

As-tu ces deux fichiers, /boot/memtest86+.elf et /boot/memtest86+.bin, sur ton système ?

Sems
Offline
Joined: 07/10/2018

Bonjour,

Après une nouvelle installation de Trisquel 8.0, je rencontre toujours les mêmes problèmes de plantage de LibreOffice, j'ai réinstallé MemTes86+ pour tester la RAM et je suis confronté au même problème énoncé ci-dessus, je ne le trouve pas dans le grub et les deux fichiers memtest86+.elf et memtest86+.bin sont bien présents dans le répertoire /boot.
Je ne trouve pas de solution pour résoudre ce problème de plantage. Question subsidiaire: est-il possible d'installer une version plus récente de LibreOffice?

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

C’est possible. Tu peux même compléter le dépôt Trisquel avec ce PPA qui te fournitra toujours la dernière version stable de LibreOffice (6.2.2, pour l’heure) : https://launchpad.net/~libreoffice/+archive/ubuntu/ppa

Depuis le terminal, la procédure est :
sudo add-apt-repository ppa:libreoffice/ppa
sudo apt update
sudo apt upgrade

Tu peux aussi utiliser le menu « Configuration/Dépôts » du « Gestionnaire de paquets Synaptic » (onglet « Autres logiciels », bouton « Ajouter… »).

Sems
Offline
Joined: 07/10/2018

Bonjour Magic Banana,

Merci pour ton retour et ces informations. J'ai réussi à installer LibreOffice 6.2.2 en suivant ta procédure et il a l'air de bien fonctionner. A voir à l'usage.

Bonne journée

Sems
Offline
Joined: 07/10/2018

Oui, ils sont bien présents dans le répertoire /boot.
J'ai quand même plusieurs soucis curieux avec Trisquel sur ce PC que j'ai acheté en mai dernier. J'ai toujours le problème récurrent de saisies de caractères qui n'arrive qu'avec IceDove et Abrowser, je n'arrive pas à saisir certaines lettres dans les mails de réponse uniquement pour IceDove (la parade que j'ai trouvée est d'écrire un nouveau mail puis de faire un copier-coller dans le mail de réponse) et le problème d'écran noir qui m'oblige à redémarrer (le système dans ce cas n'est pourtant pas figé)...
J'en suis à un point où je me demande si je ne réinstallerai pas tout le système