Problème avec une clé USB

2 replies [Last post]
Mark
Offline
Joined: 04/14/2012

Bonsoir,

J'ai un problème avec ma clé USB de 32Go. En effet, lorsque je l'insère dans un port USB de mon ordinateur portable, trisquel l'ouvre en lecture seule. Du coup, je ne peux pas copier les images dans la clé.

Comment faire pour changer les permissions machin pour copier, créer des fichiers et dossiers dans la clé ? Merci d'avance.

Bruno Letat
Offline
Joined: 05/02/2013

Bonsoir Mark,

C'est un problème connu qui arrive pour les utilisateurs qui travaillent à la fois avec des fichiers en FAT32 et des fichiers EXT3 ou EXT4.
Commence par faire dans le terminal :
mount
ou alors pour avoir directement la ligne de la clé usb
mount | grep vfat

ça donne la liste des périphériques montés et leurs droits. Tu dois avoir ro pour read-only qui doit apparaître dans la liste des périphériques montés.

Il faut remonter ta clé en lecture/écriture avec l'instruction

sudo mount /dev/s... -o remount,rw

en changeant s... par la réalité selon ce que t'aura affiché l'instruction précédente

Exemple pour ma clé usb :
mount affiche :
/dev/sdf1 on /media/USB DISK type vfat (ro,nosuid,nodev,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush,uhelper=udisks)
on voit bien le ro dans la description
je tape
sudo mount /dev/sdf1 -o remount,rw
puis je tape mount

/dev/sdf1 on /media/USB DISK type vfat (rw,nosuid,nodev,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush,uhelper=udisks)

Problème corrigé :)

Il est possible cependant que cela ne suffise pas, dans ce cas, ça veut dire qu'il faut réparer la clé usb.
Un tutoriel se trouve sur le forum ubuntu : http://doc.ubuntu-fr.org/tutoriel/comment_reparer_clef_usb

Bon courage et à bientôt
Bruno

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Curieux ce problème. Tu peux essayer de reformater la clé. Par exemple avec GParted (disponible dans le dépôt de ta Trisquel).

Si il ne s'agit que d'un problème d'option passée à 'mount' (comme Bruno le suggère), il doit être possible d'appliquer le changement une fois pour toute en ajoutant une ligne à /etc/fstab.