Problème de session gnome.

8 replies [Last post]
Mark
Offline
Joined: 04/14/2012

Bonjour tout le monde !
Je rencontre actuellement un problème bizarre.

J'ai voulu installer gnome-shell 3 enfin... Regardez ici : http://www.gnome.org/gnome-3/

J'ai donc ouvert un Terminal et entré << sudo apt-get install gnome-shell >>.
Tout s'installe mais ensuite je me rend compte que je n'ai pas la session GNOME. Donc j'installe gnome-session (<< sudo apt-get install gnome-session >>).

Mais lorsque je me connecte à la session gnome, une fenêtre apparaît et me dit "Failed to load session "gnome".

Je me dit que gnome n'est peut être pas installé. Je regarde dans le gestionnaire des paquets Synaptic et, en effet, gnome n'est pas installé.
J'utilise donc << sudo apt-get install gnome >> mais le Terminal me balance :

____________________________________________________________________________
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
gnome : Dépend: ekiga (>= 3.2) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
____________________________________________________________________________

Du coup je tente d'installer ekiga mais il me redonne la même chose avec un autre paquet.

Pouvez-vous m'aider s'il vous plais ?
Merci d'avance.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Le seul paquet à installer explicitement est gnome-session (gnome-shell vient en dépendance). J'utilise GNOME Shell depuis que Trisquel 5.5 Brigantia est sortie et en suis très content. Le paquet gnome n'est pas installé sur mon système.

J'ai peur que l'échec du chargement de GNOME Shell sur ton système vienne de son impossibilité à utiliser l'accélération 3D de ta carte graphique. C'est, pour le moment, un pré-requis (grâce au travail du projet Fedora, cela pourrait devenir optionnel d'ici peu).

Si tu as une carte graphique ATI/AMD, ne cherche pas plus loin. Le pilote "radeon" ne fournit pas d'accélération 3D. Si tu as une carte graphique nVidia, cela dépend de son modèle et tu peux essayer d'installer le paquet libgl1-mesa-dri-experimental (au risque d'instabilités). Si tu as un chipset graphique Intel alors, à moins qu'il s'agisse de Poulsbo (ou autre chipset fabriqué par PowerVR), je ne comprends pas pourquoi cela ne fonctionnerait pas. D'ailleurs, si tu as un processeur Intel *et* une carte graphique ATI/nVidia, je te recommande de désactiver ou même de retirer la carte graphique. Tu profiteras ainsi de meilleures performances graphique (incluant l'accélération 3D) tout en économisant de l'énergie.

Mark
Offline
Joined: 04/14/2012

Je viens d'essayer d'installer gnome-session sur un autre ordinateur. Le même problème se présente. L'ordinateur possède une carte ATI Radeon, donc le problème est bien dû à l'accélération 3D.
Donc un des ordinateurs n'est pas assez puissant et l'autre possède l'ATI Radeon.

Je viens de désinstaller gnome-session... Merci de ton aide.

Par ailleurs, est-il possible d'obtenir des ombres sous les fenêtres de l'interface gnome classic ?

J'ai VRAIMENT BESOIN d'une accélération 3D donc, est-il possible d'installer (à ma grande tristesse) le pilote propriétaire de ma carte graphique sur Trisquel ?

Merci de m'avoir aidé.

oysterboy

I am a member!

I am a translator!

Offline
Joined: 02/01/2011

Si tu as vraiment besoin d'accélération 3D, tes options sont a) Trisquel + carte graphique supportée b) une autre distribution (par exemple Ubuntu) et ta carte graphique actuelle. C'est malheureux mais c'est comme ça. Je me suis procuré récemment, pour un prix fort raisonnable, une carte graphique NVIDIA supportée pour cette raison précise. N'oublie pas les fondamentaux du projet Trisquel.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Ceci étant, je ne pense pas que Trisquel empêche techniquement l'installation d'un pilote privateur. Mais comme l'écrit oysterboy, c'est ta volonté d'être en plein contrôle de ton informatique qui devrait te l'empêcher. En tout cas, si tu décides d'installer du logiciel privateur, tu ne recevras aucune "aide" de la part de la communauté car nous considérons qu'il ne s'agirait justement pas d'une aide.

Mark
Offline
Joined: 04/14/2012

Bonjour à tous !
Je m'excuse pour l’arrogance de mon dernier post. J’étais assez énervé de ne pas pouvoir utiliser Blender 2.6 sous GNU Linux Trisquel 5,5 Brigantia.

Vous l'ignorez peut-être mais Blender est un puissant logiciel de création artistique 3D. Une accélération 3D est donc obligatoire sous GNU Linux Trisquel. Mon rêve c'est d'être très fort et très à l'aise avec Blender surtout dans l'animation 3D donc vous comprenez ma tristesse lorsque j'ai vu que GNU Linux Trisquel ne gère pas vraiment l'accélération 3D pour les ATI Radeon.

Je suis actuellement dans une profonde réflexion car je souhaite acheter un nouvel ordinateur fixe. Je souhaite effectuer un « dual boot » entre GNU Linux Trisquel version 5.5 et Microsoft Windows Seven sur deux disques dur différents.

En gros, sur un HDD (Hard Drive Disk) de 500Go, je souhaite installer GNU Linux Trisquel et sur un autre HDD 130Go Windows 7. Pourquoi ? C'est très simple, je souhaite utiliser 2-3 jeux vidéos qui m'ont été offert sous Windows notamment Far Cry 2 que j'aime beaucoup !!

Certains de ces jeux vidéo sont gourmand en ressources et demandent une carte graphique puissante, donc j'avais choisi une ATI Radeon haut de gamme. Mais avec GNU Linux Trisquel, il m'est impossible de la prendre. Donc à partir de cette image (pièce jointe) je dois trouver une NVIDIA qui me permet de jouer à ce jeu avec les graphismes les plus avancés (afin de rentabiliser le prix du jeu!!). Mais la carte graphique doit pouvoir être compatible avec le pilote de GNU Linux Trisquel.

Si vous pouviez m'aider à choisir la carte graphique qui puisse me permettre de Jouer à Far Cry 2 et d'exploiter les ressources de Blender et dans la foulée jouer à Hedgewars et 0.A.D sous GNU Linux Trisquel se serait formidable.
Je m'excuse encore pour mon dernier message, j'avais désinstallé GNU Linux Trisquel pour Ubuntu mais GNU Linux Trisquel est plus intéressant niveau libertés !

-- Mark --

pascal@diogoantunes.org
Offline
Joined: 09/03/2012

Pardonnes moi, mais dans ce cas pourquoi Trisquel ?
Tu souhaites faire un dual boot avec w7, et en plus avoir une carte
graphique nvidia, donc a ce moment pourquoi avoir Trisquel ?
Va voir la communaute ubuntu qui t'aidera beaucoup mieux.
Je vois pas pourquoi installe une distrib libre a cote d'une distrib
privatrice. La communaute et des solutions open source serait une
meilleur solution pour toi.
Trisquel tourne sur du linux-libre, donc pas de paquets privateurs, tu
n'auras pas ton bonheur chez Trisquel, ce n'est pas le but en tout cas.

Citando name at domain:

> Bonjour à tous !
> Je m'excuse pour l?arrogance de mon dernier post. J?étais assez
> énervé de ne pas pouvoir utiliser Blender 2.6 sous GNU Linux
> Trisquel 5,5 Brigantia.
>
> Vous l'ignorez peut-être mais Blender est un puissant logiciel
> de création artistique 3D. Une accélération 3D est donc obligatoire
> sous GNU Linux Trisquel. Mon rêve c'est d'être très fort et très à
> l'aise avec Blender surtout dans l'animation 3D donc vous comprenez
> ma tristesse lorsque j'ai vu que GNU Linux Trisquel ne gère pas
> vraiment l'accélération 3D pour les ATI Radeon.
>
> Je suis actuellement dans une profonde réflexion car je souhaite
> acheter un nouvel ordinateur fixe. Je souhaite effectuer un « dual
> boot » entre GNU Linux Trisquel version 5.5 et Microsoft Windows
> Seven sur deux disques dur différents.
>
> En gros, sur un HDD (Hard Drive Disk) de 500Go, je souhaite
> installer GNU Linux Trisquel et sur un autre HDD 130Go Windows 7.
> Pourquoi ? C'est très simple, je souhaite utiliser 2-3 jeux vidéos
> qui m'ont été offert sous Windows notamment Far Cry 2 que j'aime
> beaucoup !!
>
> Certains de ces jeux vidéo sont gourmand en ressources et
> demandent une carte graphique puissante, donc j'avais choisi une ATI
> Radeon haut de gamme. Mais avec GNU Linux Trisquel, il m'est
> impossible de la prendre. Donc à partir de cette image (pièce
> jointe) je dois trouver une NVIDIA qui me permet de jouer à ce jeu
> avec les graphismes les plus avancés (afin de rentabiliser le prix
> du jeu!!). Mais la carte graphique doit pouvoir être compatible avec
> le pilote de GNU Linux Trisquel.
>
> Si vous pouviez m'aider à choisir la carte graphique qui puisse
> me permettre de Jouer à Far Cry 2 et d'exploiter les ressources de
> Blender et dans la foulée jouer à Hedgewars et 0.A.D sous GNU Linux
> Trisquel se serait formidable.
> Je m'excuse encore pour mon dernier message, j'avais désinstallé GNU
> Linux Trisquel pour Ubuntu mais GNU Linux Trisquel est plus
> intéressant niveau libertés !
>
> -- Mark --
>

Mark
Offline
Joined: 04/14/2012

Pourquoi Trisquel ? C'est très simple, c'est une distribution 100% libre et c'est avec elle que j'ai appris les commandes et tout un tas de choses sur GNU Linux et le logiciel libre.

Maintenant j'installe Windows 7 à coté de Trisquel pour des raisons d'apprentissage. Je suis étudiant en informatique dans la maintenance donc il est obligatoire pour moi d'avoir les 2 environnements à porté de main.

Pour être honnête avec vous, je trouve que l'esprit mental de la communauté de Trisquel est très basse.
"Ouais... Nous on refuse d'aider une personne qui souhaite utiliser du propriétaire pour x raisons."
Franchement avec ça en tête, vous n'allez pas aller loin... Parce-que installer un logiciel privateur, c'est devoir bidouiller l'OS et donc forcément apprendre sont fonctionnement et l'adapter à ses besoins (1 règles fondamentale sur les 4 !).

En restant le plus direct possible, il faut être réaliste, c'est tellement plus intéressant de mettre en relation 2 OS et de les faire communiquer plutôt que de rester coincer sur UN SEUL OS libre qui ne gère même pas le wifi et l'accélération matérielle.

En tout cas, il est clair que si on me demande comment est la communauté de Trisquel et l'OS, je répondrais pour le moment que la communauté blâme les personnes voulant exploiter 2 environnements différents et n'aide pas l'utilisateur à surmonter ses difficultés. Le site est incomplet et manque cruellement de documentation. Si vous êtes si fort dans linux-libre comme vous le dite, vous auriez dû la faire.

La communauté signifie faire preuve de cohésion et aider tout utilisateur dans l'apprentissage d'une matière. Ça ne signifie pas lui dire merde s'il souhaite utiliser différemment un logiciel.

Une chose est sûr, je vais continuer mes projets de dual boot et contrairement à vous, j'aurais appris des choses. Et ce ne sera PAS DU TOUT grâce à cette communauté.

oysterboy

I am a member!

I am a translator!

Offline
Joined: 02/01/2011

Personne ne t'empêche de faire du dual/triple/multiple-boot... Par contre, en ce qui concerne la partition Trisquel, c'est passablement absurde d'essayer d'y installer un pilote propriétaire, cela allant totalement à l'encontre de la raison d'être de ce projet !

Une petite analogie culinaire : dans un forum de végétariens dédié à la promotion de ce mode de vie, comment penses-tu qu'un message demandant la meilleure recette de hâchis parmentier ou de salade césar poulet/bacon serait accueilli ;) ? Honnêtement je trouve cette (minuscule) communauté très aidante et accueillante, mais ne lui demande pas d'aller à l'encontre des valeurs les plus fondamentales qui justifient l'existence même de cette communauté !

Personnellement, j'ai plusieurs OS installés sur mes machines, et passe 99 % de mon temps sur Trisquel. Il m'arrive de faire une incursion sur Linux Mint (0.99% de mon temps) ou (que le dieu des libristes me pardonne) Windows (0.01% de mon temps), quand il me faut absolument accomplir une tâche qui s'avère impossible sous Trisquel (en général un site web à la con, ou devoir flasher le BIOS quand le constructeur ne fournit qu'un exécutable pour Windows, etc...). Je te conseille de faire de même et de ne pas chercher à souiller ta belle distribution 100% libre ;).