Problem with Editing PDF Files and Renaming Files in Nautilus

14 replies [Last post]
0d54770d

I am a member!

Offline
Joined: 04/09/2016

Hello, I am having a couple of issues that I think are probably related:

First, whenever I open up a PDF file with editable fields, I can successfully type in a couple of fields, but then, whenever I select a new field and try to type, nothing is filled in.

Also, the same thing happens whenever I try to rename files in Nautilus; I can rename a couple of files, but then it won't let me type in anything at all, until I reboot the computer.

I have tried changing the keyboard input system from "IBUS" to "none," but that doesn't solve the problem; it still does the same thing.

Has anyone else experienced this issue, and/or does anyone have any other ideas about how I could fix it.

Thank you all very much for your help!

arielenter

I am a member!

I am a translator!

Offline
Joined: 08/25/2010

Could you send the example PDF?

After renaming files in Nautilus, does the keyboard stops working all along, or it just doesn't allow you to keep renaming other files? Could you type other things in nautilus like making a search?

I hope there is something we can do to help you.

0d54770d

I am a member!

Offline
Joined: 04/09/2016

Attached is the example PDF.

After renaming the file(s) in Nautilus, the keyboard still works for everything else, just not to rename other files.

AttachmentSize
i-130.pdf 1.09 MB
animaliqua
Offline
Joined: 04/18/2015

Unfortunately I am having the same problems with Nautilus as well, and could not find a solution. The keyboard input to Nautilus halts (cannot input anything in the search fields, and Ctrl+C/Ctr+V also does not work), even though I am able to type in other programs (Abrowser, LibreOffice etc). The mouse works inside Nautilus.

On a "happier" note, it is not necessary to reboot the system; if Nautilus gets killed (I use System Monitor for that), it reopens functionally (at least for a while, until it decides not to accept keyboard inputs again).

0d54770d

I am a member!

Offline
Joined: 04/09/2016

That's good to know; it will do well for a workaround, until someone can figure out what is causing this, and comes up with a fix.

pragmatist

I am a member!

Offline
Joined: 03/03/2016

I tried the PDF and I could edit and check boxes and so on. Sometimes to give focus to the field I had to click at the beginning of the line/box specifically.

As far as renaming, when you click on a file name is it highlighted? Have you tried right-clicking and choosing 'rename'? Are you renaming files in icon mode or list mode?

Are you using a laptop with a touchpad and are using the touchpad not an external mouse? If so, go into the settings for mouse/touchpad: is there a box checked that says the touchpad is disabled when you are typing on the keyboard?

0d54770d

I am a member!

Offline
Joined: 04/09/2016

As far as the PDF files go, sometimes it's tricky to select a field, but that's not what I'm talking about; I'm talking about a field that I can click in, but doesn't allow me to type in any text.

I've tried renaming by double-clicking the file name, and by right-clicking the file and selecting "rename"; neither works.

Also, I do not use an external mouse; I have a Libreboot X200 laptop, and just use the trackpoint, so there is no option for disabling the keyboard while using the touchpad.

pragmatist

I am a member!

Offline
Joined: 03/03/2016

What are the permissions on the file?

0d54770d

I am a member!

Offline
Joined: 04/09/2016

The permissions on the file are "-rw-rw-r--".

pragmatist

I am a member!

Offline
Joined: 03/03/2016

Given that the more experienced posters, onpon4 and Magic Banana, are not thinking along these lines, it probably does not matter. Still, if you want you can try (this assumes you are the owner of the file) open a terminal and type:
chmod 777 filename.pdf

Then try renaming. If it does not work, you can put the permissions back with:
chmod 664 filename.pdf

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

What is in ~/.xinputrc (that is "the hidden file named ".xinputrc" inside your home folder)?

0d54770d

I am a member!

Offline
Joined: 04/09/2016

Here's what my ~/.xinputrc file says:

"# im-config(8) generated on Wed, 08 Jun 2016 10:41:34 -0400
run_im xim
# im-config signiture: 3fb107f000d5abfe6179da7589a85245 -"

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Try to change "xim" for "none". You can do that with your favorite text editor or use this command:
$ sed -i s/xim/none/ ~/.xinputrc

I believe the graphical session must be restarted for the change to be effective.

onpon4
Offline
Joined: 05/30/2012

The PDF editing thing is something I've experienced. What's actually happening is Evince stops responding to the keyboard entirely. Even keyboard shortcuts (like Ctrl+S) stop working. I have no clue what triggers it, but I've found that with some documents it's best to hit Enter after typing something in, and with some documents it's best to just click onto the next field.

It's annoying, but not impossible to deal with. If it stops responding to the keyboard, save the document (through the menu, since Ctrl+S doesn't work at that point) and restart Evince.

I haven't experienced being unable to rename files in Nautilus, but on some versions of Nautilus, I've experienced a bug where the rename field stops showing changes after a while, but the changes still get made. When I experienced this, the file was renamed successfully when I pressed Enter.

ADFENO
Offline
Joined: 12/31/2012

The following procedure assumes that the password of the current user
doesn't use complex caracters to reach if, for some reason, the keyboard
layout (or input method) changes abruptly before logging-in.

Check if "/etc/X11/xinit/xinputrc" has a line starting with:

run_im xim

If the line "run_im" has a different value than "xim", do:

gksudo im-config

And after telling the system that you do want to change the system's
input method, select "XIM".

Now check if your home directory has a file called ".xinputrc", and
check if the "run_im" line is set to "none". If not, do:

im-config

And after telling the system that you want to change your input method,
select "none".

Now restart the system.