Problemas con GCC

4 replies [Last post]
yawin
Offline
Joined: 02/11/2016

¡Hola a todo el mundo!

Tengo un problema gordo con GCC. Estoy compilando un programa que requiere gcc-4.9 y Trisquel me dice que no lo tengo instalado.

Por partes. Esto es lo que me devuelve cmake cuando intento compilar:

CMake Error at CMakeLists.txt:215 (message):
Insufficient gcc version, found 4.8.4. Version 4.9 or higher is required.

Si intento instalar gcc4.9 la terminal dice:

yawin@Anuva:~/.minetest$ sudo apt-get install gcc-4.9-base
Leyendo lista de paquetes... Hecho
Construyendo árbol de dependencias
Leyendo las instrucciones de estado... Hecho
gcc-4.9-base está en la versión más reciente.
0 para actualizar, 0 para instalar, 0 eliminar, y 0 sin actualizar.

He traducido lo que dice la terminal porque no lo tengo ni en castellano ni en inglés, así que es normal que no se ajuste a como lo arrojaría una terminal en castellano.

¿Qué puedo hacer?

Ark74

I am a member!

Offline
Joined: 07/15/2009

Por lo que veo estas usando aun Belenos (7.0).

GCC 4.9 está disponible para Flidas (8.0) en adelante, lo que instalaste son solo "bibliotecas" pero no el compilador gcc 4.9 en sí mismo.

Dado que gcc es un programa base, se me ocurre que podrías intentar usar docker para ejecutar dicho programa (el que intentas compilar) desde un contenedor con trisquel 8, a realizar modificaciones a gcc.

O en su caso tal vez conseguir gcc 4.9 a través de un PPA, sin embargo recomendaría mejor pensar en migrar a la versión 8.

Saludos.

yawin
Offline
Joined: 02/11/2016

Y cómo migro? Porque con "sudo apt-get dist-upgrade" me dice que no hay nada para instalar.

Vale, ya estoy actualizando. A ver si así se arregla.

yawin
Offline
Joined: 02/11/2016

Tengo instalado el build-essential