[Résolu] Empêcher le lecteur d'écran Orca de se lancer avec l'écran de connexion GDM de Trisquel 6.0.1

4 replies [Last post]
eean
Offline
Joined: 07/06/2011

Bonjour,

Comme vous le savez peut-être, une version légèrement améliorée de Trisquel 6.0, prenant notamment en charge l'UEFI, est désormais disponible.

J'ai regroupé les informations à ce sujet dans une discussion séparée dont voici le lien :

https://trisquel.info/fr/forum/installation-r%C3%A9ussie-de-trisquel-601-sur-pc-avec-uefi

Lorsque j'ai eu fini d'installer Trisquel 6.0.1, j'ai eu la surprise de voir démarrer le lecteur d'écran par synthèse vocale Orca en même temps que la fenêtre de connexion habituelle de GDM.

Je trouve que c'est un effort d'accessibilité très louable vis à vis des personnes mal voyantes ou non voyantes, même si la synthèse vocale par défaut laisse beaucoup à désirer en français (et je sais que ce n'est pas la faute de Trisquel). Seulement, lorsqu'on n'est pas personnellement concerné par ces handicaps visuels, on voudra sûrement désactiver ce démarrage automatique d'Orca.

Voici donc comment faire :

- Installer le paquet gconf-editor avec le gestionnaire de paquet Synaptic ou bien en ligne de commande, comme ceci :

sudo apt-get install gconf-editor

- Saisir votre mot de passe pour valider l'installation de l'éditeur GConf.

- Si ce n'est pas déjà fait, ouvrir un terminal et lancer l'éditeur GConf en entrant simplement la commande suivante :

gconf-editor

- Une fois que l'éditeur GConf est ouvert, parmi les catégories de la colonne de gauche, se positionner sur la suivante :

desktop > gnome > applications > at

Dans la colonne de droite apparaît la clé "screen_reader_enabled" qui est activée par défaut.

- Désactiver cette clé en décochant la case correspondante située juste à sa droite.

Ce simple réglage ne sera toutefois pas suffisant. En effet, afin que ce paramétrage soit pris en compte, il faut faire en sorte que cette désactivation devienne le réglage par défaut de la clé. Pour cela :

- Effectuer un clic droit sur cette clé "screen_reader_enabled" puis choisir l'option "Définir par défaut".

Une fenêtre d'authentification apparaît alors. Elle signale que des permissions sont nécessaires pour modifier les valeurs GConf système.

Il suffit donc de saisir son mot de passe sudo et de valider par entrée.

Au prochain démarrage, le lecteur d'écran Orca ne se lancera plus en même temps que l'écran de connexion de GDM.

Note complémentaire :

À titre de complément d'information, on pourra se référer au Manuel de référence du gestionnaire de connexions GNOME :

https://help.gnome.org/admin/gdm/stable/index.html.fr

Et plus particulièrement à la section V consacrée à sa configuration :

https://help.gnome.org/admin/gdm/stable/configuration.html.fr

Celle-ci permet en effet de mieux comprendre la structuration des fichiers de configuration de GDM, ainsi que de ses scripts de démarrage. Cela permet notamment de s'apercevoir que GDM fait appel à un fichier desktop pour lancer Orca au démarrage de la fenêtre de connexion.

Sous Trisquel, le chemin du fichier en question est le suivant :

/usr/share/gdm/autostart/LoginWindow/orca-screen-reader.desktop

En parcourant le contenu de ce fichier avec un éditeur de texte, on trouvera la ligne suivante :

AutostartCondition=GNOME /desktop/gnome/applications/at/screen_reader_enabled

Elle fait référence à la clé que nous venons venons de modifier avec gconf-editor. C'est en effet cette ligne du fichier qui fait le lien avec GConf.

On notera aussi qu'une autre façon de désactiver l'ouverture d'Orca en même temps que l'écran de connexion de GDM est précisément de modifier ce fichier (via un éditeur de texte ouvert en mode super utilisateur avec sudo ou gksudo), en commentant la ligne suivante :

Exec=orca --disable main-window --disable splash-window --disable magnifier --enable speech --enable braille

Ce qui donne donc :

#Exec=orca --disable main-window --disable splash-window --disable magnifier --enable speech --enable braille

Cette méthode toute simple permet d'éviter d'avoir recours à l'éditeur GConf mais elle est moins conforme, dans son principe, aux règles de fonctionnement de GDM. En effet, GDM fera alors quand même appel à ce fichier desktop mais sans charger Orca, plutôt que de simplement l'ignorer comme on lui a demandé de le faire via gconf-editor.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Pourquoi ne pas juste cliquer dans l'utilitaire "Accès Universel" (à chercher dans les "Paramètres système") ?

eean
Offline
Joined: 07/06/2011

C'est bien le premier réflexe que j'ai eu ! ^_^

Mais ce n'est hélas pas si simple. En effet, désactiver le lecteur d'écran via « Paramètres système > Accès universel » reste sans effet sur le comportement de l'écran de connexion du GDM.

Cela n'agit que sur la session proprement dite, donc après s'être connecté.

Seulement, avec Trisquel 6.0.1, Orca se lance par défaut pendant l'affichage de l'écran de connexion du GDM et c'est cette instance d'Orca que je cherchais à désactiver.

C'est pour cela que j'ai dû creuser un petit peu la question (euphémisme, j'y ai passé une bonne partie de mon week-end en fait…) avant de trouver à quel niveau il fallait intervenir précisément pour désactiver ce lancement d'Orca.

À un moment j'ai même songé à regarder du côté d'Upstart ou du serveur X, pour finalement revenir à ma première idée qui était la bonne (réglage lié à GDM).

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Et tu avais aussi décoché "Visual Assistance" dans les "Applications au démarrage" (toujours dans les "Paramètres système") ?

eean
Offline
Joined: 07/06/2011

Désolé de te répondre un brin tardivement Magic Banana ; je n'ai pas eu le temps avant.

Donc, oui j'avais bien désactivé Orca dans les applications au démarrage. Pour ce faire j'ai dû suivre la procédure décrite ici :

http://askubuntu.com/questions/81960/how-do-i-stop-orca-from-starting-up-on-login

Car sinon Orca n'apparaît même pas parmi les applications lancées au démarrage, alors qu'il est bien paramétré par défaut pour se lancer.

Cela dit, ça n'a eu aucun effet sur l'écran de connexion du GDM de le désactiver via cet outil. Ce qui ne m'a pas surpris outre mesure, vu que j'utilise régulièrement cet utilitaire des applications au démarrage pour en ajouter certaines et qu'elles se lancent systématiquement juste après la connexion à la session.