Résolution de quelques petits problèmes !

26 replies [Last post]
Mark
Offline
Joined: 04/14/2012

Bonjour tout le monde !

Je voulais savoir s'il est possible de mettre le navigateur Abrowser en Français. J'ai installé Trisquel 5.5 32 bits il n'y a que quelques heures.
Je ne me souvient plus comment j'ai fait pour le mettre en Français...

J'en profite aussi pour demande s'il est normal que le son de démarrage de Trisquel ne se joue pas ? Vous savez, le "tuhuhuhuhu" au démarrage ?!!!
J'ai pourtant du son, puisque les bruitages et mes pistes audio fonctionnent sous Trisquel...

Enfin, est-ce-normal que les vidéos sur le web, celles de Youtube ne se lisent pas ou très mal. Elles restent noire et Youtube me demande d'installer la dernière version de Flash Player de Adobe.
Mais je ne veux pas installer ce truc, c'est du privateur !

Comment faire pour résoudre tout ces petits soucis ? Merci d'avance ;).
Mark.

Magic Banana

I am a member!

Online
Joined: 07/24/2010

Si tu ne l'as pas déjà fait, va faire un tour du côté de la "Prise en charge des langues" dans les "Paramètres système". Le français devrait figurer tout en haut de la liste.

Je ne suis néanmoins pas certain que la localisation du navigateur Web soit prise en charge par cette configuration. Ouvre donc le "Gestionnaire de paquets Synaptic", recherche le paquet "abrowser-locale-fr" et installe-le en quelques clics. Après un redémarrage du navigateur Web, ce dernier devrait parler la langue de Molière.

Pour ce qui est du son de démarrage, je suppose que tu parles du son (bien plus discret que ce que tu mentionnes) indiquant à l'écran de connexion, que le système est prêt à lire le nom d'utilisateur souhaitant ouvrir une session. Il est possible de l'activer ou de le désactiver depuis 'gconf-editor'. Tape donc Alt+F2 et entre cette commande. Tu peux alors naviguer vers /apps/gdm/simple-greeter/settings-manager-plugins/sound et cocher la case "active".

Pour ce qui est de lire des vidéos Flash en toute liberté, je te recommande la lecture de cette entrée dans la documentation Trisquel. Plusieurs solutions y sont détaillées.

Mark
Offline
Joined: 04/14/2012

Bonsoir,

  • J'ai réussi à mettre Abrowser en Français avec ce paquet que tu m'a montré.
  • Pour les vidéos sur le web, ça ne fonctionne pas vraiment. Apparamment Gnash est une version obsolète (enfin ce que me dit une page Mozilla). Du coup il me propose d'installer Adobe Flash player,.. :(
    Je ne suis pas certain de tout avoir compris sur la page que tu m' montré.
  • Concernant le son, la case active est bien coché. Mais je ne parle pas du petit "tick" avant l'ouverture d'une session. Je parle du sons que l'on entend après avoir ouvert une session. C'est un son assez prolongé et calme.
Magic Banana

I am a member!

Online
Joined: 07/24/2010

La documentation indique plusieurs extensions à ABrowser qui permettent, sur un certain nombre de sites Web, d'automatiquement lire le flux vidéo sans passer par le conteneur Flash.

Ceci étant, YouTube permet déjà de choisir un affichage de la vidéo via la balise "video" du HTML5. La plupart des vidéos sont aujourd'hui disponibles de la sorte. Maintenant, cela est spécifique à YouTube.

Je n'ai pas non plus de son au démarrage de la session. Cela doit faire parti du grand nettoyage de fonctionnalité opéré par GNOME 3. Je ne n'ai rien trouvé de pertinent après une rapide recherche dans "gconf-editor" mais je pense qu'il doit encore être possible d'avoir un tel son.

Si tu ne trouves pas, tu peux toujours "Ajouter" dans les "Applications au démarrage" (dans les "Paramètres système") une commande qui va lire un son. Quelque chose comme mplayer /usr/share/sounds/gnome/default/alerts/bark.ogg (cette commande spécifique nécessite que mplayer soit installé sur ton système).

sellam
Offline
Joined: 11/18/2012

Bonsoir,
Pour lire la musique, les films et youtube, à la place de flashplayer qui n'est pas libre bien qu'il est gratuit, tu installes VLC et Amarok qui sont des logiciels libres et gratuits. Après installation de vlc, il est également nécessaire de lancer en console vlc est c'est fini.
A mon avis avant d'installer un logiciel, il est nécessaire de s'assurer qu'il est libre au sens de GNU-Linux-Free, 100% libre.
Cordialement.

Magic Banana

I am a member!

Online
Joined: 07/24/2010

Pour un logiciel dans les dépôts Trisquel, il n'y a rien à vérifier. C'est bien là un grand avantage de Trisquel : ses dépôts ne contiennent que des logiciels libres. Il peut, bien sûr, il y avoir des erreur mais je n'en ai jamais entendu parler.

Lorsque l'on s'approvisionne en logiciel en dehors des dépôts Trisquel (par exemple via des PPAs), la rigueur est de mise...

sellam
Offline
Joined: 11/18/2012

Bonsoir à tous
J'ai essayé d'installer codeblocks sur ma machine sous Trisquel 5.5, l'installation est faite mais lorsque je mets (build & run), rien ne s'affiche sur ma console. Celle-ci garde affiché le premier message Welcome to console.
Est-ce-qu'il y a quelqu'un pour m'aider et en plus je suis un zéro en programmation car je veux m'initier à la programmation en C sur codeblocks et merci beaucoup.
Cordialement.

Magic Banana

I am a member!

Online
Joined: 07/24/2010

Tu as écrit du code au moins ? :-)

Autrement cela me paraît naturel qu'il n'y ait rien à construire et à exécuter.

Je suis personnellement de l'ancienne école : je pense qu'il est meilleur de découvrir la programmation C en écrivant le code depuis un éditeur de texte et en le construisant avec GCC depuis un terminal. Les IDE cachent toute l'étape de construction qui semble alors magique. Par ailleurs, un IDE est un outil complexe qui demande apprentissage. Tu te retrouves donc à apprendre deux choses à la fois : un langage et un outil pour l'écrire.

sellam
Offline
Joined: 11/18/2012

Bonjour,
Merci à Magic Banana pour sa réponse et ses conseils. Donc, pour programmer,je vais essayer de me mettre à l'épreuve en commençant par le langage C et Emacs pour l'écrire. Tu dis c'est magique, c'est bien magique car la console montre tout, alors que les ide nous cachent ce qui se passe derrière.
Merci, et bon courage.

J'ai bien testé emacs avec une instruction en langage C, cette méthode me donnera le courage et le souffle pour voir ce que fait mon PC et mes logiciels.
Merci beaucoup.

sellam
Offline
Joined: 11/18/2012

Bonsoir
J'ai essayé comme d'habitude d'installer mon imprimante Canon LBP- 1120 sous Trisquel 5.5 en suivant la méthode utilisée avec ubuntu ou debian mais l'installation n'aboutit pas. Il se peut que le driver téléchargeable ne convient pas pour Trisquel ou bloqué par Trisquel elle même. S'il y a quelqu'un ayant la même imprimante, peut-il m'aider et merci beaucoup.

kawa
Offline
Joined: 11/18/2012

Installation de l'imprimante Canon Laserjet LBP-1120
sous Trisquel 6, Debian 6 ou Ubuntu 12.04
N'ayant trouvé aucune astuce pour l'installation mon imprimante laser LBP1120 sur ce site, je me permet d'écrire ce tuto.
Je me suis inspiré du tutoriels sur Debian, Ubuntu et Mint pour installer ma LBP1120 sous Trisquel6 et j'ai du modifier quelques lignes. Cette méthode devrait marcher pour les imprimantes suivantes:
i-SENSYS LBP-3000
LaserShot LBP-1120
LaserShot LBP-1210
LaserShot LBP-2900
LaserShot LBP-3000
LaserShot LBP-3300
LaserShot LBP-5000
LBP-810
LBP-3200

Création de dossiers et fichiers préliminaires

1) Création des dossiers /var/ccpd et /var/captmon:
Code:
mkdir /var/ccpd
mkdir /var/captmon

2) Création du fichier spécial fifo0:
Code:
mkfifo /var/ccpd/fifo0 (NB, ce fichier existe déjà avec l'installation de Trisquel 6)

3) Changement de droit du fichier fifo:
Code:
chmod 777 /var/ccpd/fifo0

Installation des paquets canon

4) Il faut tout d'abord récupérer le driver sur le site de canon:
http://software.canon-europe.com/software/0028622.asp
On le décompresse
Code:
tar xvfz CAPTDRV220.tar.gz

5) On se déplace dans le répertoire CAPTDRV160/driver/debian
Code:
cd CAPTDRV220/driver/debian

6) On installe les deux paquets dans l'ordre suivant :
a) cndrvcups-common_2.20-1_i386.deb
b) cndrvcups-capt_2.20-1_i386.deb
Code:
dpkg -i cndrvcups-common_2.20-1_i386.deb
dpkg -i cndrvcups-capt_2.20-1_i386.deb

7) On redémarre le système d'impression cups:
Code:
/etc/init.d/cups restart

Installation de l'imprimante

8) On recherche le nom du driver (CNCUPSLBP1120CAPTK.ppd pour une LBP1120)
Code:
ls /usr/share/cups/model/ | grep CNCUPS

9) Puis on tape:
Code:
/usr/sbin/lpadmin -p [printer model] -m [printer driver file] -v ccp:/var/ccpd/fifo0 -E

ou [printer model] est le nom de l'imprimante (LBP1120 dans mon cas)
et [printer driver file] est le nom du driver de l'imprimante (CNCUPSLBP1120CAPTK.ppd dans mon cas)
Ce qui donne pour une LBP1120:
Code:
/usr/sbin/lpadmin -p LBP1120 -m CNCUPSLBP1120CAPTK.ppd -v ccp:/var/ccpd/fifo0 -E

Fin de l'installation

10) On enregistre l'imprimante avec le ccpd daemon:
Code:
/usr/sbin/ccpdadmin -p [printer model] -o /dev/usb/lp0

Ce qui donne pour une LBP1120:
Code:
/usr/sbin/ccpdadmin -p LBP1120 -o /dev/usb/lp0

11) On redémarre cups et ccpd
Code:
/etc/init.d/cups restart && /etc/init.d/ccpd restart

12) On paramètre le système pour que ccpd se lance avec une priorité de 90 (http://www.debuntu.org/how-to-manage-se ... pdate-rc.d) :
Code:
update-rc.d ccpd defaults 90

13) En cas de message:
Code:
update-rc.d: warning: /etc/init.d/ccpd missing LSB information
update-rc.d: see
System start/stop links for /etc/init.d/ccpd already exist.

Il faut enlever le service ccpd et le remettre
Code:
update-rc.d -f ccpd remove

Code:
update-rc.d ccpd defaults 90

Test de l'imprimante

14) 1er test
Code:
ccpdadmin

doit renvoyer:
Code:
Usage:
  ccpdadmin [-p Printer-name -o Printer-dev-path]
  ccpdadmin [-x Remove-Printer-name]

CUPS_ConfigPath = /etc/cups/
LOG Path        = None
UI Port         = 39787

Entry Num  : Spooler   : Backend       : FIFO path             : Device Path  : Status
----------------------------------------------------------------------------
     [0]    : LBP1120  : ccp           : /var/ccpd/fifo0       : /dev/usb/lp0  :

15) 2ème test
Code:
captstatusui -P [printer model]

ce qui donne pour une LBP1120:
Code:
captstatusui -P LBP1120

A la fin, ouverture d'une fenêtre avec un message ready to print

A défaut, il faut ajouter les modifications suivantes avec vim /etc/rc.local ou
gedit /etc/rc.local
En ajoutant à la fin du texte, la ligne suivante :
/etc/init.d/ccpd start
Enregistrer et fermer la console.
Printer is ready to print

Magic Banana

I am a member!

Online
Joined: 07/24/2010

Tu devrais copier cela dans une page de la documentation. C'est un wiki. En laissant ce tutoriel ici, personne ne la trouvera jamais. Ce n'est pas même lié aux sujets de départ du fil...

kawa
Offline
Joined: 11/18/2012

Merci Banana, mais je ne sais pas comment faire pour le déplacer vers la documentation.

slughnaz
Offline
Joined: 01/26/2013

Bonjour kawa.
J'ai trouvé ton tutoriel très intéressant et je trouvais dommage de le voir finir perdu au milieu d'un fil oublié.
J'ai créé une page wiki et j'y ai copié le contenu de ton tutoriel. Pour éditer le contenu, tu n'as qu'à cliquer sur l'onglet Modifier en haut de la page.

kawa
Offline
Joined: 11/18/2012

Bonsoir Slughnasz et merci d'avoir publié une page wiki. Ceci va sans doute débloquer les utilisateurs des imprimantes Canon et leur faire gagner du temps pour faire autre chose.
Merci beaucoup.

kawa
Offline
Joined: 11/18/2012

Bonsoir,
J'ai installé Trisquel 5.5 (CD 700 MO), sans problème et ce sur HP (PC bureau), netbook HP pour l'utiliser avec vidéo-projecteur et mon portable Laptop Dell Latitude D 610. Tout marche bien. Les périphériques marchent correctement. Par contre, j'ai essayé une autre distribution également libre gNewSence, mai j'ai eu un problème avec la carte graphique, le bureau de cette distribution est très conviviale. Il me rappelle la jeunesse d'UBUNTU avant de passer à la Mère Debian sous Etch. Est-ce-qu'on peut règler au moins la carte graphique et autres périphériques en empruntant les outils utilisés par Trisquel pour avoir la possiblilité d'utiliser les deux distributions libres et merci.

kawa
Offline
Joined: 11/18/2012

Bonsoir
Dieu merci, à la place de gNewSense, j'ai également testé BLAG (live cd) et ce après avoir installé sur mon laptop la version Trisquel 4.0.1 LTS. Cette dernière m'a donné une grande satisfaction. La version actuelle Trisquel 5.5 STS bien qu'elle actuelle son gnome-classic est en deça de l'ancien gnome de Trisquel LTS malheureusement.
Et dans l'attente de la nouvelle version Trisquel LTS, je suis maintenant plus stable avec cette distribution LTS de type gnu-linux-libre.
Je souhaite à l'occasion du nouvel an 2013, mes meilleurs voeux, de santé et de prospérité et encore plus de liberté aux utilisateurs et développeurs de logiciels libres/Grand merci pour les développeurs de Trisquel.
Bon courage.

Mark
Offline
Joined: 04/14/2012

Bonsoir,

J'aimerais savoir pourquoi lorsque j'ouvre certaine applications depuis un Terminal, j'ai ce genre de message qui s'affiche dans le Terminal ?

En ouvrant Gedit depuis un Terminal :
** (gedit:2525): WARNING **: Could not load Gedit repository: Typelib file for namespace 'GtkSource', version '3.0' not found

En ouvrant GIMP depuis un Terminal :
(gimp:2578): GLib-WARNING **: /build/buildd/glib2.0-2.30.0/./glib/goption.c:2168: ignoring no-arg, optional-arg or filename flags (8) on option of type 0

En ouvrant LibreOffice depuis un Terminal :
javaldx: Could not find a Java Runtime Environment!
Please ensure that a JVM and the package libreoffice-java-common
is installed.
If it is already installed then try removing ~/.libreoffice/3/user/config/javasettings_Linux_*.xml
Warning: failed to read path from javaldx

Pourtant, j'utilise Trisquel 5.5 STS Brigantia 32 bits fraichement installé depuis moins d'une heure.

Je dois avouer que j'aimerais bien corriger ces erreurs et stabiliser mon OS pour le rendre plus fiable. ;)

Avez-vous des propositions ? Merci de vos réponses.

rodinux07
Offline
Joined: 12/11/2012

J'ai les mêmes message pour gedit et gimp, mais ils s'ouvrent sans problèmes malgré tout ? Pour libreoffice, je n'ai pas de message, il me semble que tu dois ajouter les packages de java, default-jre, java-common, libreoffice-java-common...
peut-être aussi les mises à jour ?
Sinon, j'ai galéré pour voir les vidéos sur internet, mais j'y arrive maintenant avec abrowser en ayant installé Greasmonkey et dans l'ajout de scripts utilisateurs, j'ai pris sur le site Linterna Magica et là j'arrive à lire toutes les vidéos aussi celle de dailymotion !

Mark
Offline
Joined: 04/14/2012

Je ne pense pas qu'il s'agit des mises à jour. Je les réalise toutes !!!

Je trouve tout ceci étrange !!

Oh, je vais essayer pour les vidéos, je n'arrive pas à toute les lires donc je vais essayer !!

rodinux07
Offline
Joined: 12/11/2012

Je ne comprends pas, j'arrivais à lire les vidéos de dailymotion avec greasemonkey et le script de linterna magiga, mais depuis que je suis passé à la version 6.0 de Trisquel et je n'y arrive plus, pourquoi ??

rodinux07
Offline
Joined: 12/11/2012

Bon, j'ai du abandonner Trisquel 6.0, j'ai eu quelques bugs et à la fin je démarrai dans le bureau de Trisquel sans la barre de tâches ! Je suis revenu à Trisquel 5.5,bien plus stable pour l'instant (peut-être étais-ce mon installation sans formater la partition home de l'ancienne version qui a causé des bugs ?).
A force d'installer, j'ai compris que l'idéal pour voir les vidéos, toutes les vidéos, même sur dailymotion, c'était d'installer le script Linterna Magica avec Greasemonkey et surtout de désactiver shockwareflash (Gnash) dans la gestion des modules de abrowser, sinon Linterna Magica s'active pas et il me semble que c'est le plugin de gnash qui le bloque.

kawa
Offline
Joined: 11/18/2012

Bonsoir
J'ai installé openerp-server & openerp-client sous trisquel LTS 4.0.1 mais la connexion de openerp-server a échoué, le serveur ne démarre pas. Comment faire pour me connecter au serveu local ? Merci pour votre aide.
La résolution doit être manuelle sous console.

Magic Banana

I am a member!

Online
Joined: 07/24/2010

Tu devrais commencer un nouveau fil sur ce forum ou, mieux, sur le forum anglophone. Ainsi, et avec un titre reflétant ton problème, il y a plus de chance que quelqu'un t'aide. Je suppose que tu as déjà jeté un coup d'œil aux journaux (logs). C'est une information que tu devrais nous donner.

Mark
Offline
Joined: 04/14/2012

Bonsoir à tous,

Une question bête mais comment fait-on pour remettre les boutons "diminuer, restaurer" sur une fenêtre de gnoe shell ?

Avec la version 5.5 de Trisquel je pouvais utiliser cette astuce mais avec la version 6.0 ça ne marche plus...

J'ai utiliser gconf-editor pour essayer de trouver quelque chose mais sans succès.

Merci d'avance.

Magic Banana

I am a member!

Online
Joined: 07/24/2010

Je suppose (je n'ai pas essayé) que tu peux retrouver les boutons... en délaisant les effets, c'est à dire en repassant à Metacity. Pour cela, dans les "Paramètres système", clique sur "Window manager and effects".

Mark
Offline
Joined: 04/14/2012

Bonsoir,

Est-il possible de faire en sorte que la liste des documents récents ne se remplisse jamais ? Je parle de la liste dans le menu de Trisquel : Raccourcis -> Documents récents.

Je suis constamment en train de la vider et parfois ça deviens lourd !! Donc, si quelqu'un peut m'éclairer se serait gentil.

Merci d'avance.