release upgrade to trisquel 7 error

6 replies [Last post]
oshanz
Offline
Joined: 02/12/2012

my current version is Trisquel 6.0.1 . i don’t like to format and re install. so i tried sudo do-release-upgrade.
and error is =>

An unresolvable problem occurred while calculating the upgrade.
This can be caused by:
* Upgrading to a pre-release version of Trisquel
* Running the current pre-release version of Trisquel
* Unofficial software packages not provided by Trisquel
If none of this applies, then please report this bug using the
command 'ubuntu-bug trisquel-release-upgrader-core' in a terminal.

yes i have many packages from PPAs. as a developer i need them. that’s the reason i don’t like to format.

1.

sudo ubuntu-bug trisquel-release-upgrader-core

*** Collecting problem information

The collected information can be sent to the developers to improve the
application. This might take a few minutes.

*** Error: Invalid problem report

Package trisquel-release-upgrader-core does not exist

Press any key to continue...

2.

grep Broken /var/log/dist-upgrade/apt.log

Broken libglib2.0-0:amd64 Breaks on libgnome-desktop-3-2 [ amd64 ] < 3.4.2-0ubuntu0.2 > ( libs ) (< 3.4.2-2)
Broken libqt5core5a:amd64 Breaks on libqt5core5 [ amd64 ] < 5.0.2+dfsg1-7ubuntu12~precise1~test4 -> 5.0.2+dfsg1-7ubuntu18 > ( libs ) (< 5.2.0+dfsg~)
Broken libgirepository-1.0-1:amd64 Breaks on libgjs0c [ amd64 ] < 1.32.0-1ubuntu1 > ( libs )
Broken cups-filters:amd64 Conflicts on foomatic-filters [ amd64 ] < 4.0.16-0ubuntu0.2+6.0trisquel1 -> 4.0.17-1ubuntu1+7.0trisquel1 > ( text )
Broken cups-filters:amd64 Conflicts on ghostscript-cups [ amd64 ] < 9.05~dfsg-0ubuntu4.2 > ( text )
Broken libjson-c2:amd64 Breaks on libjson-c2 [ i386 ] < none -> 0.11-3ubuntu1.2 > ( libs ) (!= 0.11-4+deb.sury.org~precise+1)
Broken libclutter-1.0-0:amd64 Breaks on libcogl9 [ amd64 ] < 1.10.0-0ubuntu2 > ( libs )
Broken libgoa-1.0-0b:amd64 Conflicts on libgoa-1.0-0 [ amd64 ] < 3.4.0-0ubuntu1.1 > ( libs )
Broken rpm-common:amd64 Breaks on librpm2 [ amd64 ] < 4.9.1.1-1ubuntu0.3 > ( libs )
Broken evolution-data-server:amd64 Breaks on libebook-1.2-12 [ amd64 ] < 3.2.3-0ubuntu7.2 > ( libs ) (< 3.4)
Broken im-config:amd64 Conflicts on im-switch [ amd64 ] < 1.20ubuntu5.2 -> 1.23ubuntu1 > ( universe/x11 )
Broken libmutter0c:amd64 Conflicts on libmutter0 [ amd64 ] < 3.4.1-0ubuntu1 > ( libs )
Broken poppler-data:amd64 Breaks on gs-cjk-resource [ amd64 ] < 1.20100103-3 > ( text ) (<= 1.20100103-3)
Broken libmono-wcf3.0a-cil:amd64 Conflicts on libmono-wcf3.0-cil [ amd64 ] < 2.10.8.1-1ubuntu2.2 > ( cli-mono ) (< 3.2.3)
Broken libmetacity-private0a:amd64 Breaks on libmetacity-private0 [ amd64 ] < 1:2.34.1-1ubuntu11 > ( libs )
Broken indicator-messages:amd64 Conflicts on libindicator-messages-status-provider1 [ amd64 ] < 0.6.0-0ubuntu2 > ( libs )
Broken ruby:amd64 Conflicts on ruby1.8 [ amd64 ] < 1.8.7.352-2ubuntu1.6 -> 1.8.7.358-10ubuntu1 > ( universe/interpreters )
Broken ruby:amd64 Conflicts on rubygems [ amd64 ] < 1.8.15-1ubuntu0.1 -> 1.8.24-1ubuntu2 > ( universe/interpreters )
Broken libgtksourceview-3.0-common:amd64 Conflicts on libgtksourceview-3.0-0 [ amd64 ] < 3.4.2-0ubuntu1 > ( libs )
Broken libsnmp30:amd64 Breaks on libsnmp15 [ amd64 ] < 5.4.3~dfsg-2.4ubuntu1.2 > ( libs )
Broken libjson0:i386 Depends on libjson-c2 [ i386 ] < none -> 0.11-3ubuntu1.2 > ( libs )
Broken libhdf5-serial-1.8.4:amd64 Conflicts on libhdf5-1.8 [ amd64 ] < none > ( none )
Broken osspd:amd64 Conflicts on oss-compat [ amd64 ] < 1 -> 6 > ( universe/sound )
Broken osspd:amd64 Conflicts on oss-compat [ i386 ] < none -> 6 > ( universe/sound )
Broken libpulse0:i386 Depends on libjson-c2 [ i386 ] < none -> 0.11-3ubuntu1.2 > ( libs ) (>= 0.10)
Broken gloobus-preview:amd64 Depends on libgtksourceview-3.0-0 [ amd64 ] < 3.4.2-0ubuntu1 > ( libs ) (>= 2.91.4)
Broken fonts-droid:amd64 Breaks on ttf-droid [ amd64 ] < 20101110+git-2 > ( oldlibs ) (< 1:4.2~r1-1~)
Broken libcheese3:amd64 Depends on cheese-common [ amd64 ] < 3.4.1-0ubuntu2.1 -> 3.10.2-0ubuntu2 > ( gnome ) (= 3.4.1-0ubuntu2.1)
Broken libqt5systeminfo5:amd64 Depends on libqt5core5 [ amd64 ] < 5.0.2+dfsg1-7ubuntu12~precise1~test4 -> 5.0.2+dfsg1-7ubuntu18 > ( libs ) (>= 5.0.2)
Broken libevdocument3-4:amd64 Breaks on libevince3-3 [ amd64 ] < 3.4.0-0ubuntu1.8 > ( libs )
Broken libgdal1h:amd64 Depends on libhdf5-7 [ amd64 ] < none -> 1.8.11-5ubuntu7 > ( universe/libs )
Broken postgresql-9.3-postgis-2.1:amd64 Depends on libgdal1h [ amd64 ] < none -> 1.10.1+dfsg-5ubuntu1 > ( universe/libs ) (>= 1.9.0)
Broken libperl5.14:amd64 Depends on perl-base [ amd64 ] < 5.14.2-6ubuntu2.4 -> 5.18.2-2ubuntu1 > ( perl ) (= 5.14.2-6ubuntu2.4)
Broken libqt5publishsubscribe5:amd64 Depends on libqt5core5 [ amd64 ] < 5.0.2+dfsg1-7ubuntu12~precise1~test4 -> 5.0.2+dfsg1-7ubuntu18 > ( libs ) (>= 5.0.2)
Broken libqt5serviceframework5:amd64 Depends on libqt5core5 [ amd64 ] < 5.0.2+dfsg1-7ubuntu12~precise1~test4 -> 5.0.2+dfsg1-7ubuntu18 > ( libs ) (>= 5.0.2)
Broken libgtksourceview-3.0-0:amd64 Depends on libgtksourceview-3.0-common [ amd64 ] < 3.4.2-0ubuntu1 -> 3.10.2-0ubuntu1 > ( libs ) (< 3.5)
Broken libnetcdfc7:amd64 Depends on libhdf5-7 [ amd64 ] < none -> 1.8.11-5ubuntu7 > ( universe/libs )
Broken libqscintilla2-l10n:amd64 Breaks on libqscintilla2-8 [ amd64 ] < 2.6.1-4 > ( libs )
Broken libgvc6:amd64 Conflicts on libgvc5 [ amd64 ] < 2.26.3-10ubuntu1.2 > ( libs )
Broken libmono-csharp4.0c-cil:amd64 Conflicts on libmono-csharp4.0-cil [ amd64 ] < 2.10.8.1-1ubuntu2.2 > ( cli-mono ) (< 3.2.1)
Broken libreoffice-sdbc-hsqldb:amd64 Depends on libhsqldb-java [ amd64 ] < 1.8.0.10-9ubuntu2 -> 2.2.9+dfsg-4ubuntu1 > ( universe/libs ) (< 1.8.1~)
Broken libasound2-plugins:i386 Depends on libpulse0 [ i386 ] < 1:1.1-0ubuntu15.4 -> 1:4.0-0ubuntu11.1 > ( libs ) (>= 1:0.99.1)
Broken python-evolution:amd64 Depends on libebook-1.2-12 [ amd64 ] < 3.2.3-0ubuntu7.2 > ( libs ) (>= 3.2.3)
Broken libcogl-pango0:amd64 Depends on libcogl9 [ amd64 ] < 1.10.0-0ubuntu2 > ( libs ) (>= 1.9.6)
Broken libcheese-gtk21:amd64 Depends on libcheese3 [ amd64 ] < 3.4.1-0ubuntu2.1 > ( libs ) (>= 3.3.5)
Broken libavfilter2:amd64 Depends on libavcodec53 [ amd64 ] < 4:0.8.16-0ubuntu0.12.04.1 -> 6:0.8.7-1ubuntu2 > ( universe/libs ) (< 4:0.8.16-99)
Broken libavfilter2:amd64 Depends on libavcodec-extra-53 [ amd64 ] < none > ( none ) (< 4:0.8.16.99)
Broken libavfilter2:amd64 Depends on libavformat53 [ amd64 ] < 4:0.8.16-0ubuntu0.12.04.1 -> 6:0.8.7-1ubuntu2 > ( universe/libs ) (< 4:0.8.16-99)
Broken libavfilter2:amd64 Depends on libavformat-extra-53 [ amd64 ] < none > ( none ) (< 4:0.8.16.99)
Broken libavfilter2:amd64 Depends on libavutil51 [ amd64 ] < 4:0.8.16-0ubuntu0.12.04.1 -> 6:0.8.7-1ubuntu2 > ( universe/libs ) (< 4:0.8.16-99)
Broken libavfilter2:amd64 Depends on libavutil-extra-51 [ amd64 ] < none > ( none ) (< 4:0.8.16.99)
Broken libavfilter2:amd64 Depends on libswscale2 [ amd64 ] < 4:0.8.16-0ubuntu0.12.04.1 -> 6:9.18-0ubuntu0.14.04.1 > ( universe/libs ) (< 4:0.8.16-99)
Broken libavfilter2:amd64 Depends on libswscale-extra-2 [ amd64 ] < none -> 6:9.18-0ubuntu0.14.04.1 > ( universe/libs ) (< 4:0.8.16.99)
Broken libgnokii6:amd64 Depends on gnokii-common [ amd64 ] < 0.6.30+dfsg-1build1 -> 0.6.31+dfsg-2ubuntu1 > ( universe/comm ) (= 0.6.30+dfsg-1build1)
Broken python3-aptdaemon.pkcompat:amd64 Breaks on libpackagekit-glib2-14 [ amd64 ] < 0.7.2-4ubuntu3 > ( libs )
Broken linphone-nox:amd64 Depends on linphone-common [ amd64 ] < 3.3.2-4.1ubuntu1 -> 3.6.1-2.1build2 > ( universe/sound ) (= 3.3.2-4.1ubuntu1)
Broken libedata-book-1.2-11:amd64 Depends on libebook-1.2-12 [ amd64 ] < 3.2.3-0ubuntu7.2 > ( libs ) (>= 3.2.3)
Broken gnome-session-fallback:amd64 Depends on gnome-session-bin [ amd64 ] < 3.2.1-0ubuntu8+6.0trisquel13 -> 3.9.90-0ubuntu12+7.0trisquel2 > ( gnome ) (< 3.3)
Broken gstreamer0.10-ffmpeg:amd64 Depends on libavcodec53 [ amd64 ] < 4:0.8.16-0ubuntu0.12.04.1 -> 6:0.8.7-1ubuntu2 > ( universe/libs ) (< 5:0)
Broken gstreamer0.10-ffmpeg:amd64 Depends on libavcodec-extra-53 [ amd64 ] < none > ( none ) (< 5:0)
Broken librpmbuild2:amd64 Depends on librpm2 [ amd64 ] < 4.9.1.1-1ubuntu0.3 > ( libs ) (>= 4.9.0)
Broken librpmsign0:amd64 Depends on librpm2 [ amd64 ] < 4.9.1.1-1ubuntu0.3 > ( libs ) (>= 4.9.0)
Broken unoconv:amd64 Depends on python3-uno [ amd64 ] < none -> 1:4.2.7-0ubuntu2 > ( python ) (>= 4.0)
Broken gir1.2-gjsdbus-1.0:amd64 Depends on libgjs0- [ amd64 ] < none > ( none )
Broken libedataserverui-3.0-1:amd64 Depends on libebook-1.2-12 [ amd64 ] < 3.2.3-0ubuntu7.2 > ( libs ) (>= 3.2.3)
Broken libbamf3-0:amd64 Depends on bamfdaemon [ amd64 ] < 0.2.126-0ubuntu1 -> 0.5.1+14.04.20140409-0ubuntu1 > ( libs ) (= 0.2.126-0ubuntu1)
Broken qtdeclarative5-qtaudioengine-plugin:amd64 Depends on libqt5core5 [ amd64 ] < 5.0.2+dfsg1-7ubuntu12~precise1~test4 -> 5.0.2+dfsg1-7ubuntu18 > ( libs ) (>= 5.0.2)
Broken qtsystems5-dev:amd64 Depends on libqt5serviceframework5 [ amd64 ] < 5.0~git20130718~precise1~test1 > ( universe/libs ) (= 5.0~git20130718~precise1~test1)
Broken icedtea-7-jre-cacao:amd64 Depends on openjdk-7-jre-headless [ amd64 ] < 7u75-2.5.4-1~precise1 -> 7u75-2.5.4-1~trusty1 > ( java ) (= 7u75-2.5.4-1~precise1)
Broken system-config-printer-gnome:amd64 Depends on packagekit-system-interface [ amd64 ] < none > ( none )
Broken gloobus-preview:amd64 Depends on libgtksourceview-3.0-0 [ amd64 ] < 3.4.2-0ubuntu1 > ( libs ) (>= 2.91.4)
Broken libgtksourceview-3.0-0:amd64 Depends on libgtksourceview-3.0-common [ amd64 ] < 3.4.2-0ubuntu1 -> 3.10.2-0ubuntu1 > ( libs ) (< 3.5)
Broken gloobus-preview:amd64 Depends on libgtksourceview-3.0-0 [ amd64 ] < 3.4.2-0ubuntu1 > ( libs ) (>= 2.91.4)
Broken libgtksourceview-3.0-0:amd64 Depends on libgtksourceview-3.0-common [ amd64 ] < 3.4.2-0ubuntu1 -> 3.10.2-0ubuntu1 > ( libs ) (< 3.5)
Broken gloobus-preview:amd64 Depends on libgtksourceview-3.0-0 [ amd64 ] < 3.4.2-0ubuntu1 > ( libs ) (>= 2.91.4)
Broken gloobus-sushi:amd64 Depends on gloobus-preview [ amd64 ] < 0.4.5-ubuntu11~ppa290-12.04 > ( utils )
Broken vim-tiny:amd64 Depends on vim-common [ amd64 ] < 2:7.4.648-1~ppa1~p > ( editors ) (= 2:7.4.052-1ubuntu3)
Broken trisquel-minimal:amd64 Depends on vim-tiny [ amd64 ] < none -> 2:7.4.052-1ubuntu3 > ( editors )

is there any solutions pls help.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Do you have any broken package in Trisquel 6? The Synaptic package manager can list them thanks to a "custom filter" (a button on the bottom-left corner of the window).

Please, show us your software sources:
$ cat sources.list sources.list.d/*

oshanz
Offline
Joined: 02/12/2012

no broken packages.

1.
cat sources.list
# Trisquel repositories for supported software and updates

deb http://es.archive.trisquel.info/trisquel/ toutatis main
deb http://es.archive.trisquel.info/trisquel/ toutatis-security main
deb http://es.archive.trisquel.info/trisquel/ toutatis-updates main
deb http://es.archive.trisquel.info/trisquel/ toutatis-backports main
# deb http://linux-libre.fsfla.org/pub/linux-libre/freesh/ freesh main

# deb http://ftp.heanet.ie/mirrors/mariadb/repo/10.0/ubuntu/ precise main
# deb http://apt.postgresql.org/pub/repos/apt/ precise-pgdg main

2.

cat sources.list.d/*

# deb http://ppa.launchpad.net/chris-lea/node.js/ubuntu/ precise main
# deb http://ppa.launchpad.net/chris-lea/node.js/ubuntu/ precise main
# deb http://ppa.launchpad.net/chris-lea/node.js/ubuntu/ precise main

# deb http://ppa.launchpad.net/cordova-ubuntu/ppa/ubuntu precise main
# deb http://ppa.launchpad.net/cordova-ubuntu/ppa/ubuntu precise main
# deb http://ppa.launchpad.net/cordova-ubuntu/ppa/ubuntu precise main
deb-src http://ppa.launchpad.net/elementary-os/daily/ubuntu precise main

# deb http://ppa.launchpad.net/georepublic/pgrouting/ubuntu precise main

# deb http://ppa.launchpad.net/gloobus-dev/gloobus-preview/ubuntu precise main
# deb http://ppa.launchpad.net/gloobus-dev/gloobus-preview/ubuntu precise main
# deb http://ppa.launchpad.net/gloobus-dev/gloobus-preview/ubuntu precise main
# deb http://ppa.launchpad.net/gnome-terminator/ppa/ubuntu precise main
# deb http://ppa.launchpad.net/gnome-terminator/ppa/ubuntu precise main
# deb http://ppa.launchpad.net/gnome-terminator/ppa/ubuntu precise main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
# deb http://dl.google.com/linux/chrome/deb/ stable main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
# deb http://dl.google.com/linux/chrome/deb/ stable main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
# deb http://dl.google.com/linux/chrome/deb/ stable main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
# deb http://dl.google.com/linux/earth/deb/ stable main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
# deb http://dl.google.com/linux/earth/deb/ stable main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
# deb http://dl.google.com/linux/talkplugin/deb/ stable main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
# deb http://dl.google.com/linux/talkplugin/deb/ stable main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
# deb http://dl.google.com/linux/talkplugin/deb/ stable main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
# deb http://dl.google.com/linux/webdesigner/deb/ stable main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
# deb http://dl.google.com/linux/webdesigner/deb/ stable main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
# deb http://dl.google.com/linux/webdesigner/deb/ stable main
# deb http://ppa.launchpad.net/klaus-vormweg/bluefish/ubuntu precise main
# deb http://ppa.launchpad.net/klaus-vormweg/bluefish/ubuntu precise main
# deb http://ppa.launchpad.net/klaus-vormweg/bluefish/ubuntu precise main
# deb http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu precise main

# deb http://ppa.launchpad.net/libreoffice/ppa/ubuntu precise main
# deb http://ppa.launchpad.net/libreoffice/ppa/ubuntu precise main
# deb http://ppa.launchpad.net/libreoffice/ppa/ubuntu precise main
deb http://ppa.launchpad.net/linux-libre/ppa/ubuntu precise main
deb-src http://ppa.launchpad.net/marlin-devs/marlin-daily/ubuntu precise main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
# deb http://dl.google.com/linux/mod-pagespeed/deb/ stable main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
# deb http://dl.google.com/linux/mod-pagespeed/deb/ stable main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
# deb http://dl.google.com/linux/mod-pagespeed/deb/ stable main
# deb http://downloads-distro.mongodb.org/repo/ubuntu-upstart dist 10gen
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out entries below, but any other modifications may be lost.
# Use command 'dpkg-reconfigure mysql-apt-config' as root for modifications.

### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out entries below, but any other modifications may be lost.
# Use command 'dpkg-reconfigure mysql-apt-config' as root for modifications.

### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out entries below, but any other modifications may be lost.
# Use command 'dpkg-reconfigure mysql-apt-config' as root for modifications.

# deb http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu precise main
# deb http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu precise main
# deb http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu precise main
# deb http://ppa.launchpad.net/ondrej/php5/ubuntu precise main
# deb http://download.opensuse.org/repositories/isv:/ownCloud:/community/xUbuntu_12.04/ /
deb http://ppa.launchpad.net/pcf/miro-releases/ubuntu precise main
# deb http://apt.postgresql.org/pub/repos/apt/ precise-pgdg main
# deb http://ppa.launchpad.net/pi-rho/dev/ubuntu precise main
# deb http://ppa.launchpad.net/pi-rho/dev/ubuntu precise main
# deb http://ppa.launchpad.net/pi-rho/dev/ubuntu precise main

# deb http://ppa.launchpad.net/rabbitvcs/ppa/ubuntu precise main

# deb http://ppa.launchpad.net/rabbitvcs/ppa/ubuntu precise main

deb http://ppa.launchpad.net/rabbitvcs/ppa/ubuntu precise main
# deb http://ppa.launchpad.net/rvm/smplayer/ubuntu precise main
# deb http://ppa.launchpad.net/rvm/smplayer/ubuntu precise main
# deb http://ppa.launchpad.net/rvm/smplayer/ubuntu precise main

deb http://ppa.launchpad.net/tualatrix/ppa/ubuntu precise main
# deb http://ppa.launchpad.net/tuxpoldo/phpmyadmin/ubuntu/ precise main

# deb http://ppa.launchpad.net/tuxpoldo/phpmyadmin/ubuntu/ precise main

# deb http://ppa.launchpad.net/tuxpoldo/phpmyadmin/ubuntu/ precise main

# deb http://ppa.launchpad.net/ubuntu-mozilla-daily/firefox-aurora/ubuntu precise main
# deb http://ppa.launchpad.net/ubuntu-mozilla-daily/firefox-aurora/ubuntu precise main
# deb http://ppa.launchpad.net/ubuntu-mozilla-daily/firefox-aurora/ubuntu precise main
deb http://ppa.launchpad.net/ubuntu-mozilla-daily/ppa/ubuntu precise main
# deb http://ppa.launchpad.net/ubuntu-mozilla-security/ppa/ubuntu precise main
# deb http://ppa.launchpad.net/ubuntu-mozilla-security/ppa/ubuntu precise main
# deb http://ppa.launchpad.net/ubuntu-mozilla-security/ppa/ubuntu precise main

# deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu precise main
deb http://ppa.launchpad.net/videolan/master-daily/ubuntu trusty main

# deb http://ppa.launchpad.net/wfg/0ad/ubuntu precise main

yeh may be there are lot of non free things. nothing to do.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

nothing to do.

Well, you have quite some cleaning to do! Notice that the lines starting with "#" are comments. Deleting them makes space and does not change APT's behavior in any way. I obviously invite you to disable the PPAs that propose proprietary software too.

Your problem probably comes from the package PPAs provide. It is easy to list those packages in Synaptic: use the "Origin" button. Try to remove them (or at least some of them).

oshanz
Offline
Joined: 02/12/2012

i comment them all to try upgrade. is deleting make any difference?

davidnotcoulthard (not verified)
davidnotcoulthard

It doesn't.

oshanz
Offline
Joined: 02/12/2012

finally fixed it.
if anyone interest, i removed many packages from => grep Broken /var/log/dist-upgrade/apt.log