T7→T8 Des paquets me manquent !

6 replies [Last post]
Ker Tris
Offline
Joined: 05/27/2016

Bonjour,
En passant de Belenos à Flidas, certains des paquets installés n'ont pas pu suivre la mise à niveau...
Il s'agit de :
- conky-all ;
- jitsi ;
- psensor.

Savez-vous si c'est temporaire ou définitif ? Pourquoi ? Que faire ?

Voici ce que j'obtiens en essayant de les ré-installer via Synaptic :

1/ conky-all

Échec de la sélection de tous les paquets à installer ou à mettre à jour
Les paquets suivants contiennent des dépendances non résolues.
Assurez-vous que tous les dépôts soient ajoutés et activés dans les préférences.

conky-all:
 Dépend : libaudclient2 mais ne doit pas être installé
 Dépend : libimlib2 mais ne doit pas être installé
 Dépend : libxmmsclient6 mais ne doit pas être installé
 Dépend: libxnvctrl0  but it is not installable

2/ jitsi

Échec de la sélection de tous les paquets à installer ou à mettre à jour
Les paquets suivants contiennent des dépendances non résolues.
Assurez-vous que tous les dépôts soient ajoutés et activés dans les préférences.

jitsi:

Le paquet jitsi n'est pas disponible bien qu'il soit listé dans la base de données.
Les explications possibles sont que le paquet est listé dans les dépendances sans jamais avoir été publié, qu'il est devenu obsolète ou qu'il n'est pas disponible sur les dépôts définis dans le fichier sources.list

3/ psensor

Échec de la sélection de tous les paquets à installer ou à mettre à jour
Les paquets suivants contiennent des dépendances non résolues.
Assurez-vous que tous les dépôts soient ajoutés et activés dans les préférences.

psensor:
 Dépend : psensor-common mais ne doit pas être installé
 Dépend: libxnvctrl0  but it is not installable
Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Jitsi n’est tout simplement pas dans le dépôt Trisquel. Il ne semble plus maintenu. En effet, https://jitsi.org décrit jitsi desktop ainsi :

Our legacy SIP and XMPP user agent (not compatible with Jitsi Meet)

Pour les autres paquets, il peut s’agir de bogues ou de véritables incompatibilités entre paquets qui ne peuvent pas être installés en même temps.

Ker Tris
Offline
Joined: 05/27/2016

Merci pour tes réponses, mais je pense que je ne suis pas sûr de bien les comprendre, alors je vais les commenter.


Jitsi n’est tout simplement pas dans le dépôt Trisquel.

Il était pourtant dans les dépôts de Trisquel 7, sais-tu s'il y a un endroit qui explique la raison de ce retrait ?


Il ne semble plus maintenu.

Pourtant sur GitHub, les dernières modification semblent remonter à seulement 2 mois.
(cf : capture jointe)


En effet, https://jitsi.org décrit jitsi desktop ainsi :
Our legacy SIP and XMPP user agent (not compatible with Jitsi Meet)

Oui, ça a toujours été le cas : Jitsi Desktop utilise SIP et XMPP alors que Jitsi Meet utilise WebRTC. L'absence d'interopérabilité est dommage, mais je peux m'en passer.


Pour les autres paquets, il peut s’agir de bogues ou de véritables incompatibilités entre paquets qui ne peuvent pas être installés en même temps.

Comment savoir, ou que me conseilles-tu de faire ? Si c'est des incompatibilités entre paquets, il serait intéressant de les identifier afin de déterminer lesquels me sont les plus utiles.

Jitsi GitHub.png
Magic Banana

I am a member!

Offline
Joined: 07/24/2010

C’est le mot « legacy » auquel je me réfère dans la description de Jitsi Desktop. Cela veut dire « antérieur » et suggère la fin de son développement. Peut-être que des problèmes sont néanmoins encore corrigés. J’utilise de mon côté Wire : http://wire.com (la section « download » propose des paquets .deb pour Ubuntu et donc Trisquel).

Pour les deux autres paquets, le problème est le même : la dépendance « libxnvctrl0 » n’est pas dans le dépôt. Une recherche sur le Web montre qu’il s’agit de logiciel de nVidia pour configurer son pilote privateur. Voilà certainement pourquoi le projet Trisquel a retiré ce paquet.

Ker Tris
Offline
Joined: 05/27/2016

Ah ok, pour moi, « legacy » se traduit en « héritage »... Du coup, dans le contexte, je me suis dit que ça signifiait « historique », mais je n'y voyais pas une suggestion de fin de développement ! Merci pour Wire, mais c'est dommage qu'il ne soit pas dans les dépôts alors qu'il est dans ceux de Debian apparemment.

Pour « libxnvctrl0 », bien vu merci ! Je me demande ce qui était utilisé à la place jusqu'à présent... Tu aurais aussi des conseils pour un logiciel graphique de surveillance des températures et un autre similaire à Conky ?

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

« Legacy » veut avant tout dire « héritage » mais je crois que « legacy software » se réfère à du logiciel qui n’est plus développé.

Est-ce que « conky-all » st vraiment nécessaire pour montrer les températures ? Il y a aussi « conky-std ».

Ker Tris
Offline
Joined: 05/27/2016

Ok pour « Legacy ».

Conky, je ne l'utilisais pas pour les températures, mais pour d'autres informations sur le système. Il faudra que je regarde si je peux ajouter les températures. « conky-std » s'installe correctement, merci ! En revanche, je dois refaire complètement mon « .conkyrc » car la syntaxe n'est plus la même, mon ancien fichier est incompatible...