Testing voice calling apps on Trisquel

5 replies [Last post]
Joined: 05/14/2015

In the last few days I finally managed to find some people to test some voice calls with 100% free code apps (organized through the fediverse, where I'm now @strypey(at)mastodon.nzoss.nz). Both these tests were conducted using my ancient netbook (Acer Aspire One), on which I've previously only been able to have any kind of voice chat using Mumble. Here's some quick notes on my experiences:

Wire: https://wire.com/
(My ID = strypey)
Server/client (not federated as yet), with clients for: web and all major platforms. GNU-Linux app uses Electron.
Tested on: Trisquel 7

Had a voice call on #Wire on Sept 10, using their GNU-Linux desktop app (still in beta), on an ancient netbook (Acer Aspire One) over a VPN. Really impressed with the performance! We could hear each other clearly, and it didn't jitter if we started talking at the same time. We were able to send images and links to each other while talking with no loss of voice quality. Top Marks Wire!

The Wire UI is very user-friendly. It is easy to search for and add contacts, send messages (asynchronous text messages are supported), and organize a time for a voice call, all within the app. Supports text messaging groups, conference calls, and video chat, but I haven't tested any of these yet. I would recommend this as a replacement for Skype / FaceTime / FB Messenger / Ello / Telegram, for use with friends and family who aren't very confident with bleeding edge tech.

Wire has E2E encryption by default, so no messages are stored unencrypted on the Wire server, although I'm not sure whether encrypted messages are stored at rest, or whether any metadata is collected on the server. The server code is 100% free (AGPL) so you can investigate if you want to know more on these points:

GNU Ring: http://ring.cx/
(My ID: strypey)
P2P, with clients for: all major platforms.
Tested on: Trisquel 8

Tested a voice call on #GNU #Ring for the first time on 11 Sept, using the GNU-Linux desktop app. Worked pretty well. Not quite as good as #Wire, mainly because with Ring there was 3 sec delay, and I couldn't get it to stop echoing my own voice back to me, even using headphones and an external mic. More tweaking required (at my end or theirs)? Quite impressive though considering no server is involved. Client #UX isn't quite a smooth as Wire yet, but it has a lot of potential.

I would recommend this as an app to use with other software freedom activists, and others who are motivated to learn how to use P2P / decentralized tech. With more active use, contributions, and quality feedback to the devs, I'm hopeful the UX could be improved to the point where I would recommend it for mainstream use.

Being a P2P app, no metadata is stored on any server, and I believe that E2E encryption is baked in, although I'm not sure if the security has been independently audited.

I'm keen to do more testing, particularly of conference calling with 3 or more people, and video chat. If anyone is keen to test with me, install the app, add me, and send me a message, or share your ID here.

hack and hack
Joined: 04/02/2015

Ah, so Ring isn't solid enough yet?
Is it easy to setup for someone with very little coputing skills ?

I can talk about Jitsi, though it's been a while I used it.
The setup is as far from easy/straightforward as it can be.
Once I figured out what xmpp was, I had to create accounts.
For some reason, they failed to work.
I eventually found more reliable xmpp providers, and yet, there's always a little something to fix before using it.
Even on non GNU/Linux OS.

The experience goes from perfect to unuseable, even with the same devices.

Still, I used it to connect on a remote computer to fix something there. And for conversations of course. Great experience when it works.

But the people you communicate with better be extremely patient.

Joined: 05/14/2015

hack and hack:
> "Ah, so Ring isn't solid enough yet?"

It's usable, but as I said, I wouldn't suggest trying to get newbies to use it yet. That said, I haven't tried it on any other platform yet.

> "Is it easy to setup for someone with very little coputing skills ?"

Depends. For Windows, MacOS, and iOS you just download and run the installer:

For Android you can install from Play store or F-Droid. Simple enough.

For GNU/Linux there are installation instructions for Ubuntu 16.04/ 18.04, Debian 9, or Fedora 27/28. All of them involve running terminal commands to add repos. I installed on Trisquel 7 using the 16.04 instructions, but I had to skip one of the steps that isn't required for Trisquel (the one to add 'universe', which Trisquel repos doesn't have).

> "The experience goes from perfect to unuseable, even with the same devices."

Funny, there was a guy on the fediverse dismissing Telegram, Signal, and Wire for being non-federated, and asking why everyone doesn't use XMPP. The client he recommended was Jitsi. Your experience is the answer to his question. For everything other than non-secure text chat, XMPP clients are notoriously unreliable, and often have appalling UX.

hack and hack
Joined: 04/02/2015

Nice, I want to try it !
Easy to install is a big advantage.
Hopefully the echo and delay is an isolated issue.

The only downside is remote desktop control (I'm thinking remote assistance here).
Maybe the updated Jitsi is more stable and easier to setup.
And I just found this : https://remmina.org/
But the setup is a bit complex to explain to someone on the phone: https://opensource.com/article/18/6/linux-remote-desktop
I think I'll try Jitsi again for remote assistance.

Joined: 05/14/2015

Neither GNU Ring nor Jitsi seem to be in the Trisquel 8 repos. Why is that?

EDIT: added Ring to the question

Magic Banana

I am a member!

I am a translator!

Joined: 07/24/2010

GNU Ring entered Ubuntu after Ubuntu 16.04 (on which Trisquel 8 is based). Jitsi exited Ubuntu before (Trisquel 7 has it; Trisquel 8 has not).