Trisquel 7 cannot detect the mic on my Libreboot Thinkpad X60.

7 replies [Last post]
northernarcher
Offline
Joined: 12/24/2014

Or any other mic for that matter. It's a fresh install of Trisquel 7. It can't detect the mic in the Thinkpad or the mic in my logitech webcam. Sound settings shows nothing on the input levels and sound recorder does not get anything. Can someone please help me? I don't know what to do.

onpon4
Offline
Joined: 05/30/2012

Older versions of GNOME had a "hardware" tab that allowed you to manually select what hardware to use. That was removed at some point between 3.4 and 3.10. I understand why they did it (because ideally GNOME should be able to figure out what to use automatically), but I do wish they'd left in an easy way to manually override this...

I suppose the way to do it now is to change something in the dconf Editor, but I don't know what.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

The "Input" tab of the "Sound" utility (in the "System settings") let you choose your input device and adjust its volume.

northernarcher
Offline
Joined: 12/24/2014

I've set the mic to full and I'm still not getting anything.

SuperTramp83

I am a translator!

Offline
Joined: 10/31/2014

"alsamixer" in terminal and see if the setting are right and there if you press f6 you can choose which mic to use.
hope that helps

northernarcher
Offline
Joined: 12/24/2014

I tried to turn everything related to input all the way up in alsamixer but it did not change anything.

northernarcher
Offline
Joined: 12/24/2014

[Update] I was told about this page which says that doing "amixer sset Capture cap" should fix it, but it did not. I still cannot get sound from the X60 mic or external mics.

http://gentoo-en.vfose.ru/wiki/Lenovo_Thinkpad_X60s#Sound

Platypus333
Offline
Joined: 12/10/2010

In alsamixer you can toggle mute/unmute of a channel with the 'm' key , have you tried that (shows "MM" for muted) ?

Do the mics work if you live boot with a previous version of the liveCD ?

Trisquel 6.0.1 LiveCD .iso image (692MB)
http://cdimage.trisquel.info/trisquel-images/trisquel_6.0.1_i686.iso

For clarification, did you install your current system from the 1.5Gb LiveDVD, the Trisquel mini LiveCD or the Trisquel netinstall image ?