Trisquel 7 forcepae intel pentium M

10 replies [Last post]
Sasaki
Offline
Joined: 08/11/2014

Salut,

j'ai récemment installé trisquel mini 7 par dessus une install de trisquel mini 6 qui ne voulait pas se mettre à jour car pas de support pae.
J'ai d'abord essayé d'installer les linux-headers pae, et un autre paquet dont je ne me souviens plus du nom et de booter dessus. Rien n'y a fait. J'ai donc téléchargé Trisquel mini 7 et mis sur une clé usb puis installé avec l'option forcepae.
Apparemment je n'avais pas à me préoccuper du warning qui vient avec, car j'ai un pentium M sur ce pc et utiliser cette option sur un pentium m ne pose pas de problèmes se lon ce que j'ai pu lire sur un tuto.

Pourtant le système est quasi inutilisable... Je ne peux pas lancer synaptic avec le pointeur, ni mettre mes options de localisation à jour en graphique, car je n'ai pas les privilèges root, et on ne veut pas me mettre de fenêtre de mdp.
Je ne peux pas non plus prendre de capture d'écran car un dossier n'existe pas.
Je ne peux pas naviguer correctement car une sorte de barre de censure recouvre le texte de ma barre d'adresse et plusieurs textes dans mes pages web...

J'espère vaguement qu'un super linuxien me donnera une commande à copier-coller dans mon terminal et que tout rentrera dans l'ordre.

Comme il n'y a pas trop de chances que ça arrive, j'ai un problème : trisquel-mini 6 ne se mettait plus à jour, j'avais juste mettre à jour vers trisquel 7. C'est pas censé être LTS ? Si je ne peux pas faire marcher trisquel 7 correctement sur mon processeur non-pae, il faut bien que j'y mette une autre distro qui aille bien, genre gnewsense, mais j'aimerais bien quand même avoir trisquel mini 6 qui se met à jour...

Sasaki
Offline
Joined: 08/11/2014

Une petite auto-réponse :

Une bonne partie des problèmes a été résolue en installant simplement policykit-1 gnome. Je peux désormais lancer mes applications sensibles en mode graphique, mettre à jour mes paramètres de localisation, faire une recherche dans ajouter/supprimer des applications, et faire mes mises à jour avec l'outil approprié.
Je peux aussi prendre des captures d'écran, il fallait installer scrot avec synaptic.
Ça va mieux quoi.
Mais pourquoi diable ces deux paquets manquaient-ils à mon installation ? Serait-ce un oubli des développeurs ?

Et j'ai toujours des carrés noirs sur mes textes mais seulement dans la barre d'adresse avec abrowser, alors qu'avec midori c'est partout. Je peux donc naviguer.
Je planche dessus...

Reste la question que je posais : pourquoi trisquel 6 ne voulait-il plus me proposer d'autres mises à jour que trisquel 7 ?

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Ce n'est pas d'un linux-headers PAE dont tu as besoin mais d'un linux-image PAE.

Sasaki
Offline
Joined: 08/11/2014

J'avais installé les deux je crois bien. En tout cas, sur la nouvelle installation avec de Trisquel mini 7 avec forcepae je viens de voir ils ne sont pas installés. Il faudrait que je les mette ?

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Tu as plus de 4 Go de RAM, n'est-ce pas ? Sinon, aucun problème ne se pose : tu n'as pas besoin d'une extension de l'adressage physique (ce que PAE signifie).

Je vois sur https://en.wikipedia.org/wiki/Physical_Address_Extension#History :

PAE is supported by Intel Pentium Pro and later Pentium-series processors except most 400 MHz-bus versions of the Pentium M.

Si tu as ce genre de Pentium M (les plus vieux je crois), alors tu as bien fait d'ajouter l'option "forcepae"... mais l'as-tu aussi ajoutée au noyau installé en démarrant le noyau du système Live avec une chaîne d'options se terminant par "-- forcepae" ? Je sors ce conseil de https://help.ubuntu.com/community/PAE

Même si tu l'as fait, il est possible que cela n'ait pas fonctionné (cela fonctionne seulement avec la version serveur d'Ubuntu ?!). Voilà alors quoi faire :

  1. Édite /etc/default/grub (ici avec GEdit) :
    $ gksu gedit /etc/default/grub
  2. Ajoute à la variable GRUB_CMDLINE_LINUX_DEFAULT l'option forcepae (par exemple "quiet splash" devient "quiet splash forcepae");
  3. Sauvegarde, quitte l'éditeur et exécute :
    $ sudo update-grub
Sasaki
Offline
Joined: 08/11/2014

Voici le contenu actuel de mon /etc/default/grub

GRUB_DEFAULT=0
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomdmonddf nomdmonisw"
GRUB_CMDLINE_LINUX="forcepae"

Est-il nécéssaire que je rajoute l'option forcepae à la ligne 4 vu que c'est sur la ligne d'après ?

Sur ce Dell latitude D500 le processeur est un Intel(R) Pentium(R) M processor 1300MHz. J'ai 1000 MiB de mémoire vive.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Est-il nécéssaire que je rajoute l'option forcepae à la ligne 4 vu que c'est sur la ligne d'après ?

Pas besoin, non. Comme l'explique https://www.gnu.org/software/grub/manual/grub.html#Simple-configuration GRUB_CMDLINE_LINUX sont les options pour toutes les entrées démarrant un noyau Linux, GRUB_CMDLINE_LINUX_DEFAULT seulement pour celles qui ne sont pas des entrées de rescousse (que tu obtiens avec GRUB_DISABLE_RECOVERY="true" dans /etc/default/grub).

Mais encore une fois : tu as plus de 4 Go de RAM et ne parviens pas à les adresser, n'est-ce pas ?

Sasaki
Offline
Joined: 08/11/2014

Non, je n'ai que 1Go de mémoire vive. C'est le maximum sur la fiche produit du Latitude D500.

http://www.dell.com/downloads/us/products/latit/d500_spec.pdf

Par contre je ne comprends pas leur processeur. Dans sysinfo j'ai 1300MHZ et la fiche produit dit 400MHZ :

"The Dell Latitude D500 features the latest Intel® Pentium® M processors, which utilize a new micro-
architecture incorporating a power-optimized 400MHz processor system bus and aggressive clock
gating designed for higher performance & lower power"

nmrk.n
Offline
Joined: 11/01/2013

Il y a la fréquence du processeur et la fréquence du bus ce qui n'est pas la même chose bien qu'elles soient liées.

"... 400MHz processor system bus ..."

La fréquence de ton processeur , elle, est de 1,4 Ghz.
(page 2, première ligne de http://www.dell.com/downloads/us/products/latit/d500_spec.pdf )

http://fr.wikipedia.org/wiki/Front_side_bus

:merci:

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Non, je n'ai que 1Go de mémoire vive.

Tu n'as donc pas besoin de PAE !

Sasaki
Offline
Joined: 08/11/2014

Beh si je mets pas l'option forcepae, le live-usb refuse de booter en disant clairement qu'il faut le pae et trisquel 6 refuse de se mettre à jour en disant clairement qu'il faudrait activer le pae (si possible) pour que ça fonctionne.